Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

Can not login twitch

After updating AMD Adrenalin, I can not log in to twitch anymore. But the twitch web or mobile app has no login issue, even if I change the password still does not work.

37 Replies

I have the same problem after a driver rollback. I had updated drivers up to version 22.9.1 but recording gameplays became unstable, the games crashed as soon as I tried to start recording. Then I decided to go back to version 22.6.1 (the recommended version at the time of writing), and did a factory reset install (that's the only way to rollback drivers through the installer). Twitch login simply doesn't work in any way, shape or form in Adrenalin since then. What is going on?

Adept I


Same here...

Adept I

I reinstall my OS, and I still can't login to twitch in AMD adrenalin. I guess maybe twitch blocked the session from adrenalin or something idk.

Journeyman III

Is there any news on this? I installed the drivers recently. First I had a version from march, then 22.9.1, and now 22.10.1 but I still can't log into twitch.

Nothing. Nobody seems to have a clue, sadly.

Hopefully an answer will arise at some point, if we keep the discussion alive long enough.


I think I might have found some sort of lead to the actual problem. After spamming Enter, trying to force a login, the error message changed from "Something went wrong" to this, which roughly translates to "There's currently no support for your browser. Try to login with another browser or click here to know more."

I guess I will try contacting Twitch over this and see what they have to say.

I use 3 browsers 

OPERA: 90%

TOR : perhaps 7%

EDGE : anytime the others are not supported.

Twitch may attempt to use your default, which in my case it is OPERA.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
Journeyman III

This is still an issue. Commenting for visibility.

Any updates?

Community Manager

Thanks for the posts. This is an issue we are aware of and are investigating. 

I have been going crazy trying to get in to twitch not once did the support team say if you run AMD we are sorry you can't play with us any more. 




Am i doing something wrong>?

Adept I

@soulmet @Matt_AMD 

It could be that the error message is wrong.

You cannot stream anymore without activating 2 factor authentication on twitch.


Can you test it @soulmet ?


Preventing Account Takeover (

"[...]Enabling 2FA is not required to watch streams on Twitch, but it is required to start streaming, and is recommended for all community members. [...]"



You can read how to do it here:

Setting up Two-Factor Authentication (2FA) (

or there

How to Enable Two-Factor Authentication (2FA) for Twitch | Streamlabs


I enabled 2FA but it doesn't work

I could steam without 2FA in adrenaline before, but after the update, it no longer works


I thought it was just me, but it appears that we're not the only ones with the issue.  I thought it might be due to running a VPN, so now I'm curious if any of those having this issue are also running a VPN.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I'm not using VPN.

Adept I

Is it just me as I am still having issues


No problems for me.
Logged in on 22.11.1 even with double authentification.

Maybe you should check what engine is used for in-app webview?
Windows 11 uses Edge WebView for in-application web surfing from what i know.



Thanks for the heads up using windows 10 both Edge and Chrome AMD version I'll check for an update and see if I can get a fix.


No still doesn't allow access to Twitch I have changed passwords many times I have edited AVG to allow Twitch I have updated Chrome many times. I can log in if I'm not using this machine and the other machine does not use an AMD chip.


Ran a load of updates last night and something went right I can now get back in to twitch

hey, the issue you were having, is what im currently facing.... i can log in from anywhere else but when i try through adrenalin, i keep receiving the "browser not supported" notification. what did you do to fix the issue?


G'day my issue ended up being an issue with Duck Duck Go and Twitch I had some great help from the Twitch support team took about 30 minutes to get fixed


Duckduckgo? I thought the adrenalin uses chromium? I contacted twitch support they told me to disable extensions, some stuff on vpn and anti virus, if those things werent working than i was practically on my own


Duck Duck Go is the search engine I use. Which anti Virus are you using?


I've just been on live chat with twitch and they just told me to contact AMD because it's their software

Adept I

Has anyone managed to find a fix for this?. I'm having the same issue on 24.1.1

Adept I

Managed to figure out a work around

Enable browser in Adrenaline then go to Record & Stream - settings - Twitch


It will open a tab up - copy the url and paste it in to your normal browser and log in - after you've logged in copy the url and paste it in to the Adrenaline browser and it should link your twitch account

This works right here but only if you do it exactly how he explained it it will be an extremely long url and you can only use your  keyboard for copy and past 

You’re a livesaver thanks man

Your method was key part of the solution, me banging my head to the wall ... but I got success only after clearing browser cache and cookies (using Chrome)... 

This worked

thank you for finding this solution 

you da goat fr

Thank you very much, this worked perfectly.

can confirm that this works 22.03.2024


what a Godsend. Crazy after nearly a year and a half amd hasn't fixed this

Thanks for the tutorial, it works for me too. I don't understand why the developers weren't able to get it working in such a long time. Some streamers use Prism Live, for example, but why would I do that when I have software for my graphics card.