cancel
Showing results for 
Search instead for 
Did you mean: 

Gaming Discussions

Mooncatt
Adept I

FPS locked when no lock set, MSFS

I recently upgraded from a MSI 6600xt to an XFX 7800xt. I re-tuned my settings in Microsoft flight sim to take advantage of it while also keeping 50+ fps in most situations, but do not have any frame rate locks set other than Radeon Chill capped at 59fps to prevent a persistent screen tear (another new problem problem in itself) and Freesync active with a Freesync compatible monitor.

 

In some situations the frame rate will dip into the low 30's in the sim. On the old card, it would come right back up when the load was removed. On this new one, it'll often lock itself at 30 fps and will not go back up when I lower the graphical demand (i.e. looking up at a clear sky). When this happens, I have to tab out and back into the sim to get full frame rates back.

 

I sent a bug report, but asking here just in case this is some sort of user error. I have tried numerous combinations of frame sync and caps, and none at all. I've also ran DDU and started completely from scratch. I haven't tried an older driver, but I'm thinking about it. 

12 Replies
rtbh99
Challenger

i think this might just be a quirk of radeon chill. i have to use it in fallout 76 because my 7900xt runs the game at such a high frame rate indoors that the physics engine breaks and i cant move my character. why are you using radeon chill for msfs anyway, i would think higher, smoother fps would be more desirable?

---
lets talk about rtbh99

I'll double check, but pretty sure this was happening without chill activated. The reason I'm using chill is because of a persistent screen tear if I run at my monitor's max 60fps. It's like running vsync but the sync is out of phase with the monitor. If frame rates stay in the 45-59fps range, Freesync keeps tearing in check. This is another problem I only have with this card and didn't have with the 6600xt.

I'll double check, but pretty sure this was happening without chill activated. The reason I'm using chill is because of a persistent screen tear if I run at my monitor's max 60fps. It's like running vsync but the sync is out of phase with the monitor. If frame rates stay in the 45-59fps range, Freesync keeps tearing in check. This is another problem I only have with this card and didn't have with the 6600xt.

0 Likes
432hz
Adept III

You may want to try the Frame Rate Target Control in the Adrenalin > Gaming > Graphics > Global Gaming Experience settings section instead of Radeon Chill and see if there's any improvement.

 

I had some issues with the 24.x.x drivers in combination with Resizable BAR including a lot of screen tearing. I disabled ReBAR in BIOS and clean installed 23.12.1 and have had good stability since.

 

I also disabled MPO and have seen overall improvement: https://www.youtube.com/watch?v=fw_xv1Id6UM

 

Screenshot (30).png

RX 6800 • Intel 12600k • G.Skill 6000 32GB • MSI B760M Mortar

Just to check back in that this is still happening. I've tried the suggestions here (except changing MPO since that seems to address a different issue), but no permanent improvement. I know I'm not CPU bottlenecked as indicated by the sim. I.e. CPU frame time is 16-18 ms, and GPU frame time would be around 25 ms, and a further artificial total render time locked at 33.33 ms (30fps) even in low demanding areas like at cruise altitude. Temps are kept under 70° on the hot spot with aggressive fan curves. When acting up, the GPU wattage is only around 120W, but will pull much more as would be expected when operating at full load.

 

And it's only this game that it seems to be doing this. Running Heaven Benchmark and the GPU benchmark in Cinebench 24, it will run all out for extended periods of time. My other games don't really load it up, though. And if anything, the problem is now worse, being almost constant now.

BigAl01
Volunteer Moderator

I'm wondering why you don't upgrade to a display port monitor capable of at least 120 Hz.  Running at 60 fps with your current monitor on an RX 7900 XT is like tying one arm behind your back while gaming.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
0 Likes

I am running through a display port and it's a 4k monitor. The sim is also extremely demanding on the GPU, and my settings are nowhere near maxed out, running almost fully loaded when at 60fps.

 

As for getting another monitor:

They are currently prohibitively expensive to get a 27" 4k144 IPS replacement (zero desire for OLED and burn in).

 

I don't play any games where  I would care for such high frame rates.

 

Besides, how do you expect that to help with the problem at hand?

 

Also, it's a 7800XT, not a 7900XT.

 

BigAl01
Volunteer Moderator

Ok, my mistake on the GPU.  Are you using a DP 1.4 cable (or one rated higher)?  Maybe giving the HDMI port a try with a quality cable might result in different behavior with the frame lock problem.  Also, there is a new version of the Adrenalin drivers out (24.5.1) that might address the problem. 

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
0 Likes

This is the exact monitor, which has DP 1.4 and using the OEM cable that was able to run fine on the 6600XT i replaced (albeit on lower settings to keep frame rates up).

 

https://www.lg.com/hk_en/monitors/uhd-4k-5k/27ul600/

 

I did try HDMI at some point in the past, but there was an issue with it and DP worked noticably better. Unfortunately it's been so long that I don't remember the problem,  but i think it was related to using HDR. I haven't tried it on this GPU, though.

 

I am also on the most current drivers.

FunkZ
Forerunner

If your monitor is only capable of 60Hz refresh then have you tried simply enabling vSync in the game settings to set the max at 60 FPS?

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

V-sync is  partly broken in the game, and would only exacerbate the problem by keeping me a 30 even if I could hit in the 50's with Freesync.

Balrogos
Adept II

But what minimum FPS u set on radeon chill? set it close to 59, also radeon chill is meant more for laptops users on battery, Try normal limiting fps via adrenalin, or RTSS