Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

XR382CQK and flicker with freesync, Windmill won't work PERIOD, screen tearing, oh my heck

How do you tell if Freesync is working????

Asus Crosshair VI with May 2018 bios

1700 at default settings

32GB  2666MHz

Vega 64 - I've tried drivers 18.7.1, 18.5.1 and 17.12.2.

Acer XR382CQK

Windows 10 pro 64bit

First, World of Tanks and World of Warships seemed to be stuttering and screen brightness flickered, and I could have sworn there was screen tearing so I decided to investigate further. I installed DOOM, and even though it seems smooth, I could see screen tearing with ANY setting (couldn't notice screen brightness flickering). I downloaded older drivers, even back to 17.12.2 as I saw a thread regarding what solved flickering for someone.  17.12.2 seems to have helped solve flickering in World of Tanks and World of Warships. But i still see screen tearing.   So, I installed Skyrim and Wolfenstein.   Skyrim is hard to tell of any screen tearing, but seemed to be BUTTER-SMOOTH only ONE TIME. Now some stutters!?!?!?!   Wolfenstein is nauseating while playing due to the screen tearing.  Is it just the games that don't work with Freesync?

However, AMD's Windmill is insanely choppy. I have tried AMD driver VSYNC, ehanced sync, Freesync on/off, frame limiter, etc.   NOTHING will make this demo work.  I even switched out monitors and tried the 34" version of the Acer (XR341CK) but still no go.

I could have SWORN I saw this Windmill Demo work for 10-15 second once, but restarting the demo, still won't seem smooth.  I've done DDU, and didn't help. I did a full REFRESH, didn't help.  FORMATTED and reinstalled Windows 10, still no help.

Things I've tried

-Windows 10 full reinstall

-Different driver versions

-FRTC changes

-CHILL on/off

-Freesync (driver) on/off

-Disabled Windows 10 xbox game recording stuff

-Double check 75Hz refresh

-Installed Acer's monitor drivers

-Disabled CHROME'S hardware acceleration

Thing's I've yet to try:

-bought a new DisplayPort cable (8Kx60Hz display port 1.4 certified)

-disabling AMD services one-by-one

-uninstalling STEAM

-disabling any service one-by-one.

I'm an avid fan of AMD, but this is starting to drive me crazy.  Is Freesync working? I can't tell with any game yet.  Whats most frustrating is I SWORE I could see the Windmill demo work and was awesomely smooth, and Skyrim was smooth as butter....BUT ONLY ONCE!

Do I need to try a whole different computer platform (intel?) ? Go to Windows 7?  Shake a magic stick?  Seems gaming on a samsung 22" 60Hz IP with a nvidia GTX 960 was a lot more smooth than a Vega 64 on a freesync high-end 38" 75Hz monitor.  I feel like i'm going crazy........

4 Replies

Windmill is outdated, doesn't work with newer drivers, so feel free to ignore it. That's normal. Some things you need to try:

1) Disable fullscreen optimizations (in game exe's properties). This enables exclusive fullscreen mode - pick it in the game's settings if available.

2) Monitor framerate - if you're going over 75, your monitor's refresh rate, Freesync won't be working. If you're dipping below the Freesync minimum - 48on your monitor - it will stop working too.

3) Enable in-game Vsync. This way you won't see tearing when you leave the Freesync range.

Some amount of filckering on loading screens is normal. Use new drivers - the old ones aren't better for most (all?) people.


Windmill being outdated is a big sigh of relief.   Do you know if it does work with release drivers of the Vega 64? After I installed RTSS (see below!) the Windmill demo is definitely broken.  The onscreen FPS is NOT what is being actually shown on screen. On screen its 34-38 FPS (outside of 48fps Freesync range on my monitor), but shows a massive range of different FPS on the demo's built-in FPS counter. No wonder it looks choppy!  Its only 34-38 FPS, and I really don't think V-SYNC works with it at all.

-I'll try that on a few select ones.    I've tried it with Doom and didn't seem to make a difference with the tearing.  However, RTSS I think is the solution for right now. See below.

-Last night I locked my monitor with Riva's utility RTSS (Rivatuner Statistics Server) at 75Hz.  I need to do more testing, but I *THINK* that might solve a lot of issues.  Radeon utilities CHILL and the FRTC didn't seem to make any difference.  Doom would go well above 75Hz with those in place half the time.

-I installed the newest drivers, 18.7.1 again, before I installed Riva's RTSS software to lock it in at 75Hz.   Now games max out at 75Hz! (Radeon driver utility does not work half the time).  

I'll go back and retest everything with the RTSS installed.   That might be the current trick to get things smooth.

Thanks for the reply!!!


Don't think about Windmill at all. I tried it on 17.2.1 drivers and it didn't work properly even then. AMD no longer provides the download, as far as I know.

RTSS is an option, but in my experience FRTC works better with Freesync - probably because it's closer to the Freesync engine. It's more of a concern for LFC though, which your monitor doesn't support.

FRTC just doesn't work in select games and in games with Vsync on. And the thing is, I don't actually need to limit framerate to refresh rate. In-game Vsync is enough for me. (18.6.1, R9 380)

Journeyman III

So update two years later.  I had a chance to temporarily swap out my Vega64 to a friend's GTX 1080 and use freesync. Sure, freesync causes this monitor to blackout sometimes, but shesh.......

THE NVIDIA CARD WORKS BETTER AND HAS NO MICROSTUTTER IN ANY GAMES COMPARED TO THE VEGA64.    And that was just a simple swap and install drivers, not wiping ANYTHING.

What on EARTH is going on AMD?    

Vega64 + XR382CQK  = SUCKS

GTX 1080 + XR382CQK  = AWESOME

I turned freesync off and on, tried multiple drivers, tried different high quality DisplayPort cables, formatted my system and reinstalled windows, updated, changed, downgraded motherboard BIOS, swapped PCIe ports, disabled everything misc thing on the motherboard, etc etc etc.

I want to support AMD...i really do, but after this. SHESH.  This has been the biggest headache since....since...having to figure out how to get 632K free in DOS to run some DOS games!

I swear, if Navi does this crap when its released, I'm going back to the evil green empire.