Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

x16 anisotropic filtering setting in AMD Software not working at all

As in the topic title - The x16 anisotropic filtering setting in AMD Software does not work at all on my system. I noticed that this has not been working for several versions of the driver.


My GPU: RX 570 4 GB model

Driver version: 24.3.1 latest for my gpu

OS: Windows 10 LTSC 1809


Here is a few steps to reproduce my problem using the example of Grand Theft Auto V where usually the anisotropic filtering setting from AMD Software worked perfectly.



- Run the game and go to graphics settings

- Set shader detail to "medium" and anisotropic filtering to "off" (This is for making sure that anisotropic filtering was not enabled from the game engine)

- Save settings and restart the game

- Turn off the game

- Go to AMD Settings and set anisotropic filtering to "on" and set it to "x16"

- Once again run the game and load story mode


You should see some ugly blurry textures (Particularly visible on road textures) Proof that the x16 anisotropic filtering setting from AMD Software doesn't work at all aaand now the twist... The x16 setting is the ONLY ONE that doesn't work and to check this just repeat all the above steps but instead of x16 set anisotropic filtering to x8 in AMD Software. This time the textures in the game should be much sharper and clearer. This is the proof that the x8 setting is working properly and by the way all this also proves that AMD tooltip saying that this setting only works in DX9 games is false!


I know Polaris GPUs no longer have driver support for new features buuut... I would really like to at least ask you AMD to fix the x16 filtering setting in some of the next version of the driver. IMO this is one of the most important settings affecting the look of games.

1 Reply
Adept I

I started checking all previous versions of the driver one by one to check on which version the problem with x16 anisotropic filtering started and ofc I did a clean install using DDU each time.


The last version on which the x16 setting worked as it should was version 23.5.2


The problem starts with version 23.7.1 and since this version every subsequent driver relase including current 24.3.1 has some problem with x16 anisotropic filtering setting and it doesn't work properly or doesn't work at all like on current version.