cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

F1FTY0NE
Adept I

Windows cannot find 'C:\AMD\AMD_Software_Installer_22.10.3\Setup.exe'. Type correctly, try again.

To start off with the error that pops up is...

"Windows cannot find 'C:\AMD\AMD_Software_Installer_22.10.3\Setup.exe'. Make sure you typed the name correctly, and then try again."

OMEN by HP Obelisk Desktop 
Windows 10 Pro
AMD Ryzen 7 3700X 8-Core Processor 3.59 GHz
AMD Radeon RX 5700XT
RAM 16 GB

So the other day I went to use AMD software: Adrenaline Edition to install the new graphics drivers for the RX 5700XT.  I downloaded them and I went to INSTALL the drivers. However, after clicking on the install button the error message listed above popped up. I tried looking for this issue on the forums or elsewhere but was only able to find issues that were SIMILAR. For example Windows not being able to find radeonsettings or was concerning a Ryzen CPU or something.  Most of the posts I saw had solutions like going into the registry ("Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options" ) and deleting radeonsettings, but I honestly don't see anything listed in the "Image File Execution Options" folder that has anything to do with AMD. So there is honestly nothing TO delete there. Also, I know messing with the registry isn't exactly advised all that much. 

I tried reinstalling the AMD software: Adrenaline Edition update tool, but it didn't work. The same error popped up again.Here is the error that pops up.Here is the error that pops up.

Also on a bit of a side note...
I have NEVER played Alien Isolation before in my life. It's is not even installed on this PC, nor has it EVER been installed. I've played AC Valhalla, AOE, CP2077, and C&C recently so that's normal, but I'm also freaked out why some 800 hours of Alien Isolation would be in the history.

9 Replies
charliegall
Journeyman III

have you found a fix yet?

it seems to be an issue with the download because if you go to the folder in the error message (AMD\AMD_Software_Installer_22.10.3) it is empty 

0 Likes

No not yet, but I will give the possible fix the other commenter had in a bit and report back.

0 Likes
JustAPig56
Journeyman III

Hey man, i unistalled my drivers completely incuding the adrenaline edition and reinstalled from there website and it worked for me. You might have to restart a bit or try a few times but i dont think this is on us.

0 Likes
F1FTY0NE
Adept I

Yeah I will try that in a bit, when I have time and let you know.

0 Likes

I have the same problem...

0 Likes
Vynski
Exemplar

That is one bizarre error with the 800 hrs. history of something that has never been installed.

It looks like it is receiving data from a previous driver installation, but from where is the question.  I've read a bit about the AMD DDU uninstall app, but I've been using BC Uninstaller for several years now and I feel that it does a much better job.  I'm not knocking DDU but I dislike having to go into "safe mode" to uninstall drivers.  I would recommend you try BCU (use it in default mode) and uninstall your drivers then delete any directory where they were installed prior to reinstalling them.  Make sure you shut down then restart prior to reinstalling, that's just an old time process that I have used for many years.  I also prefer a cold system restart as opposed to a warm system restart when cleaning up old drivers etc.

Now where it got the Alien Isolation from, I haven't a clue, I guess aliens.


Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
MikeBoa
Journeyman III

Hey, I'm not getting an error, but I just went to check my driver for updates and found 548 hours of Alien Isolation logged on my GPU somehow!Screenshot_20230102_065834.png

kulcix
Journeyman III

found a fix
go into C:\AMD\AMD_Software_Installer_23.8.1\Bin64 and run AMDSoftwareInstaller.exe

w1nd0wz
Journeyman III

Thank you

0 Likes