Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Windows 10 DirectX9 Anti-aliasing FIX (mostly) for most DX9 and some earlier DirectX games


For everyone that is struggling to get the in-driver anti-aliasing to work, I will explain below steps that has helped me in a lot of cases, even in Unreal Engine 3 DirectX 9 games.

The problem seems to be related to the fact that Microsoft forces Fullscreen Windowed to some extent for all applications, and lets "Fullscreen Exclusive" applications "think" that they are running in Exclusive mode and this causes in-driver Anti-Aliasing to have no effect in-game:

- To work around this problem you have to disable fullscreen optimizations for the related game,

- Firstly, locate the games' main .exe file,

- Right Click on it and select "Properties",

- Select the "Compatibility" tab,

- Tick the "Disable Fullscreen Optimizations" tab,

- Hit "apply" and then "ok",

- If you have not enabled the AA options in the driver yet, you can do so now,

- Remember to choose "Override in-game settings" with the in-driver application mode and then select your level; I usually choose "x4 + eq" or "x2 + eq" and then "Adaptive Multisampling", but plain Multisampling should be the safest. EDIT: Furthermore, using higher settings that x2 with "SuperSampling" becomes a CPU bottlneck; believe it or not; or it does not use all the Compute Units/Engines on the Radeon GPUs. Might be an old unoptimized algorithm similar to the UHD used in the Witcher 2.

From my testing this is sometimes the same case for Nvidia GPUs as well, and keep in mind that it is mainly meant for DirectX9 games, but sometimes works for earlier DirectX games such as Dungeon Siege 1. Furthermore, the Morpholigical Anti-Aliasing option is only for DirectX11 games (seems to actually only work for DX9 games) and introduces blurry text in-game.

Hope this helps some people, at does for me at least.

Kind regards

3 Replies
Journeyman III


regarding Supersampling AA and that CPU bottleneck, I have used this mode in Crysis Wars with my old Radeon 290 and RX 590 later on. At least with the Crytec Engine I cannot confirm any unspecific performance penalty on the CPU side.

Running it on an FX-9590 for a long time I can confirm the engine itself is clearly CPU-limited. Tweaking around to max out quality at a playable framerate was always hard work. AFTER reaching that point, I could add 2x or 4x SSAA without any performance loss. 8x was nonticably slower, although still playable, but kind of an overkill anyway.

Just wanted to let you know my experience with this excellent AA method that pretties up these old games a lot. Sadly its DirectX 10 support suddenly has been axed from the driver...

Hi @WilleHelm ,

Awesome to hear you are running a FX 9590 and I really wanted to buy one 2nd hand a few months ago but did not receive any reply from the seller for more than a year, so I made a hard decision and bought a Ryzen 5 5600 and it is crazy what difference that extra L3 cache makes in "CPU limited" scenarios; what I mean by the quotes is an underutilized CPU.

May I ask, are you referring to in-game anti-aliasing settings or Radeon driver anti-aliasing settings? It would creep up if you test it with a game that is not completely CPU limited to start of with, I am referring to the SuperSampling setting in the Radeon Software application.

I am glad if I helped you to improve some anti-aliasing in your older games. I understand that Crysis is DirectX10 and have not tested if my method works for Crysis, but I might have a look to see if I can get it working for Crysis. One thing you can try for Crysis is to use Radeon Virtual Super Resolution and then set the game to 2560x1440, this method also helps to alleviate the refresh rate issue that sometimes creeps up in the Crysis trilogy, but it is a considerable GPU performance hit.

DirectX10 is an in-between, between DirectX9 and DirectX11 so there is a slight change that my original tip in this post might work for it, but I think the VSR solution is more solid when considering the refresh rate bug and the fact that you have an awesome RX 590.

Journeyman III

Well, I nearly have overlooked the actual topic and solution you have given me! I was actually mislead for days because of the clear note that the driver option affects DirectX 9 only, and last time I had Windows 7. o.O

I say THANKS for saving my day, and the next LAN party with eye candy again!