Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Weird Monitor resolution with RX 5700 XT

I just bought a complete AMD configuration for desktop, built it, run it, and everything went fine, until i tried to go for my double monitor.

As stated in the title, I have a RX 5700 XT (Sapphire), which has 4 video port : DP, HDMI, DP, DP.

I installed the driver related to my graphic card, plugged my first screen into the HDMI port, and it went fine (except half of the screen that gets blue from time to time, until I switch focus between windows).

Today, i just went to the store, bought 2 DP cables, tried to plug my 2 monitors. The monitors are 2 exact same ones. 2K - 144Hz, which is the resolution and refresh rate I was expecting, as it was working fine on my previous computer.

When I turn my computer on, with the 2 monitors, one is completely fine, and the other is maxed at 1600*1200, windows does not even detect a higher resolution for it. At this point, working monitor is plugged in slot 1, buggy is plugged in slot 3. I wanted to check the ports / cables, so I switched the cable from slot 1 to slot 4 (and only this one) and I rebooted. After the reboot, the screen that's plugged in port 3, is perfectly fine (was not just before) and the one that is now plugged in port 4 has got the same bug as before, although that one was working fine minutes ago.

I could then conclude that it does not come from the screens, neither from the cables or the slot, but it seems that the graphic cards does it on the "last" plugged screen (from order 1 to 4). I checked online for solution, and the first thing I saw was the idea of re-installing the driver, which I did. During the re-installation of the AMD Radeon Software the bug fixed itself, so I was pretty happy, and tried rebooting => problem happened again.

The problem now occurs everytime I boot and i'm forced to reinstall the AMD Radeon Software each time to fix the problem.

Please give me any advice about this, it's my first time with AMD hardware, i'm both excited to discover, and afraid to see so many problems coming in (I had quite a few that I could figure out by myself before).

Cheers !

15 Replies
Adept I

Is your Windows completely up to date?  Check manually.  Also are you AMD Chipset drivers up to date as well as the AMD Graphics Drive up to date?  Get the latest AMD drivers here:   You would want to make sure everything is up to date.  I have no resolution issues with my all AMD build using my Sapphire Pulse 5700 XT using 2 monitors.

Hi o/

First of all, thanks for your reply, it's good to know that some people do not meet this problem
I am sure my windows is fully up to date, and I am pretty sure my drivers are fine too, as i face no problem when I reinstall the graphic driver until next reboot... it just seems to not stay correctly installed.

Anyway, i'll surely reinstall my whole OS due to some errors when creating partitions etc... so I'll do the whole manipulation again from scratch, probably this weekend ^-^ I'll let you know if I still face the problem, or if it has been resolved



Hello there,

I found time to reinstall my whole computer last night, so I am now sure that my windows is up to date, and I just installed both AMD chipset driver and AMD Graphics Drive, but I still get the same problem... 1st screen is working fine, second has very low resolution and low refresh rate :/

any clue appreciated :3

Journeyman III

Which Monitor do you have? I have a similar problem. Often from a cold boot, the resolution of the screen is limited to 1600x900 although I run a 4K monitor. If the monitor goes to sleep and wakes up again, it will fix itself, or I can unplug and replug the monitor and that can sometimes fix it.

My monitor is an LG 27UD88

I never had the trouble with 1 screen plugged only, but the resolution ain't the same soo, who knows ^^.

When i started having my troubles (so when I started using 2 screens) plugging 1 on the go while booted, usually resulted in a black screen until next reboot anyway :/

My monitors are both Samsung 27" LED - LC27JG50QQUXEN

Journeyman III

Hi all,

I have exactly the same problem as described above. I have identical monitors the AOC 2590H4. I have newly bought my entire pc and these monitors so my AMD setup would work like a charm.

I’m running an AMD Ryzen 5 3600 Processor paired with the AMD Radeon RX 5700. Freshly installed windows 10 pro (updated) and of course all drivers are up to date (07-11-2019).

I’ve tried everything to make my monitors work properly but every time I reboot it’s the same result. My main monitor is working perfect and my second will have a bad resolution. Even when I duplicate the monitors, the second one will have a bad resolution even when I says its on 1920 x 1080. I have to take the power out of my second monitor and wait a few sec, plug it back in and set the resolution to 1920 x 1080.

I am kind of sad there seems to be no solution for this problem, I worked and saved hard to be able to buy this setup and it seems AMD has let me down.

I’d love to hear from some one who has been able to fix this issue or Amd themselves.


Hello mate o/,

So, I'm the one who originally made this topic. I had the trouble where I was always supposed to re-install the graphic driver at boot.
After a given time, (i honnestly don't know if there is anything but time or amount of driver installation) it stopped being a problem and my monitors were working fine. It sometimes still happen, but turning the wrong monitor off and on seems to be a quick fix.

Also, if you ever meet graphic freeze, black screen, or crashes "due to graphical driver", think about disabling material acceleration as it is absolutely not well supported. The 2 main softwares I had to do it with were Discord and Firefox.

(a bit off topic, but so you get a complete guide of what can go wrong, according to my experience)
A last graphical trouble I have with AMD right now, is with software that applies post-treatment modification to your display. I'm using F.lux to make my screen go a lil' orange when it gets dark, and it seems that with this software working, my monitor sometimes show 50% of the screen with an horrible blue filter (that is not made by F.lux, obviously). Just switch window focus a couple of times and it disappears.


Journeyman III

I have very similar issues with both my rx5700 and rx5700xt (powercolor and sapphire, both reference models). I don't think this is a driver issue at all since I'm using both windows and ubuntu. It just won't detect the actual monitor resolution some times over display port. When that happens (very often) I need to plug in something else via HDMI and restart, then plug in my monitor via displayport and it will pick up the resolution.

This is driving me crazy because even though it always works fine with HDMI it won't support freesync. I'm not sure what I can do at this point, if it's any help this is my monitor:

I haven't been able to find much over the internet, just hoping someone reads this and has any info. Thanks!


I ran across this problem myself. So I reset windows again to get around it.

Not sure what caused the problems.


What's really strange is that I'm having the issues on Linux as well, it's

as if the video card got into a weird state with the monitor. I'm thinking

there may be an issue with either the DP cable or the monitor.

On Wed, Apr 29, 2020, 7:35 PM hardcoregames™ <>


My Panel also has HDMI so that is always an alternative for testing

Adept III

Same issue here, i.e., sometimes after cold boot, my monitor's (AOC Q3279VWF) native resolution (2560x 1440) simply disappears from the list. I have to replug the DP cable and turn off/on my monitor. Really annoying.


nordvargr wrote:

Same issue here, i.e., sometimes after cold boot, my monitor's (AOC Q3279VWF) native resolution (2560x 1440) simply disappears from the list. I have to replug the DP cable and turn off/on my monitor. Really annoying.

I have everything on a power bar so I can power down everything if need be

Journeyman III


Same for me. I fixed it by turning off 'fast boot' and 'display logo' in the bios.

I dont know which one of these 2 options fixed the problem but it worked for me. 


So I figured this out, within the driver (21.4.1), go to the display tab, then turn on "virtual super resolution", if you have multiple monitors, in the top left it allows you to change the settings for "display 1", "display 2", etc..