Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Vega 56 is not being detected, or the driver isn't functioning properly

I've tried several different things, there was a previous thread on these forums about using DDU and then following it with a fresh install, that didn't work for me. I also tried a manual install in addition to multiple runs of the express installer. I've attached the error I've gotten every time.

While we're at it, this card will artifact and crash while gaming. Is it worth trying to troubleshoot these two issues, or should I return it? What else can I try as far as troubleshooting goes? This PC is a brand-new build, nothing was purchased used, I assembled this less than a month ago.


  • Ryzen 5 1600
  • Sapphire Pulse Vega 56
  • 8x2 GB of G.Skill Aegis DDR4 3000 RAM
  • ASRock Fatal1ty B450 Gaming-ITX/ac motherboard BIOS date and version P3.10, 20 March 2019
  • PowerSpec 650W PSU
  • Windows 10 64bit
  • I'm attempting to update to 19.7.2, Radeon settings won't open though because the card can't be detected
  • I'm using a ViewSonic monitor, 1920x1080p, 60Hz refresh rate
2 Replies
Adept III

Try updating chipset and bios and see if that does work.
For me i had instaler hang with outdated chipset and bios on 19.7.1 which was only recoverable by system restore...
Chipset and bios upgrade worked great for me.


The card's BIOS is the most current version of it, I believe the chipset is as well but I'll have to check that when I get home. 

I contacted Sapphire and they said it sounds like a hardware issue and that I should send my receipt in for a warranty request. Problem solved, I guess.