cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mr_neverdies
Journeyman III

USB 3.00 and USB 3.10 Driver

Can be deleted.

115 Replies
dxlc0
Adept III

I have the exact same motherboard (ASUS TUF B450-Plus) and almost the exact same error.

The AMD USB 3.10 eXtensible Host Controller keeps failing. Sometimes it just fails without BSOD, and sometimes it fails with BSOD and a very quick automatic reboot. Usually the BSOD goes by so fast I cannot read the error code at the bottom.

I have noticed that I can cause the error to occur more frequently when I install and use a PCI-e WiFi card. If the WiFi card is disabled, the crash of the AMD USB 3.10 eXtensible Host Controller happens less frequently (maybe once a month). If I enable the WiFi card and use it to connect to the network, then the AMD USB 3.10 eXtensible Host Controller fails very frequently.

I had the same problem with two different WiFi cards, one brand new ASUS PCE-AC58BT and one older but highly reliable Intel 5100AGN card. Both cards cause the same frequent failures of the AMD USB 3.10 eXtensible Host Controller.

Different from your case, my AMD USB 3.0 eXtensible Host Controller does not fail.

0 Likes
dxlc0
Adept III

@mr.neverdies:

Do you happen to have an Intel Wifi card in the bottom PCIe slot of your mobo?

I have been testing with three different Intel WiFi PCIe cards, and the AMD USB 3.10 eXtensible Host Controller crashes only when the Intel WiFi card is installed and enabled. If I disable it, then the USB 3.10 EHC driver stops crashing.

I tested an Intel 9260, Intel 5100, and Intel 7260 and they all have the same problem.

Also, if I disable the Realtek Gigabit Ethernet card on the motherboard, then it looks like I can use the Intel WiFi card without the USB 3.10 EHC crashing. But I need to test it for a few more days to confirm this.

0 Likes
dxlc0
Adept III

I fixed this issue by reinstalling Windows 10 from scratch.

I figured out that it must be a software problem by running my PC in Safe Mode with Networking for a day. It had zero crashes of the USB 3.10 eXtensible Host Controller driver, even though this driver was loaded by Safe Mode.

Thus, I realized that it must have been one of the 3rd party drivers not loaded by Safe Mode, but I was not able to figure out which one. So I did the reinstall and the problem has gone away.

0 Likes
dxlc0
Adept III

Sadly, the problem came back after I installed the latest AMD B450 Chipset Driver package downloaded from amd.com. I rolled back all six of the drivers in the package but the problem did not go away.

Then, I did a system restore to a point right after I reinstalled Windows 10, and the crashing was almost completely gone, but after the latest Windows 10 comprehensive update to 1909, the crashing of the AMD USB 3.10 eXtensible Host Controller 1.10 driver has begun again.

This might be a bad Windows 10 update or might be a bad AMD Chipset Driver.

dxlc0
Adept III

Final update. In the end, after trying everything I could think of and everything that ASUS tech support asked me to try, I sent the motherboard in for warranty repair. ASUS opted to replace the motherboard. I am testing it now but do not expect any problems.

My suspicion is that the PCI-to-PCI bridge that the AMD USB 3.10 eXtensible Host Controller was a child device of kept failing, taking down all the child and grandchild devices at the same time. This included the integrated RealTek GBE Family Controller and the Intel 7260-ac Wifi card I had in the bottom PCI-e slot. Nothing I changed in software or in the BIOS made a difference, so I figured it had to be hardware and shipped the board back to ASUS.

Hope this helps someone.

UPDATE: after ASUS replaced my motherboard with a brand new one, I no longer have the AMD USB 3.10 eXtensible Host Controller problems. It was a hardware problem.

FURTHER UPDATE:

I just got the same error with the AMD USB 3.10 eXtensible Host Controller failing.

This is with the brand new motherboard ASUS sent me (not refurbished).

It was right after I installed the AMD Ryzen Power Plan 5.0.0.0.

I have been installing/updating drivers and software one at a time for about 2 weeks and then running it for several hours to a few days to see if the software was at fault.

I uninstalled the AMD Ryzen Power Plan 5.0.0.0 right after the crash of the USB 3.10 EHC and am testing it now.

So far, uninstalling the Ryzen Power Plan 5.0.0.0 seems to have worked. I've gone 48 hours without the USB 3.10 EHC crashing.

Uninstalling the power plan is not the same as deleting it. Deleting the power plan still sees the USB 3.10 EHC crash. You must uninstall it. The AMD chipset driver installation EXE can do a custom uninstall if you use the commands in the release notes.

Hi, I have the same exact issue as you, same mobo and issue when I have a network card adapter, since this post has the issue been fixed?

If so, can you post an explanation on how to uninstall the Ryzen Power Plan 5.0.0.0 as I have not found any documentation online explaining how to do so.

Thanks for the dedication on solving this issue.

0 Likes

If you still have the original installer .exe, you can run a command in the same directory like so:

START /WAIT "" <path to executable with exe name> /S /CUSTOMUNINSTALL="<feature name/names assigned to the drivers that are to be uninstalled separated by comma>"

The list of features is at the bottom of the Release Notes that came with the driver .exe.

For the Ryzen Power Plan, it is:

RYZENPPKG

So the final command would be:

START /WAIT "" .\AMD_Chipset_Software.exe /S /CUSTOMUNINSTALL="RYZENPPKG"

---

Note that I have discovered that the Ryzen Power Plan 5.0.0.0 is not the only thing that causes the USB 3.10 eXtensible Host Controller to fail. I still get the failure after uninstalling the Ryzen Power Plan, just a lot less often.

I have not figured out what other driver(s) to uninstall or update or downgrade to get it to where my system just works all the time with the WiFi+Bluetooth NIC in the last PCI-e slot. Am still trying things out to pin it down. I've even got a fourth brand new NIC on order to try in the last PCI-e slot, hoping that it fixes the problem (but it probably won't--three NICs didn't work, why would a fourth one?)

Thanks for the answer, the thing is I don't even have Ryzen Power Plan installed...

When you installed a fresh copy of Windows you said the issue stopped for a bit until you updated to the latest AMD Chipset drivers, is there any chance that if I installed a fresh copy of windows and didn't install the latest AMD chipset drivers the issue would stop? Or does the Windows update always mess it up?

Anyways please continue to post updates to this thread if you find out anymore related info.

0 Likes

Windows Update does eventually provide somewhat recent drivers (from 2019). The older drivers (2015 or thereabouts) seemed more reliable to me, but the 2019 ones aren't that bad. I do get the occasional (once per week) crash of the USB 3.10 eXtensible Host Controller with the drivers provided by Windows, but it's nowhere near as bad as when I install the AMD ones provided by AMD's website or the ones provided by ASUS's website for the TUF B450M Gaming Plus mobo (once every hour).

I am seriously thinking about buying a new mobo (with some other chipset than B450) just to stop the frustration.

I have to wonder if it is something Asus did? I have no issues like this with my MSI Tomahawk B450 board. 

I read somewhere that it is possible to design a B450 mobo so that the PCI-e slot(s) are too far away from the chipset, causing intermittent problems.

It could explain why I only have trouble when a NIC is installed in the fourth, furthest slot.

One option for me is to pull the NIC out entirely and use a WiFi-to-Ethernet bridge plugged into the integrated RealTek GBE NIC. That did work in the past (no crashes at all), but I sold the WiFi-to-Ethernet bridge because its performance was too slow. It didn't have big external antennae, whereas the NIC I have in Slot 4 has huge antennae on the back and gets much better performance.

Thanks for the tip about the MSI Tomahawk B450 board. I might buy one of those if this keeps going on.

0 Likes

I think the Tomahawk Max is the only one available now. However both those are even known to work with the R9 3x series. MSI did a great job with not cheaping out on the design. The VRMs are great. 

Based on description of events I would say your guess is spot on. 

I could test it out this way.

If I got a skinny GPU card and installed it in Slot 1, allowing me to use Slot 2, then I could move the NIC from Slot 4 to Slot 2 and test it for a while. Nothing else changes.

If the crashes go away, then yeah, it's probably Slot 4 being right on the edge of too far from the chipset.

I would have to step down to a less powerful GPU to get a smaller heatsink, though.

---

Oh, I forgot to mention another possibility. One thing I was tracking down was that some threads claimed that these WiFi NICs that are adapter boards with laptop WiFi modules on them do something like take a x2 laptop module and neck it down to an x1 PCI-e card. Supposedly this can confuse some mobos, but I don't entirely believe this myself yet. I would have to test it (take same laptop module, move it to an adapter board that is x2 or x4, then see how it performs in Slot 4 (which is x16)). But I don't think any such adapter boards exist.

I have my wifi adapter card on the second pci-e slot and it still happens, so I guess that's not the cause.

Did you look at your energy settings, turn the PCI-Express energy savinging (link state management?) off and the energy saving for the USB under advanced Energy Management.

USB 3.# flips out on my other AMD system if i plug my old wireless mouse adapter into a USB 3.0 port, so check you have something thats not USB 3.3 plugged into one of the USB 3.# ports.

Excellent advice. Those were among the first things I tried months ago. I also thought it was a USB device at first and moved things around, but nothing made a difference except wiping Windows 10 and reinstalling (which I did when I received my replacement mobo, which made me think the replacement solved the problem). Note that after wiping and reinstalling Windows 10, I did not set PCI-e Energy or USB settings, and the system was stable for a while (until I foolishly tried upgrading the AMD Chipset Drivers).

0 Likes

Oh, glad that you reported that. You just saved me an expensive experiment (and that blows away the hypothesis about distances and electrical signals).

Well, I'm going to try the other hypothesis by ordering yet another WiFi adapter. But it is also a laptop module on an adapter board. (Gigabyte's implementation of the Intel AX200 module.) The problem is that there aren't many choices for WiFi 6 modules right now. Maybe I should go back to a WiFi-n board that was famous for being ultra-reliable and use that for testing.

BTW, the current version of my AMD drivers is:

AMD PCI: 1.0.0.75 (12/18/2019)

AMD GPIO Controller: 2.2.0.126 (1/14/2020) <-- I think this was provided by Windows Update since I force-uninstalled the entire AMD Chipset Drivers package a week or so ago.

AMD GPIO Controller: 2.0.1.0 (4/2/2019)

AMD PSP 3.0 Device: 4.4.0.0 (6/2/2017) <-- definitely provided by Windows Update because it had no driver at all after the force-uninstall of the AMD Chipset Drivers. It was an Unknown Device until the most recent Windows Update from this weekend.

AMD SMBus: 5.12.0.31 (1/18/2015) <-- I think this was the other of the two Unknown Devices I had after force-uninstalling the AMD Chipset Drivers.

This current setup still has the USB 3.10 eXtensible Host Controller crash about once a week.

The drivers after the last fresh install of Windows 10 were older than above. I am looking for the log I wrote down of the versions as I slowly added one thing at a time, but I think I lost it in the last wipe and reinstall.

0 Likes

Another interesting fact is that, in my case, the crash occurs only when I'm having low workloads, like browsing the system of the web. When I'm gaming, for instance, it never happens. I even made the experiment of leaving a game open and minimized after having 4 crashes in one hour and the crashes stopped.

Thanks for that input. It's mixed for me. I've had it fail while in the middle of watching streaming videos, in the middle of gaming, and (worst) in the middle of work. It's even failed right after waking the PC from sleep (haven't had time to do anything yet).

I haven't seen a pattern yet (such as if it happens more when I'm watching videos or not).

BTW, I plan on submitting this as a ticket to AMD, since it seems to come from them and not from ASUS. I already spent a few months with ASUS diagnosing the problem (they told me a bunch of stuff to try), and they gave up and said to swap the board. After this, they're only marginally interested since they know it's not their hardware. I've been keeping them in the loop too, in case other customers of theirs report the same problem.

I know there is some pretty big disparity in the B450 boards. Some are 3 layer boards with inadequate VRMs. Other makers like MSi are using a 5 layer board with good components. You can't assume that one board is the similar enough to another to rule out an issue necessarily. If one variable is different it can change other things in different ways. 

Excellent point. I read somewhere that the ASUS TUF B450M Gaming Plus is a 4-layer board. It's supposed to have good VRMs, but maybe it doesn't.

The price was about middle-of-the-range, so it's probably just a mid-quality board. I only got it because it came as part of a bundle and I needed a micro-ATX mobo.

Any design can potentially have trace issues. Just like it is pretty well known that the Gigabyte 450 boards have issues using all 4 rams slots where it works fine on MSI and Asrock boards. Even within the same model board depending on what revision you have there can be issues. A lot of boards are made as long a couple years and have several revisions. Unfortunately all you can do is read reviews and more importantly reviews on new egg, micro center or Amazon of other users and their experience. Sometimes no matter how well you do your homework you buy a lemon. 

I have seen several reviewers say that the only stable AMD boards are the ATX boards and that the micro boards are pretty bad from most manufacturers. I have zero personal experience with this as I always use full size boards. 

whitesnake76
Adept II

Some motherboard use customized chipsets, so its best to install the driver provided by the manufacturer of your motherboard, and not the one from the AMD suport site.

I am suspecting that is the problem here because you mention the problem starts after installing the Chipset drivers from AMD.

On top of that i must add there are a lot of people reporting problems with AMD B450 chipset motherboards, but mostly Gigabyte B450

That is great advice.

However, in my case, I tried both the AMD Chipset Drivers provided by the mobo mfg. and the ones from the AMD website, and both gave the same exact kinds of errors.

It looks like the mobo mfg. just provides an older version of the AMD Chipset Drivers as-is. The installer says AMD and acts just like the AMD installer.

Thanks for the tip about other B450 mobos. If I do buy a new mobo, it'll be some other chipset, hopefully one that's more reliable.

dxlc0
Adept III

Interesting post here by someone else who has the same symptoms with the exact same mobo that the OP and I have.

https://www.overclock.net/forum/11-amd-motherboards/1730900-asus-tuf-b450m-plus-gaming-3200g-issues.... 

Though this post didn't mention the AMD USB 3.00/3.10 eXtensible Host Controllers failing by name, he described the same result (USB bus fails, along with the integrated RealTek GBE NIC).

He was able to reproduce the failure by stress-testing his build. I was not able to do that (ASUS asked me to run several stress tests before I was granted an RMA warranty return, and my mobo passed all the tests with flying colors.)

Anyway, note the final "fix" at the end of the thread--he dumped the ASUS mobo and went with a different brand.

I've watched this thread for a while, I've had exactly the same issues with my ASUS B450 Tuf Gaming mobo, I've had several times where I thought things have been fixed, but it appears that the latest AMD Chipset drivers 2.04.04.111 released on 7th April might have sorted things, it's been a couple of hours using my WiFi to download 30GB+ of games and I've had no issues. Before updating to the new drivers the AMD USB 3.10 eXtensible Host Controller was failing fairly constantly after 30 minutes or so. 

I really hope this is permanently fixed, I will leave things running overnight and report back tomorrow!

Hey, thanks for letting us know!--I didn't even know a new set of drivers had been released recently.

Yesterday (before I installed the new, fourth NIC), I had a series of AMD USB 3.10 EHC crashes in a row (usually it's once a week at the older driver versions). It was really disheartening to get three or four within an hour.

Please let us know how the new chipset driver goes--thanks!

It's been 15 hours now and no issues, I'm not going to get too excited, but this is definitely the most stable it's been since I switched to a WiFi card!

Has anyone else tried to download this new driver? I've downloaded it and when I tried to unzip it, I got the message "The archive is either unknown format or damaged, No archives found", I've tried to unzip it with winrar, 7-zip and windows archiver and I got the same message in all of them.

If anyone knows anything about this I would appreciate the help.

Thanks

0 Likes

I just downloaded it right this instant from amd.com and was able to unzip it without errors.

Give it another try.

There are certainly many disruptions on the internet in recent weeks. Your download may be getting messed with from some hop between you and AMD beyond both of your control. I would just try it again later. Make sure to try a different browser to download it too if you still have issue. 

dxlc0
Adept III

Follow up regarding the fourth WiFi+Bluetooth NIC card test.

I received my brand new Gigabyte GC-WBAX200 today and installed it. It is just a genuine Intel AX200 laptop module in an adapter board.

During the driver installation, the system BSOD-crashed. BSODs are pretty common with the other three WiFi adapters I put into PCI-e slot 4.

I have yet to put in the ticket to AMD for their chipset drivers and will do that later today. It is the next step in the process.

srandrews
Adept I

Well, it was too good to be true   The AMD USB 3.0 and 3.10 eXtensible Host Controller failed today for the first time. It's definitely more stable, but this could just be coincidence. 

Thanks for reporting back!

I have kinda good news so far. I've been running the new Gigabyte WiFi card for 3 days now, and aside from the initial BSODs right before I updated the Intel AX200 to the latest driver version (21.80.2.1 dated 2/25/2020), it's been more stable than the other 3 WiFi NICs I tried (all Intel, but different modules).

If this keeps up, I won't need to buy another mobo.

So far so good with the new Gigabyte GC-WBAX200 WiFi NIC. I have not had any AMD USB 3.10 EHC crashes with it installed for 7 days, running the PC over 12 hours a day.

I did not upgrade the AMD Chipset Drivers and still am at these versions:

AMD PCI: 1.0.0.75 (12/18/2019)

AMD GPIO Controller: 2.2.0.126 (1/14/2020)

AMD GPIO Controller: 2.0.1.0 (4/2/2019)

AMD PSP 3.0 Device: 4.4.0.0 (6/2/2017)

AMD SMBus: 5.12.0.31 (1/18/2015)

If this keeps up, I am good to go. The WiFi connection itself is stable and if the AMD USB 3.10 EHC doesn't crash, then the system as a whole is stable and usable.

I'll report back again in a week or two.

0 Likes
babuu
Journeyman III

I'm having the same issue with the same motherboard. It regularly crashes regardless if I use wifi or ethernet. Was hoping an RMA would fix it. 

0 Likes