Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

The AMDRyzenMasterDriverV22 service failed to start, its being caused by AMD Adrenaline?

Hi so I'm getting this error even though I don't use RyzenMaster, funny thing is that I thought I was getting this error due to not having it so I installed it and figured that would fix it. But it didn't it shows every reboot, it used to be "The AMDRyzenMasterDriverV22 service failed to start due to the following error: The system cannot find the file specified."

But now its "The AMDRyzenMasterDriverV22 service failed to start due to the following error: Cannot create a file when that file already exists."

Odd thing is that this error started on 9/28/2023 which is the same time I had installed Adrenaline driver  23.9.3, I have now since installed driver 23.10.2 so I thought that would fix it but no it just changed the message of the error. I tried delete the old AMDRyzenMasterDriverV20 in my registry like I saw some folks do but it just resiantlls itself again. Any other advice? Screenshot (4).pngScreenshot (5).pngScreenshot (6).pngScreenshot (7).pngScreenshot (8).pngScreenshot (9).pngScreenshot (10).png



8 Replies
Journeyman III

have you found a solution to this yet? ive been having the same issue since v20 was installed which appears to have happened on the 12th of september.


Thankfully when I updated to the latest driver in October I was able to delete the old V20  in registry.


I am dealing with this too, but I see a light at the end of the tunnel. For me, I found that if you download Revo Uninstaller, it will scan and delete the registry files so it doesn't come back. I just restarted my PC and this is the first time the other files are actually gone after a restart. 


Hi, i am in the same problem, can you plz explain with details how you can make it ?



Journeyman III

Experiencing an error with AMDRyzenMasterDriverV22 service, initially showing a file not found error and later changing to "Cannot create a file when that file already exists." Installed RyzenMaster, but the issue persists. The problem started around the time of the Adrenaline driver 23.9.3 update and continues after updating to 23.10.2. Deleting the old AMDRyzenMasterDriverV20 in the registry did not resolve the issue. Seeking advice or solutions to fix this persistent error.


Hey, have you found a solution to this?  I’m having the same issue 


So unfortunately it did come back for me, and after some fiddling around I decided to system restore to a previous date before it happens and uninstalled Ryzen Master. If you have Ryzen Master uninstall it and try a reboot. It fixed it for me,


So I was led here as I am having the same issue. I've tried all the solutions I could find posted on the internet with nothing working. What I have found though is that for me at least the issue appears to be created by the Adrenalin software. Previously I used AI Suite 3 instead of Ryzen Master although I did have RyzenMaster installed at one point. Deleting the RyzenMaster entries in Regedit had no effect as they reappear after a restart.

So as part of my troubleshooting, I tried uninstalling all AMD software Chipset, Adrenalin AI Suite 3. I then removed all leftover files in program files, Program Filesx86 then deleted the Ryzen Master entries in the registry. Restarted and the error was gone unsurprisingly.

I Then reinstalled the Chipset Drivers restarted and checked Event Viewer, the error was still not appearing. Then reinstalled Adrenaline 24.5.1 and checked and the error had already returned. 

So no RyzenMaster Software or AI Suite 3 nothing related to CPU Tweeking at all. Surely this suggests the problem lies within the Adrenaline Software and not RyzenMaster itself. Below is a snip showing my registry after installing Adrenaline and no other software as you can see the offending entries are showing without RyzenMaster ever having been installed. I'm thinking of rolling back to an earlier version of adrenaline and see if it helps I will report back any further findings.

Screenshot 2024-06-13 115721.png

MotherBoard - RogStrix X370F

CPU - Ryzen 7 2700x 8 Core