cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

glados-potato
Journeyman III

StoreMi issues - SMART passthrough needed, and intermittent INACCESSIBLE_BOOT_DEVICE

I built a new AMD system recently (Asrock B550M Steel Legend and 5900x) with Windows 10 Pro, and have run into a number of issues - of which two are pertinent to this thread:

1. INACCESSIBLE_BOOT_DEVICE

I see this intermittently: never if I use "fast startup" in Windows 10, sometimes on cold boot if fast startup is disabled, never on second attempt after first failed attempt.

2. CrystalDiskInfo, Hwinfo64 etc. cannot show me any SMART information for any disks. Adata SSD Toolbox would not work either (it doesn't detect any SATA drives at all).

Both these issues have gone away after uninstalling StoreMi (which apparently puts ALL the disks into some different SCSI "wrapper" that causes the above bugs).

I'm coming from an Intel system where I used RST to accelerate my HDDs using an SSD (I'm cheap, yes) and it worked pretty well, for years. I'd like to see AMD's offering be on par:

1. Don't result in INACCESSIBLE_BOOT_DEVICE

2. Allow SCSI pass through of SATA commands

3. Enable write caching (it looks like this was disabled in StoreMi v2 because v1 had some data corruption issues).

I'm uninstalling StoreMi for now, would be good to see at least issue 1 handled soon; 2 and 3 would be nice to haves.

0 Likes