Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Second monitor resolution stuck at 640x480


CPU  : Ryzen 9 5900x

GPU : Asus ROG 6800xt

Adrenalin 22.5.2

Monitor 1 : Samsung, all is good here, connected via DP

Monitor 2 : BenQ G2400W. Its an old one but a good one, always been fine, been using it at 1920x1200 with the Vega, in windows 10 and 11. The monitor only has one HDMI, which is the one plugged in, plus DVI and VGA. My new card has 3x DP and 1x HDMI, and I don't have any adapters for it. 

Been using a Vega 64 GPU for a few years, but I've just upgraded to a 6800xt

I was having some issues with the Vega crashing alot, and so I installed Win11, no improvement. It was time for an upgrade, so I got a new MB, CPU and GPU. I then clean installed Win11 on an M2 drive. 

The second monitor is stuck at 640x480 resolution. I've searched forums for suggestions, and I've tried the following : 

Unplug and replug the HDMI

Shutting down the computer, turning off the PSU, then back on again

Unplugging the power to the monitor, leaving the HDMI plugged in, and having it unplugged. 

Setting custom resolution in Adrenaline, but I'm told the monitor does not support this. (tested 1920x1200 and 1080)


I'm hoping someone here can offer help, other than getting a new monitor, as there's nothing wrong with it, been doing its job perfectly for years

I could uninstall the driver and go for 22.5.1, but I hope there's a better way



Tried setting custom resolution again in Adrenaline, started low and worked my way up, worked this time. 

0 Replies