Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Ryzen master curve optimizer on 8600G do not work per core after reboot

when i create the curve per core i can choose per core and reboot. the setting is per core but mode on left side show all cores. it is german text. How can i switch ryzen master to english on german windows 11 ? I use default values -30 to create the curve and no crash reboot during curve optimaze happen. after 50 minutes per core curve is create. Does the 8600G not support curve per Core ?

10 Replies
Journeyman III

Try switching Ryzen Master language to English in settings. Ryzen 8600G should support per-core curve optimization, verify compatibility with AMD or reinstall Ryzen Master.


I have download from here


it use automatic german , in settings i see nothing that can change language . I do a new curve optimize per core with -50 now(before was default -30). no crashes but same. after choose pro Kern(per core) übernehmen(accept) and reboot left side show Modus Alle Kerne(Mode All Core). what is problem ?. maybe need some special bios settings ?. I have a MSI B650 board

ryzern master main page.jpgryzen master settings.jpg


I think my CPU have lots too much power consumption in idle in Hwinfo. it is 20 watts . in forums can read a 5600G need only 10 watts in this hwinfo display . change to standard also not help. I sue 144 hz 2560x1440 display. with 2560x1440 60 hz it is 1 watt less . normaly a 8600G should be at least perform in power consumption as a 5600G in idle



Switch Ryzen Master to Advanced View.

There is a CO value for both the CPU and GPU which can be set independently.

Not sure that the Auto-Optimization feature works with Per-Core, have you tried using Per-Core with manually set values?

The 8600G has higher power consumption than a 5600G, this is true for all Zen4 vs Zen3 chips.

No idea on the language settting, sorry.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

In the advanced view there can see that the curve optimizer all cores seem have a Bug. in core 1 it set to -255 . Or did you think there can a CPU work with that value ?


I see no AGPU curve optimization tests . how can i do this, or is it not possible ?kurve optimizer.jpg


It seem the core one value -255 is ignored because ryzen master notice it is too low and all core is used or it can be this way when all cores are good at -50 (millivolt i guess) it is display as all cores. so i need try out more - settings ?. does -100 often work ?.


with the default -30 mv cpu package is 20-22 watt in idle. with -50 it is 17-19 watts. guess under load it is also 15% less power consumption



Adept I

I have done curve optimisation per core with  -100 then -150 . it optimize complete without crash. but on some page it show -50 on other page - 150.    I think the -50 is correct because idle power consumption is same as with -50.


how can report a bug and get answer from AMD if that is a CPU limit or maybe a Bug in Ryzen master ?


here -150.jpgonly -50.jpg


My understanding is Zen3 (5000) CO value range is +/- 30 whereas Zen4 (7000) is +/- 50 but I can't find official documentation to support those. Here is the AMD doc on CO I was able to find and it only mentions 5000 along with a screenshot indicating -30. Also as I understand (but again, nothing official) each +/- 1 offset equals 3-6mV in voltage, with lesser variance near the bottom of the curve and greater adjustment near the top.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

I have verify in manual mode. I can insert at 1. core -30 let other cores -40 then it show this per core values instead all cores. Limit is really -50 .I find AMD support page where they answer and ask about that


To get best i think underclock cpu and overclock GPU core from 8600G . currently a game use 40 % CPU 87 watt is reach and GPU downclock to 2700 with 99% GPU load. Temperature is only 60 celcius(CPU Limit is 95 celcius) with silent 900 rpm. I use only a cheap Alpenföhn Ben Nevis Advanced for cooling. with FSR 3 frame gen i can play what i like with over 70 fps. only sometimes FSR 3 frame gen stop to create new frames because the pixel distance between frame is too much on fast rotate.


Maybe the limit to disable Frame generation should be set by user. during move i never see very bad notice frame gen problems on fast rotate. and if some maybe look much better as when frame rate drop from 70 fps to 35 fps


my CPU have no problem with -50, so can go lower. In the stress test when all cores are test it reach 82 celcius with all 6 cores at 4.7 GHZ. base clock in spec is only 4.3 GHZ

diffrent cores.jpg

Have you tried applying a negative CO to the GPU as well?

On my 5700G I have -25 CO set for both CPU and GPU as well as boost overclock +200 on both CPU and GPU.


Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

set -50 work in theory, here ryzen master allow lowest limit -50 .but can you suggest a AMD GFX stresstest ?. I see on a friend PC in radeon page a stresstest for his external RX card. but i find none in my radeon APU


gfx curve.jpggfxcurve 2.jpg


There are lots of graphics benchmarks available that simulate how the GPU performs in gaming. One that is made specifically for APUs is 3DMark Night Raid which is available in the free bundle.

If you want a graphics stress test that will really put the thumbscrews to the GPU use FurMark.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT