cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

frustratedwithdrivers
Journeyman III

rx470 driver not working properly in Windows 10 (Code 43)

Hi.

I have looked at all forums and followed loads of advice, requiring removal of the card, un-installing/re-installing, certificates etc etc, but nothing has resolved my issue.

I bought a Sapphire Nitro+ RX470 Radeon 8GB for my son's PC - Christmas upgrade on the existing HD6870 XFX Black Edition.  The PC is built on an ASUS M5A78L-M USB3 motherboard with an AMD Phenom Processor (x6 1045T 2.70GHz), with 8GB Ram.

I have tried literally everything to install the darn card - windows recognises it in Devices Manager, but show the Code 43 and is using the standard Microsoft Display as a result.  I had a similar issue when I built my PC with a 2200G AMD Ryzen and on this the Card in built in! (Can't quite work out how I fixed it either.)

I have tried installing from the disk (which was Vulcan VT and Crimson I think), tried the latest Adrenaline update and optional one.  Uninstalled them all with a driver removal tool and also manually, reinstalled.  Taken the card out and cleaned the connections.  Nothing is working.

Why is it so difficult for Microsoft not to recognise the driver or for AMD to understand that this happens (Seen A LOT of people with problems), and create a wizard or troubleshooter???

Anyway - can anyone help please?  This is seriously affecting my son's PC Fortnite game stats....

Many thanks

0 Likes
6 Replies
Hardwood
Paragon

Re: rx470 driver not working properly in Windows 10 (Code 43)

Assuming your using win10x64

install these 18.5.1: Radeon™ RX 470 Previous Drivers | AMD

But first, use DDU in safe mode. Use Clean and Restart option

You might want to disconnect from the internet too. That would prevent windows from installing it's default driver.

or

In DDU's options the very last option will do the same.

0 Likes
frustratedwithdrivers
Journeyman III

Re: rx470 driver not working properly in Windows 10 (Code 43)

Hi Hardwood,

Thanks for taking the time to respond.  Yes, I am using win 10x64.

Unfortunately it didn't work.  Here is what I did for anyone else that may have this issue though (or in case I missed something):

1. Went into safe mode (Shift+Restart from start menu)

2. Troubleshoot>Advanced Options>Start-up settings>Restart

3. F4 for Safe mode

4. Removed Internet cable

5. Started DDU and selected GPU Drivers (perhaps I did something wrong here???)

6. Selected Clean and Shutdown first time and Clean and restart second time

7. Manually deleted "AMD" folders on C Drive (second time)

8. Microsoft Basic Display Adapter was still showing in Devices manager (Uninstalled on second attempt)

9. Installed 18.5.1, having previously downloaded, ran as admin, with Devices Manager open on second go.

10. When 18.5.1 starts up, Microsoft Basic Display Adapter is re-installed (assume it scans hardware and the MBDA is part of windows and not downloaded from the internet?)

11. Selected express install.

12. installed without issue, said driver installed fine with tick to confirm, but there is still a Code 43 error on Devices manager and when selecting Radeon Settings no driver installed (see below).

13. Shutdown and restarted, but no change.

I have tried this twice now :-(

Any other suggestions would be much appreciated, this is becoming very frustrating now!

Images below....

20181228_155308.jpg20181228_155246.jpg

It is definitely a Radeon RX470 8Gb Sapphire Nitro+  !!!!

20181228_155321.jpg

0 Likes
Hardwood
Paragon

Re: rx470 driver not working properly in Windows 10 (Code 43)

Dag blam it!!! That should work.

If nobody else offers a solution...

Seeing as you've spent a lot of time on this already and the preferred fix isn't working...

Are you in to:

1) putting the gpu in another computer?

and if that works then

2) reinstalling your son's OS?

I just think we might be wasting precious fortnite time here if there's a problem with either the card or the OS install.

0 Likes
dmitrykr
Newcomer

Re: rx470 driver not working properly in Windows 10 (Code 43)

For me the issue were resolved by upgrading vcard firmware using techpowerup.com amd flash tools and latest rom for my strix 4gb Gaming

0 Likes
dropp
Journeyman III

Re: rx470 driver not working properly in Windows 10 (Code 43)

i have the exact same issu, tryed the excat same things as you have, then i saw this post...

Did you find out anything? i have 12 of these cards, going to make a mining rig... but you know... not working.... been on it for 8 hours now

0 Likes
gaze
Journeyman III

Re: rx470 driver not working properly in Windows 10 (Code 43)

My friend gave me the RX470 card he was using for mining crypto and I had the same problem as is described in this thread. Finally I was able to get rid of it by using this clock patcher https://crypto-mining.club/en/mining/amd-ati-pixel-clock-1-4-7-atikmdag-patcher-download-for-windows... 

Everything works now, I hope it helps also to you.

0 Likes