Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

RX 6600M Not Detected - (MSI Alpha 15)

About my Laptop:
MSI Alpha 15 B5EEK
GPU - RX 6600M
CPU - Ryzen 7 5800H
RAM - 40 GB
OS - Windows 11

I bought it a year ago with pre installed Windows. It was working fine. Then I wanted to switch to Linux, so erased Windows completely and installed Ubuntu 22.04, but later I came to know that RX 6600M does not support Linux.

So I had to delete Ubuntu and do a fresh install of Windows 11. I did and everything was working fine.

But when I tried to connect to a second monitor, it didn't work. So I checked Device Manager, Task Manager, 3rd Party Softwares, but nothing detected my dedicated GPU. Everything shows that only my iGPU but not the dedicated GPU. 

I followed the forum solutions, articles and tried to fix it for the past 5 days. No luck. 

I tried,
> Installing new and old drivers
> Completely remove using DDU and reinstalled (normal and safe mode)
> Installing 3rd party drivers
> Update Chipset driver
> Manually download and update drivers
> Driver from MSI site
> Driver from AMD site
> Updated my firmware
> Reinstalled Windows 11 around 10-15 times
> Checked with Hidden Devices in Device Manager
> Updates Windows 11 to the latest version

No solution worked for me.
I am not able to play any game, connect to my second monitor using HDMI.
My warranty period ended 2 months ago.
Service center guys too didn't know how to fix it.

So I feel like I'm stuck. Can't use linux. Can't use dedicated GPU. Any help would be really appreciated.

1 Reply
Adept II

I had Omen 16 (Ryzen 9 5900HX, 16 GB of memory, Radeon RX 6600M) 

idk if this going to work, but it was my last best shot :

*be sure you have already download your driver from your laptop manufacturer first 

1. Install win 10, after that don't let it connect to any network/internet

2. disable any windows/driver update immediately , see here

3. Install your driver

4. Pray

5. Restart your PC

if it works good, wait a whole day or three day, still working? good. Make a restore point.

sometimes ddu just don't help (in my case) 

** some tried to suggest installing the PRO version of the driver but it just don't work for me, maybe try that first and see what happen