cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mess
Adept I

RX 5700 XT 640X480 resolution on new drivers

I'm having problem with any driver newer than 21.1.1. Only available resolution is 640x480. Tried different ports, cables, DP/HDMI, reset, factory reset no result... Custom resolution does nothing. Is there any fix to it? Video card RX 5700 XT. Connected via DP. Monitor Gigabyte Aorus 2K 27'. With 21.1.1 it works fine.

8 Replies
MightyGuallo
Adept I

Re: RX 5700 XT 640X480 resolution on new drivers

I own an Aorus F127Q. Same problem here. I installed the latest 21.3.1 and my monitor was locked as a Generic PnP Monitor 640x480. So I uninstalled and go back to AMD Raedon v. 20.12.1 and at least Windows 10 Pro x64 still detects my monitor as a Generic PnP, but with the refresh rate of 165hz and 2560x1440... so for the moment, this is my temporary solution. Thanks.

0 Likes
RPX100
Challenger

Re: RX 5700 XT 640X480 resolution on new drivers

@mess @MightyGuallo 

1) Start by unplugging the display cable from the monitor while PC and monitor are powered up.
Plug it back in after ~20 seconds delay and see if you get option to change resolution then.

2) If that does not change anything, then try to turn the display off (power switch or pull cable)
Then after ~20 seconds reconnect the cable or enable the power switch again.

3) Next best option could be to go into Windows Device Manager and unistall all PnP Monitors,
including the hidden (unplugged) ones it still lists (option can be enabled via menu).

4) try booting into Windows Safe Mode and see if the resolution can be changed there.

---

You might want to try and run System File Checker via Windows Command Prompt.
sfc /scannow
... and see if that brings up any errors

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
0 Likes
mess
Adept I

Re: RX 5700 XT 640X480 resolution on new drivers

@RPX100 

Tried all three options. Nothing changed. Did not tried 4. Some people on this forum got it working with HDMI, but it's not an option for me, because video card has only one HDMI port and I need it for other device which btw works fine in 4K. It's some kind of Gigabyte Aorus FI27Q and newer AMD driver bug.

0 Likes
RPX100
Challenger

Re: RX 5700 XT 640X480 resolution on new drivers

@mess yes, I have noticed the other topic about Gigabyte Aorus FI27Q, after my initial post.
With this many people having the exact same issue, its just a matter of time until AMD might find a fix.

Thanks for trying my provided troubleshooting steps anyway.
Maybe @amdmatt can forward, that these steps did not change anything, to the dev team.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
MightyGuallo
Adept I

Re: RX 5700 XT 640X480 resolution on new drivers

The first thing I did was try all the four options. Nothing work. But for the moment, I deleted 21.3.1 v. and returned to 20.5.1 as temporary solution... and I say "temporary", because after I installed and then uninstalled v.21.3.1 the monitor performance is not the same at all.

0 Likes
MightyGuallo
Adept I

Re: RX 5700 XT 640X480 resolution on new drivers

For the record, I just submitted a bug report to Microsoft, summarizing this issue. Let´´´ s see what they have to say.

Herus
Journeyman III

Re: RX 5700 XT 640X480 resolution on new drivers

I've Aorus FI27Q and Gigabyte RX5700XT and same issue (can't change resolution- only 640x480 is available) with drivers no. 21.4.1 and 21.3.x. The last drivers i have right are 21.2.X

Plaese fix it.

0 Likes
Flyfisherman
Adept III

Re: RX 5700 XT 640X480 resolution on new drivers

Hi,
Se this thread https://community.amd.com/t5/drivers-software/latest-driver-21-3-1-locked-my-monitor-to-640x480/td-p...
where several of us with the Gigabyte Aorus-F127Q monitor, downgraded its firmware from F05 to F03 and it works.
Btw. I had to change the refresh rate to 165Hz again after firmware downgrade:
Right click on desktop > display settings > Advanced display settings

Then I tried to upgrade the AMD adrenalin from 21.2.3 to 21.3.1 No problem (just for checking) and then again upgraded to the latest Adrenalin 21.4.1 and it still works.
So for now I will use Aorus-F127Q firmware F03.

I think it's a serious problem with the Aorus-F127Q F05 firmware together with AMD Adrenalin later 21.x.x s/w versions.

Best regards from Sweden

0 Likes