cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

cheetah_hunter
Adept II

RX 560 giving texture issues in Project cars

Recently after updating to 18.8.1 i've played pcars but it seems that the textures are taking time load. When i am racing with AI, the texture on the other cars load up when i go closer to them, and they lose their textures as they move away from me. I just dont know if its my card, the driver (I've tried with a few other drivers as well) or a problem with the game itself. I have recnetly bought my pc so I really dont think its my pc. any help appreciated.

0 Likes
4 Replies
benman2785
Big Boss

Re: RX 560 giving texture issues in Project cars

reinstall driver after cleaning with DDU
test again

if error persists
is you GPU vram OCed?
or
do you use "lowest" settings but changed viewrange?

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes
cheetah_hunter
Adept II

Re: RX 560 giving texture issues in Project cars

Thanks so much for taking your time to help. however I have tried uninstalling with both ddu, amd clean uninstall utility. The driver 18.6.1 seems to have lessened the problem but its still there. My GPU is a gigabyte Radeon RX560 4GB OC version, ie. already OCed when i bought it. I dont think the GPU is damaged since this does not occur in assetto corsa. Pcars uses high/medium settings by default. I haven't really messed with the game setting, but could you tell me which settings in game might be responsible for this texture glitch? there are so many settings I am a bit bit confused. Thanks again

0 Likes
benman2785
Big Boss

Re: RX 560 giving texture issues in Project cars

if you have to game on an "slow"ish hdd there can also be texture glitches - especially if you also have limited ram etc

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Likes
cheetah_hunter
Adept II

Re: RX 560 giving texture issues in Project cars

I have a Toshiba 1tb HDD @ 7200rpm and 8GB corsair vengeance ram. now i realised this glitch is most visible with the mitsubishi evo 6. If you have this game, could you please tell me whether you have this glitch as well?

0 Likes