Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

RAID drivers update makes second NVMe invisible

My PC is Gigabyte x570 Ultra with 3900x, two NVMe drives NOT in RAID and two SATA in RAID. Latest BIOS (F10). Win10 1903.

Everything worked ok with RAID drivers Both NVMes archived 3400 - 3500 Mbs read speed. SATA RAID is very slow but that's other problem.

Cause of plans to upgrade Win 10 to 1909 I updated my chipset and RAID drivers to latest one ( & After upgrade (and reboot) my second NVMe is invisible! SATA RAID is ok and my boot NVMe (first one) is also ok.

On second NVMe I have same Win 10 but without latest drivers and it works ok (copy of original Win 10 for cases like this).

I tried following:

  1. System Restore - does not work (probably cause of missing drive)
  2. Uninstalling everything from AMD (Control Panel and Apps & features) - does not work
  3. Manually uninstalling RAID drivers as in rft document - no help
  4. Disabling RAID in BIOS - no help

Only what helps is to:

  1. Enable NVMe RAID in BIOS

After enabling NVMe RAID I finally see my second NVMe (and of course SATA RAID). But, second NVMe speed dropped 50% !!!!!  I'm using Samsung Magician (first NVMe is 970 Pro 1TB) for measurements and speed of first NVMe (in this case boot drive) did not changed (3700 read, 3400 write) but second NVMe (AData 8200 Pro 2TB) is now half the prev speed - 1400 read!

When I run RAIDXpert my second NVMe is listed as Legacy. That's ok cause RAID must be enabled on NVMe to see this drive.

BTW RAID version 9.2 uses web based interface while 9.3 is UWP app.

Above I mentioned my catastrophic SATA speed. I have two 12TB IronWolf drives in mirror. Write speed is some 10 MB/s!? For smaller files is even worse! Unfortunately I don't have third drive to test without SATA RAID but if my NVMe dropped 50%...

Could someone help how to get rid of NVMe RAID driver?

How to forcibly remove it from system and prevent future problems (besides AMD to fix their sw problems).

7 Replies
Adept I

Ok guys, I fixed my problem!

Let's start with my upgrade procedure from prev post. I upgraded my working Win 10 1903 using drivers from AMD site in this order: RAID ( then Chipset drivers ( After reboot second NVMe became invisible until NVMe RAID was enabled in BIOS. Result is 50% loss in seq reading and 300% loss in random!!!

Here is Samsung Magician performance test (it also has today's test after fix - at the top):

Samsung Magician - After Fix.png

At the bottom is speed before problematic update, then 2 results with NVMe RAID enabled and at the top result after fix.

Thanks God I made exact disk copy before upgrading in case of Microsoft. But as we see also in AMD case!

I will show you two Device Manger screenshots. First one is working one (before upgrade):

AMD-RAID Bottom Device Properties.png

and second one is after upgrade:

AMD-RAID Bottom Device Properties.png

Do you notice difference?

Upgrade without any warning replaced "Standard NVM Express Controller" with "AMD-RAID Bottom Device" driver!!!

How to fix:

  1. Find "AMD-RAID Bottom Device" for your missing NVMe SSD
  2. Right click, select Properties and click on Driver tab
  3. Click on Roll Back Driver

After above procedure invisible NVMe immediately becomes visible but reboot to be sure!

If Roll Back Driver is disabled try to Update Driver. Click on "Browse my com..." and then on "Let me pick.." and in the list should be "Standard NVM Express Controller". If not try to search for stornvme.inf.

How to distinguish NVMe from SATA RAID I do not know. In my case it was on: PCI 4, 0, 0. Simply compare AMD-RAID Bottom Devices and see which one is different from others.

BTW, AMD support sent me an email that expert is looking at my problem but after two weeks no news from expert.

If someone in AMD is reading this please check your driver installation!

Hello there friend,

I have similar problem like yours, and I was wondering if you had any information from AMD support center!

I wish to had watched your solution before my disk format, as now I am not able to roll back to any previous drivers.

My second thought is to manually delete all the AMD files from my system but I really wanted to leave that as the last option.




Hi Oldar,

Sorry to hear about your problem.

You mentioned AMD support, oh what a joke!

Well after I fixed my problem and explained how I did it they asked do I need help I explained what problem is and asked them to tell developers and fix this issue. Did they? I do not see newer RAID drivers!

I’m not sure is my info on AMD support enough and did it help you. If and when AMD releases new RAID drivers I will just unpack them and install manually one by one.

In any case since day 1 I create VHDX of my C drive (non RAID) and have a fully running Win10 on drive D (separate SSD also not in RAID). On spare Win 10 I have disk tools to recover my primary Win10 from VHDX.

But as time goes, I’m thinking more and more to kill AMD RAID and switch to Windows one. Hardware RAID is questionable in case of motherboard failure while Windows one will always work.




Thank you SO much for your reply!!!

If you allow me to ask you these questions because I am really one step

closer to loose my mind here!

1. What AMD RAID Drivers do you use now?, or 9.2.0.


2. If you go from control panel and choose the AMD RAID driver there, which

it must be named something like AMD_Chipset_Driver Version 1.11.XX.XXX you

can unistall it with success? Because in my case with I cannot

unistall them neither from Control Panel, or with another way. A message

come up and warning me "there is not a unistallable software in your

system" or something like that.

I am afraid with such a poor driver software I will have to format for a

fifth time my drive and set it up all over again, but at least if I know

which drivers are the more stable I will be able to figure it out sooner.

3. I was thinking the same thing about killing the AMD RAID and turn it on,

in windows, but in case of windows failure how are you going to retrieve

the data from the raid drives? That was the only reason that keep me with

the hardware raid...

I tried to delete manually the folders AMD from Program Files and Program

Files (x86), and their drivers still do not go away!!! I mean cmon!!! What

are they doing in their support departement? In any case I had to restore

my system on order to enter windows and now I think I will not avoid

another clean windows install... But I do not know which drivers I need to


Thanks in advance for your time!









I’m using latest one on web. Let me check… this is from app:

In device manager all drives are, I’m not sure why here bottom is 9.2?

Chipset drivers are also latest one:

Latest chipset drivers also have problems with installation as previous ones. Usually GPIO is not correctly installed. In my case it is:

When I found (read) about chipset drivers problem I uninstalled all previous without any problem. I do not remember did I uninstalled RAID. Not sure what happened when I had problem.

About RAID. AMD RAID formats disks somehow but there are at least 2 partitions on drive.

It tells me that second one is NTFS but I think on HDDs is different cause this is software view, after RAID driver. If I remember correctly when I booted directly into partitioning sw it was something Linuxy. Not sure.

Windows RAID is completely implemented in OS and both drives are NTFS. You could simply take one drive out and it will work.

HW RAID is HW and driver based and who knows.

I was interesting in unplugging one RAID drive and check it but no time at the moment. Also I do not have 4gb free to make a copy of everything. I could but no time for this.

About AMD drivers. They are not in Program Files. Idiots create two copies, one in C:\AMD (or so) and other identical copy in %AppData% (either Roaming or Local folders) - %AppData% is Roaming: C:\Users\drazen\AppData\Roaming. Both could be deleted cause real drivers are installed inside c:\windows. There are several locations cause of x86 and x64 code.

To completely remove them google for removal tool. Not sure does one exists but it exists for graphics drives.

Attached is device manager screenshots when was not working (Bad) and after fixing (Good). “Zadnje OK” is latest version.

I have 2 SSDs where Samsung is using Samsung driver, AData is using MS one and AMD RAID its own (2 x 4) – bottom and strport.

If you do not use NVMe SSDs, only SATA, then even when drive is not in RAID drivers MUST be installed. You must install RAID drivers during win installation otherwise Win will not see them. So, if RAID is enabled in BIOS to boot RAID drivers must be installed. Drives not in RAID are also controlled by RAID but are not in RAID.

This is my case:

I have 5 HDDs, 2 SSDs not shown here, 2 HDDs in RAID and 1 HDD not in RAID.

Cause I’m not booting from RAID there is no need to have drivers installed during installation.

I hope this helps! Good Luck.


I had a similar issue, with just one NVME 1.3 on the motherboard. Motherboard model: B450M from MSI, I also updated the Standard NVM Express Controller, using the MSI website driver named: AM4_RAID_Driver ver. by directly clicking on Device Manager to "update driver" and pointing towards the folder where the new driver was... It updates nicely but then the NVMe SSD is gone! not even DISKPART can see it!


Your solution, "roll back driver" is great! (mine was greyed out but I used the workaroun of "search new driver", "let me pick" and selected: "Standard NVM Express Controller")


Adept I

Hi, I was reading through this (well skimming tbh).  I got to the bottom, and I just tried something.  Opened the device manager and "scan for hardware changes" and my 2nd SSD popped up in explorer.  I have a raid 10 4x 14TB wd140EMFZ, a "legacy" 850 evo SSD, and a "volume" 860 evo SSD with R/W caching enabled.

Now that my SSD is seen, and hopefully can use this trick in future (cause windows forgets it on cold boot); I need to enable write caching on my RAID10 (I bought a UPS and just updated firmware); so my data is secure even in the event of a power cut.

Wth my 2nd SSD I was using the pull sata data cable out, delete corresponding array.  Boot windows, restart.  Plug in cable in the bios.  F10 save.  Boot windows, and it was usually recognised at this point (or another reboot).

However I once deleted the array with the cable attached and then the drive was not recognised in the bios (after multiple posts) until I recreated an array (which has different settings vs the "legacy" type as seen in raidXpert2) it was not visble in bios. 

I need to enable write caching on my raid 10 to see its true performance.  I am afraid if I delete and recreate the array I will have to copy all my data from backup to the array (lol backup with raid10).