Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Radeon Software: GPU Utilization 100% bug

Occurs when the following settings are made in some video games.
Remains at 100% usage even after exiting the game program.

Tom Clancy's The Division: Options - Video - Enable DX12 Renderer. - Yes
Tom Clancy's The Division 2: Settings - Video - Enable DX12 Renderer - Yes



This can be fixed by exiting AMDRSServ.exe, but this is a bad solution.


Adrenalin 21.9.2
Radeon RX 580
Windows [Version 10.0.19043.1237]
Core i5 10400

1 Solution

AMD Software: Adrenalin Edition 22.11.2

AMD Soft.png

Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GL650F UltraGear 144 Hz FHD; Windows 11 Pro 22h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

View solution in original post

175 Replies

@bobalazs I'll try it now, and let you know.


Minimal, driver only... nothing works! 


Did you DDU before installing? Did you click ddu to not install driver automatically?

ryzen 5600 + 6700 XT

Yes, with amdcleanuputility, Revo, CCleaner...


Minimal driver or driver only are the only ways to "fix" the 100% usage bug, at least in my case. But again, you are losing the best part of adrenalin software...


Tried both, all games work like **bleep**.


So, i did a clean install on windows, and let the update install my drivers (installed the graphic card without AMD utility), and seems to be working now. If it goes bad again, I'll post here.


now pray and don't touch anything xd

ryzen 5600 + 6700 XT

Hey @Solipsistul ,

Yeah it is quite frustrating, one thing you can temporarily try whilst AMD has hopefully started attending this issue, is, if it is a DX9/DX11 game, to use the DXVK wrapper.

I have found this to help in some older games.

Adept II

Three more months and this post (and problem) will be a year old!

Adept II

they have updated the release date of Adrenalin 22.5.2 Optional but nothing has changed. what can it be?


a new driver has been released, but the problem still remains

Yup seems like one of these issues AMD just adds to "known issues" to calm down people but never actually fixing it. I mean just look how long Enhanced Sync Issues are on that "known issues list". Guess it will be the same with this issue.

The best you can do now is buy an nvidia GPU. I was one of those who thought people were exaggerating when they said AMD drivers were bad, but man, this is ridiculous...

At this point I'm pretty sure AMD is trolling us. They release a new driver for Win 7 and again no fix for such an important issue. I completely don't understand such weird movements. However, I know very well that my next GPU will definitely not be from the AMD brand - I am fed up with such disrespect towards users of their products.

I mean to be fair the "drivers" itself are fine. It's the AMD-Settings that cause issues. Every few Drivers it's either unstable or adds some new issues. It's annoying because i use some of its features like Freesync or Chill. So i "need" it.
I'm not really a Fanboi of any Company but i always had sympathy for AMD. I got an AMD CPU and if i had to choose between a Nvidia GPU or an AMD GPU that both have the same performance and pricing i'd choose AMD. But now? Really i don't see a reason why i should do that. Some Issues take AMD forever to solve or even account. It's annoying. And even worse a lot of people might not report these issues because it's often these small (yet annoying) issues only "Enthusiasts" actually notice. I mean what kind of Causal would even look at the GPU Utilization after playing a game?
That's an Advantage that Green has, it has so many users that things actually get reported and Green can't just avoid the issues and hope it will be forgotten.

Another example is the aweful OpenGL performance on "newer" AMD-GPUs AMD just doesn'T care fixing it. If i go to the basement and rip out my old 7950 from my old Computer i'll have better performance and smoother gameplay in a lot of older OpenGL games compared to my current RX580 GPU. Nobody cares so it will never be fixed.

I agree @-RKI- , it is totally disrespectful from AMD to treat us this way, considering we saved up money to support them and then they turn a blind eye to issues we report.

Hey @nonametoday , I mostly agree with you since I am sitting with a RX 480 that I saved up to buy in end of 2016 and I at this point find it super disrespectful that AMD have re-integrated a lost/deleted DirectX9 Unreal Engine 3 optimization only for Navi RX 6000 and possibly Navi RX 5000, after me and other users have been reporting the massive performance loss in Unreal Tournament 3 since 17.7.2; and Vega users are also affected by this, although if you have a very strong single threaded CPU that scores over 400 single core in CPUz, you won't really notice it. But, I even notice it severely on a Ryzen 5 1600.

It seems AMD have been working on OpenGL improvements for, again, mainly the RX 6000 series as you can see in this video:

I doubt the fixes will come for us older users who almost deserves it more, since we have been tanking with it since ~2013 (I had a R9 280) and AMD have barely properly ported the recent RX 6000 DirectX 11 optimizations to RX 5000 properly. Furthermore, I have not gained any DirectX11 improvements on my RX 480 with even the latest 22.6.1 driver, where I have been experiencing major underutilization in a lot of games; for example, Assassin's Creed Origins, and many other. In all these cases I am testing on 8 threaded CPUs and also a 16 threaded CPU.

EDIT: Also, the 100% GPU load bug is not only after exiting some Vulkan/DirectX12 games, it happens during gameplay in a very old game such as Kane & Lynch 2, where the power usage is dropping to ~40W-60W with 100% GPU load and FPS down to 42FPS on my RX 480 in certain areas of the map, whereas my 3GB GTX 1060 does 80-100FPS in the same area. When a RX 480 works properly it uses about 100W-115W under full load, not like this bug.
Furthermore, I have also discovered it happening in Project Cars during a replay, my GTX 1060 will do 50FPS during the replay and the RX 480 drops to constant 25FPS with 100% GPU load at stock 1303Mhz and low watt usage of 60W-70W.

So, basically if you have a polaris GPU you don't have any kind of support now, it doesn't matter that these cards are officially supported...

@KermyChamp, yeah and this is how I experienced it almost immediately after Ryzen & Vega (2017) was launched, although we were lucky enough to get Radeon Sharpening, Chill and Anti-Lag, although only for like two or three graphics APIs.

In addition, although I really think these are great features, I barely use them for my RX 480, since there is no point in using Fidelity Super Resolution if AMD's DirectX11 driver stutters on the CPU and no performance is gained since the single-thread overhead on the CPU drops to the same frame-rate irregardless of the resolution or graphics settings.

Furthermore, I really want to use Chill but after numerous reports it still has this periodic micro-stutter every 3-5 seconds even when setting MIN = MAX on a FreeSync display. It is slightly less observant on a FreeSync display with MIN = MAX = 60FPS+ but it is definitely noticeable, especially when trying limits such as 30FPS or 40FPS as if the algorithm empties the Render Ahead Queue too much for quicker input response with the side-effect of periodic jitter.

I'm running in this thread's issue too, and I guess I can cope with killing the process to get idle stats back after finishing playing, but I'm concerned if having the GPU stuck at 100% usage while gaming isn't too hard on the card. I have an RX 580, I have no idea if 100% usage is supposed to be a realistic real case use scenario it can run at with no issues, or if it's meant to not be reached by casual use.

This is the stats I get after closing a game and getting the bug, I guess it's what the card is pumping out while gaming too, is it fine to play with clock, power consumption and fans constantly this high? 

Hey @cloudropis , thank you for your input to this post and also confirming that this is a real issue that AMD should attend to and it does not just happen after quiting Vulkan/DX12 games, but also during some DirectX9 or DirectX11 games.

You and me have basically the same Graphics Card, I have the MSI Radeon RX 480 Gaming X 8G and mine is factory overclocked to 1303Mhz.

Furthermore, your stats are definitely related to the bug but in your case it is not dangerous. Safe temperatures for our cards are below 84C-90C and max Watt usage of 100W-120W.

In your case you can tell it is the bug, because we should not constantly have 100% GPU utilization at half the rated Watt-usage for our cards. For example, when my card runs flat taps 100% it should be between 100W-115W and your may be between 115W-130W with the improved power phases/design, but we should not be running at 100% locked GPU usage and only 40W-70W with low FPS, and this happens to me whilst playing some DirectX9 and DirectX11 games such as Kane & Lynch 2, Project Cars 1, WRC9.

It also seems to be related to PCIe throughput in some cases, which can cause 100% utilization reports by the GPU if the PCIe slot is being overburdened. In addition, to me it very likely seems AMD has hogged PCIe throughput in recent drivers to promote their SAM (Smart Access Memory), since I did not experience it this bad before and am not experiencing it as bad on my refurbished 3GB GTX 1060.

Logically, this shouldn't even be the case since it is the reason why we have 8GB VRAM cards to reduce the PCIe bottleneck, but it seems AMD may be finding entertainment therein to lag some texture/data streaming through those PCIe lanes to promote their SAM.


@hitbm47 the only games I've been playing since I realistically got this are Monster Hunter Rise (dx12) and maybe Guilty Gear XX +R (dx9). I'm not sure I get any performance issues like you describe though, the stats from my screenshot are in the "stuck at 100% but after having closed the game" phase, not while gaming itself, and a few days ago I was checking temps while gaming and i think it went to the 70s. I wasn't aware of this problem yet so I didn't check anything further, and I don't have the in-game performance overlay because i'm using the crappy Window Update served basic drivers, but I can guess that under play it still goes past the stats in my screenshot - they are an annoyingly high baseline when idle, but at least it's not a performance cap like it seems to be for you.

Anyway, asked a friend with a RX 580 (I have the 4gb vram one btw) and he doesn't seem to be having this problem, he's using 22.5.1 Full Install drivers. On Monday I'm gonna DDU my current drivers away and update to those and see if that driver version is safe

EDIT yeah this is what it looks like under load, so it's like i assumed, i'm not capped like you, i get the full power consumption you would expect


@cloudropis  are u sure that your friend doesn't have this bug? Because as far as I know even a fresh windows install is not enough to solve this thing, its obviously a driver problem, this bug is so annoying for me that i'm using the 21.8.2 driver that is the latest driver without that problem, a least in my case.

@cloudropis, like a said it happens in certain DirectX9 and DirectX11 games while gaming, not in general. Furthermore, yes it will not necessarily "cap" frame-rate, but there are instances when it appears and severely affects performance during a game without efficiently utilizing the GPU and this can be seen when there is 100% utilization and only 40W-70W unlike to nice 113W screenshot you just took.

I have found it to affect Doom eternal during certain parts of gameplay as well where utilization would be 100% and around only 70W, in this instance it is a Vulkan game. Furthermore, it sometimes creeps up in certain areas of games just as it creeps up after quitting a Vulkan or DX12 game, which it did not use to be the case.

Did you ask your friend to test the same games as you and to follow the exact sequences that produces the bug on your end?


@hitbm47 I guess I'll keep my eyes peeled on non-DX12 games and check if the wattage is capped as you describe. Funnily enough, I always had crap performance on DE, a definite GPU bottleneck that wasn't consistent with the performance people with inferior hardware seemed to be getting, now I'm starting to wonder (probably not because this was on release and it obviously predates these drivers).

My friend just plays Apex Legends (DX12 i assume), he has consistent machine uptime (ie he never turns the pc off) and when he turns the game off Radeon Software lists his GPU usage correctly without the need to kill the process described earlier in the thread. That's the extent of the sequence afaik, just turning a game on and off leads to the bug for me.

@MikeRM2 oh I'm not claiming that my friend not having the bug means that it's not a driver problem, just that maybe that specific version doesn't have it? Maybe some specific driver version between today and the start of the thread is safe? Either way, I'm on the WU drivers, so I have the benefit of arbitrarily picking any of the manufacturer drivers now, I'd rather try first with one someone with my same GPU is free from the bug with

@cloudropisApex legends uses DX11,  not 12

@cloudropis, thanks for sharing your input. Remember it is the scenario of low Wattage and 100% GPU usage almost very consistently. By DE, are you referring to doom eternal?

Apex legends renders through DirectX11, but it is one of the few games that perform quite well on Radeon hardware and does not experience the bug from what I could tell. Popular E-sport games seems to be some of the few games which AMD actually optimize for more than just their Navi RX 6000, and thankfully, they tend to perform relatively well and I prefer my Radeon in 60-70% of e-sport games over my Nvidia, although StarCraft 2 performs like poop when paired with pre-ryzen AMD CPUs.

What do you mean pick from the manufacturers drivers? They just relist official AMD drivers since all RX 580's; for example, should adhere to the same chipset design, well at least MSI does. Furthermore, the Microsoft Update keeps an older in-depth tested WHQL AMD driver and often lack new features.


@hitbm47  Installed a clean copy of win, for driver to work... Worked for a while, of course! But watched the video, installed the drivers and it's working again! Until I get Nvidia! :))

@Solipsistul, do you mean you are using the modded drivers?


Hey guys, I installed NimeZ modded driver (22.5.1) with the adrenalin software dependencies 5.0 and I can confirm that the 100% gpu clock usage bug after gaming is gone. The only "issue" is that my RX 570 was renamed as a RX 580 and reading the post in the forum i can tell that this is the normal behavior for the modded drivers.

@KermyChamp, apparently it is renamed to allow extra features or optimizations; for example, my RX 480 gets renamed to RX 580X.

But, a problem for me was that Epic Games would experience artefacting when I used the DXNavi Kernal over Polaris (RX480) and therefore I could not login.


@hitbm47 Yeah, in my case with dxnavi optimizations I was getting a lot of artifacts and graphical glitches in my web browser. Its a shame cause I saw a big performance jump with some DX11 games.

@KermyChamp, exactly! Like I noted previously it even gave back the lost DirectX9 Unreal Engine 3 optimizations which we have been reporting since 17.7.1 on Polaris. My minimum FPS jumped from 40FPS to 90FPS in Unreal Tournament 3 on the CPU-side, but now I can't really use it due to the artefacts in other applications.

This is even making me consider to give Linux a go again and try WINE with DXVK, since the community and even AMD are contributing to the MESA driver and probably the RADV (for Vulkan) driver and theoretically according to me it should give better performance in most DX9 and DX11 games than AMD is giving us Polaris users on Windows. My major concern is the NTFS format of my Windows hard-drives, since last time Steam Proton did not seem very compatible with it.


Anyone tested out the driver Pro 22.Q2 to see if this problem is present?

Adept III

Lol 22.8.1 still not fixed. Wow.

almost 11 months

they still haven't fixed it, it's a pity... How long can they not fix the problem

Adept I

Now I can describe the whole AMD company in two words - Pure Joke. Totally 0 respect for all Polaris users. I'm simply pissed... Almost year without fix!

What would be a bigger joke if they didn't acknowledge the issue.

ryzen 5600 + 6700 XT