Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

"Thread Stuck in Device Driver" BSoD when installing AMD driver

Hello everyone! I had a problem last week where my gpu driver seemed to "vanish" and I wasn't successful so far in reinstalling it. I'm not very versed in the matter so I'll try my best to explain what's going on and what I tried so far.


The issue:

A week ago (July 23) I was playing a game only to notice I had only 6~12 FPS. I tried opening the driver application but it said there was either no driver installed or no gpu. I then downloaded the most recent driver on AMD's website, tried installing and was greeted with a BSoD which later didn't allow me to do anything in Recovery Mode saying I needed to sign in as administrator to perform any of the troubleshooting actions, but there were no administrator accounts. After cracking my head for a while I was able to resolve the problem with a bootable usb and managed to restore to a previous point. Since then, I have been able to log into Windows and do pretty much anything, except my gpu driver is nowhere to be found and every time I try to install it, it enters a BSoD with the Thread Stuck In Device Driver message. The system tries to boot 3 times and, after not succeeding, gives me the option to restore to a previous point. The only time I was ever able to install the driver was when I attempted to do so in Safe Mode with Networking. The installation went through but as soon as I tried to boot in normal mode the same BSoD appeared. Here's a picture from BlueScreenViewer showing that it's caused by driver amdkmdag.sys.


A few points that might be of importance:

- Until I cleaned up the previous driver, the gpu would appear in the Device Manager as disabled. Choosing to activate it would then show an error in the status saying it wasn't working due to driver issues. After the cleanup, the gpu doesn't show up anymore and what's showing up is Microsoft Basic Display Adapter, which is working. The GPU fans are still spinning.

- I recently looked into Windows Update History in hopes to find anything that matched the date in which the driver became faulty, but... there's nothing on the page. It's just blank. Checking Installed Updates on the Control Panel does show up a few, but nothing matches the date.

- On my last try installing the driver I had the Task Manager opened to look for anything suspicious. I did notice  my Disk% went up and stayed at 100% for most of the period. I should also mention that on the day I first had the problem I had 100% Disk usage as well, even though there didn't seem to be any heavy tasks being performed. After I finally got through the administrator BSoD problem, I was still faced with 100% Disk. I tried a few solutions online and it finally went down after I did an antivirus full scan (that didn't show up anything). However, from time to time I'll still get 100% Disk, for either a few seconds or multiple minutes.

- Whenever I tried the driver installation, if I marked the Factory Reset box, after the cleanup was done the system would restart (as it should), but the installation wouldn't continue on startup. I did run either AMD Cleanup Utility or DDU before install attempts, but was never able to add the Factory Reset option because of this.


What I tried up to now:

- Updated Windows through Windows Update

- Updated drivers through Intel Driver and Support Assistant

- DISM and SFC

- Chkdsk

- Interrupted Avast Antivirus and Firewall, as well as uninstalling Avast

- Removed Internet Connection before startup and paused Windows Update

- Past versions of the driver, including an old one from October that I succesfully installed back then

- Installing Driver Only, as opposed to Full Install

- AMD Cleanup Utility


- CCleaner (yeah, had to give it a go)

- No new DirectX updates available


What I have not yet tried:

- BIOS Update - to be fair, because 1) I'm frightened by it (never updated it before); and 2) my version is from 2016, and the most recent one is from March 2018. I'm not sure if a problem that happened last week would be solved by an update that is more than 3 years old.

- Windows Clean Install - I was hoping to avoid because I also never done it before and it's quite a hassle, but I'm running out of options.

- Restore to a point where my driver seemed to be working properly - I guess it should have been one of my first thoughts, but I'm a noob at this and didn't think about it until yesterday, and when I look at System Restore Points there aren't any from that period of time unfortunately.

- Test the GPU on another PC – unfortunately I don’t own another one nor do I know anyone who could help with that


My configuration (built in 2016 and not upgraded since):

CPU: Intel Core i3-6100 @ 3.70GHz
GPU: Powercolor PCS+ R9 380 4GB

MOBO: Asus H170-Plus D3

RAM: HyperX 8,0GB DDR3 (single)

HD: Seagate Barracura 1TB st1000dm003-1er162


OS: Windows 10 Pro 64 bits Version 21H1

BIOS: Version 0404 BIOS page


I'm very sorry for the text wall but I wanted to include every information that could be relevant in identifying the problem and, hopefully, a solution. I am eternally grateful for anyone who can help me fix the issue.

2 Replies
Journeyman III

I know this is a long shot, but did you ever solve it? 


Hi. Unfortunatelly, no. Never discovered the problem. I still own the GPU and might try taking it to an expert some day, but had to give up solving the issue myself.