Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

opencl - where is it? has amd removed it quietly?


did amd removed opencl for hawaii gpus? wikipedia says it supports opencl in 2.0+. i can remember that i used it someday.

now i wanted to use opencl for adobe premiere pro again and was very dissappointed. NO OPENCL WTF AMD?

how to i get those opencl drivers? amd app sdk? gone

newest drivers of their page? no opencl in there.


i know i gonne buy nvidia soon, there will be cuda in the next century for old cards.....

Describe your system:

AMD Graphics Card

    • AMD R9 290 of Gigabyte
  • Desktop or Laptop System
  • Desktop
  • Operating System
    • Windows 10 64bit

Driver version installed

latest driver 18.9.3

Driver Packaging Version

  • Display Devices
    • LG IPS 27"
  • Motherboard + Bios Revision
  • MSI Z270-A Pro latest Bios 1.60
  • I5 7600kPower Supply Unit  Make, Model & Wattage
  • Bequiet Dark Power Pro 11 650watt
  • RAM
    • DDR4-2400 GSkill Ripjaws V F4-2400C15D-8GVR 16gb

Nachricht geändert durch Christoph Haase

27 Replies

Don't know if this is any help but you can download the OpenCL SDK from Github (2017) which I believe is the latest: Releases · GPUOpen-LibrariesAndSDKs/OCL-SDK · GitHub

Also from Github concerning the same SDK : Releases · GPUOpen-LibrariesAndSDKs/OCL-SDK · GitHub

Found the above links from this previous AMD Thread concerning OpenCL : OpenCL SDK


doenst work, still no opencl device in gpu-z

i think amd failed. im gonne buy nvidia end of year.


Can you post the information that kingfish​ requested?

Need to know at least the GPU card you have installed and current Windows and AMD Driver.


i already posted the mask with my information on it.


Thanks that helps immensely.!

This is a very old AMD Driver but the AMD Website says it is the driver for Opencl 2.0: AMD OpenCL™ 2.0 Driver .

Even though the driver is  for Windows 8.1, just for troubleshooting purposes, would it be possible to install this old AMD Driver just to see if GPU-Z recognizes Opencl on your GPU card?

Note: This is the same exact driver from Gigabyte Support website for your GPU Card: GV-R929OC-4GD | Graphics Card - GIGABYTE Global

AMD Driver
OS: Windows 8.1 64bit,Windows 8.1 32bit,Windows 8 64bit,Windows 8 32bit,Windows 7 64bit,Windows 7 32bit


305.12 MB


Asia China America Europe

Also Gigabyte Support has a the last vBIOS update for your GPU card. See if it is the same one listed in GPU-Z: GV-R929OC-4GD | Graphics Card - GIGABYTE Global


  • VersionSizeDateDownloadDescription

    F5 0.63 MB 08/01/2014

    Asia China America Europe

    1. Release for ELPIDA Memory
    2. ATI Source BIOS Version:
    3. GPU Clock/Memory Clock:1040/5000MHz
    4. Improve compatibility

i chcked my gpu first before flashing

i got the gv 2929d5 4gd b not your in the link mentioned version.  im flashing the bios to f2 then to f3. lemme see if there is opencl enabled then.

i already downloaded your older ccc and there was no opencl, still. so i hope the bios thingy will do it.


seems like it has the same vBIOS as the GPU card that  I posted according to TechPowerUP vBIOS Database:  VGA Bios Collection | TechPowerUp

GigabyteR9 290 4 GB


2013-12-31 08:59:00015. / 1250GDDR5Download | Details

Yet for your model it has the older vBIOS (F2) and not (F3). The dates was when the User uploaded the vBIOS to the website.

GigabyteR9 290 4 GB


2014-02-20 21:11:00015. / 1250GDDR5Download | Details

But I just noticed that at Gigabyte Support for the other GPU card with various vBIOS updates, they all have the same version but different updates.


hm i tried the "f3" version where it says N/A in the table i get an error.

still no opencl support. i can remember that i had opencl back in the days when i bought the card. anyway. end of year i'll get a new gpu. its a bottleneck right now and escape from tarkov/arma 3 needs nvidia.


Sorry to hear that. I would have thought that updating the old vBIOS on your card it would have GPU-Z show the card supported OpenCl.

Did you restart your computer after updating the vBIOS?

If your card supported Opencl in the past, there should be no reason why it shouldn't support it now. According to your GPU specs from Techpowerup is does support Opencl 2.0:

Graphics Features

12.0 (12_0)
Shader Model

and I know all latest AMD Drivers still support Opencl.

Try installing and uninstalling the AMD Driver using this method. It may help to eliminate any previous AMD or Nvidia Driver (if applicable) conflicts:

install AMD driver:

1) Download the correct AMD Full Set of drivers from AMD Support. Make sure your Windows is fully updated via Windows Update. Windows Must be fully updated because the latest AMD Drivers requires all the latest "Optional" and "Recommended" updates to be installed.

2) Use Windows Uninstall to uninstall current AMD driver and software and disconnect the internet from your computer. Then use DDU (Display Driver Uninstaller) Display Driver Uninstaller (DDU) from Wagnardsoft  Forum in Safe Mode. This will eliminate all traces of the AMD driver and software from your computer.

Delete C: \ AMD folder from the Root Directory. Reboot

3) Go to Device Manager and click "Display Adapter" and make sure you are on the MS Basic Display Adapter. If not, uninstall the AMD driver using Properties.

4) Try reinstalling the AMD FULL SET OF DRIVERS that you have downloaded manually. Make sure you disable the Internet to prevent Windows from installing a newer version. So configure windows to prevent it from updating drivers via windows update. So it has been mentioned to disable any anti-virus programs before installing AMD Drivers.

5) If the new AMD drivers installs and works correctly, delete again the C: \ AMD folder from the root directory. To save space on the HDD.

6) Enable both the Internet and Anti-Virus program (if applicable).

7) Go back to Device Manager and check your GPU card driver is working and identified correctly.

Try installing the lastest AMD driver using the above method and see if Opencl is activated again on your GPU card.


windows is u2d, every tuesday is patchday.

i use the amdcleanuputility and test 18.5.1 18.5.3 your driver and so on. there isnt mentioned any opencl stuff.

I'll wait till a official guy of amd will answer this. but i doubt it so the nvidia guy can buy a new leatherjacket to christmas.


Yea, that is what I tell my dentist after he charges me an arm and a leg for a dental procedure except I say I will be paying for his next expensive vacation.

This poster is one of the top Users here at AMD Forums. This is what he said about Opencl (05/2018) in a earlier Thread : OpenCL with Windows10


Correct Answerby black_zion on May 15, 2018 8:03 AM

That's an old support article which should be deleted. OpenCL support is included in all driver packages.

1 of 1 people found this helpfulSee the answer in context


It is possible it is a hardware problem rather than a Driver problem.

Maybe you should Stress test your GPU card and see how it behaves under heavy loading.

I normally recommend using OCCT which is free and it checks GPU cards under stress and for errors in Full screen.

If interested, you can download it from here : Download

Or can use any other diagnostic programs that stresses GPU card for stability.


Sorry I couldn't be more helpful.

Good luck

EDIT: One very important information I forgot to mention. This isn't AMD Support rather a Forum where Users can ask or help others with their GPU issues. If you really need to contact AMD Support open a AMD EMAIL SUPPORT Ticket online from here : Email Form .

This way you will most likely get a reply back to your question.


If he' is using a laptop, the default graphics for Adobe will be the integrated graphics. Until he/she posts computer specs, it's a guessing game and a waste of time.


i already posted the mask with my information on it. press ctrl+f5 to reload the page properly. i edited after u posted it.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

I pretty sure this is not a AMD driver problem.....R9 290X

It is helpful to show that the R9 2xx does support Opencl.  What the OPS need to do is find out what is preventing the GPU card from showing that it supports Opencl.

Updating vBIOS didn't help. Installing previous and latest AMD GPU Drivers didn't help.

Maybe if the OPS boots into a 'Clean" windows desktop where all 3rd party software is disabled his R9 might again show Opencl support. If it does it means he has a conflict with a 3rd party software that is preventing the Driver from activating the Opencl feature of his GPU card.

I did read that someone did a clean Windows install to get his GPU card to show Opencl but that is a last resort and chances are it may not fix the problem.

Could the type of BIOS (legacy or UEFI) prevent the card from showing Opencl? 


How do we know it is not supported on his card? Did you see anything?


The OP mentioned that it worked before " i can remember that i used it someday" referring to Opencl,  So the card did support it at one time. Plus as the OP mentioned the specs for that card indicates that it does support Opencl plus the specs from Techpowerup varifies that. Also your card, R9 290X, which is basically a more powerful R9 290 shows it supports Opencl according to your image. Both the R9 290 and 290x uses the Hawaii chip except his is Hawaii Pro and yours is Hawaii XT.

So as you mentioned, It doesn't seem to be a Driver issue. So it is either a conflict with another driver or software or the GPU card has hardware issues.


His question has been answered. "did amd removed opencl for hawaii gpus? " And the answer is no.

OpenCL and Premiere Pro CS6 | Creative Cloud blog by Adobe

Adobe Premiere Pro System Requirements

The links, very good by the way,  shows that R9 290 is supported by Adobe. But he can't get the Opencl to show on his R9 290 or to work.

Do you know what might prevent his GPU card from showing and using Opencl ?  


I haven't seen where it shows it does not.


Applications and services may not be available in all countries or languages and may be subject to change or discontinuation without notice. Additional fees or membership charges may apply.


Not supported under gpu acceleration on some versions.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Beginning with Premiere Pro CS5, we have been using the GPU on certain graphics cards to process many things within Premiere Pro. This GPU processing (sometimes loosely referred to as “hardware acceleration”) relied on CUDA, a set of technologies from Nvidia.

We got a lot of requests from people using computer systems that couldn’t use CUDA—such as those with built-in GPUs from AMD—to expand our GPU acceleration features to also use OpenCL.

So, we did.

In Premiere Pro CS6, nearly all of the things that can be processed with CUDA on certain Nvidia GPUs can also be processed by OpenCL on certain AMD GPUs.


''i know i gonne buy nvidia soon, there will be cuda in the next century for old cards.....''

Good bye.


OpenCL is supported just fine by AMD in the drivers...the problem is something else in your system.