Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Not able to access BIOS Screen. Doesn't show boot screens.

Computer Type: Custom Build Desktop

GPU: AMD RX 5600XT Sapphire Pulse

CPU: AMD® Ryzen 5 1500x quad-core processor × 8

Motherboard: MSI B350 PC Mate

Operating System & Version: Windows 10/Ubuntu 20.04

Monitor: ASUS VP228

Description of Original Problem: I just installed the above graphics card into my PC. I previously had an NVIDIA card installed. Prior to uninstalling the NVIDIA card I uninstalled the driver. Then I installed the AMD card. Now I’m having an issue with the ASUS screen displaying an “Out of Range” error. It doesn’t even boot up to the BIOS screen allowing me to enter the BIOS set up, or review my boot list.

Now here’s a tricky part: I have a partitioned hard drive with Ubuntu 20.04 and Windows 10 on alternate partitions. 

If I re-apply my previous NVIDIA card, it boots up as normal.

Troubleshooting: I have uninstalled and re-installed my previous graphics card. 

Ultimately, I was able to download a driver for Windows and am now able to see Windows- but I still can't access my BIOS screen.  I'm still getting the error from my monitor saying "Out of Range".  I need to be able to access BIOS.

9 Replies

How is your monitor connected to the GPU card?

Have you tried a different video output from your GPU card to your monitor?

Are you using an Adapter on your Monitor cable?


My monitor is connected via an HDMI cable, without an adapter.

I have not tried any different cables.  Do you have a recommendation?


I know that many Users have been having issues with their 5600 series GPU card AMD drivers.

I see that your Monitor has VGA, DVI-D, and HDMI inputs and Sapphire has 1 HDMI and 3 DP output ports.

I really don't have any answers as to why you are having that issue except it might be due to the AMD Driver itself.  Sometimes using a different GPU Video Output port helps get better results or using a previous AMD Driver like from here: 

What does Windows Settings - Display show as your maximum Resolution or "Recommended" Resolution?

You could purchase an Active DP>HDMI adapter for 4k resolutions at 60 hz or higher but they are not cheap or buy a passive DP>HDMI adapter that will give 1920x1200 HD Resolution. They generally cost less than $15.00.

Can you change the Resolution settings to a lower setting to see if you get any video when you have the 'Out of Range' error?

Have you tried connecting a different Monitor or maybe your TV set if it has an HDMI input to see if it works during boot up?

Otherwise I am out of suggestions. Maybe some other Users can give some other tips to resolve your problem.

NOTE: I once had an ACER 1920x 1200 HD Monitor and using HDMI I couldn't see my BIOS but once it boots into Windows I had video. But when I used my DP port I had video during BIOS. My Acer Monitor had both HDMI and DP input ports.

But in your case it is different since you actually are getting an "Out of Range" error whereas my didn't get any errors at all just a black screen until Windows started loading.


Have you tried disable CSM support? You can find CSM options in the BIOS boot settings. It can also cause similar problems if VBIOS is not installed properly. Check out the original signed VBIOS on the Sapphire website and install it if you find it. If you are sure that the original signed VBIOS is installed on the GPU, contact the store where you bought the GPU and request a replacement with a different brand GPU. In short, the problem you are having is not related to AMD is related to the graphics card manufacturer.

Adept I

Same here

Though my card is a rx 570 8gb.

Adept I

I am facing the exact same issue since Wednesday
i am using a rx 580 4gb  

No sign of bios 
direct load  windows.


Problem solved by reflashing the graphics  cards bios 
dont know how and why ?
but its works as **bleep** now  


No screen after disable CSM in general is a VGA bios related any BIOS change you lose the bios signature/efi keys only way to fix it by reflash the original bios. 


do u smoke weedD or something else ?
its not about screen u fool 
it was the bios loading screen before load windows XD 
and it fixed by reflashing the graphics cards bios 
anyway thanks for your **bleep**ty reply