Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

New PC Build won't play games *HELP*

Just built a new PC with the specs listed below. The build has worked great for absolutely everything except for games. Any time I go to open a game from Steam, the PC freezes up and I have to use task manager to get out of the game. The same goes for opening 3DMark benchmark programs. It’ll freeze as soon as I try to run any of them. In addition to freezing, I’ll get the following error at times “AMD has detected that a driver timeout has occurred on your system”.

Things that I’ve already done to try to solve the problem:

  • Updated all drivers (except BIOS)

  • deleted all AMD drivers and reinstalled with AMD cleanup tool

  • Cleared AMD Card Shaders Cache

  • Disabled Multi-Plane Overlay (MPO) in windows registry editor

  • Installed and uninstalled AMD Adrenalin

  • Ensured all Windows updates were installed Checked all connections (PSU to Motherboard & GPU)

  • Reset the whole PC and reinstalled windows, then did all the steps above again.

  • Tried with XMP/EXPO on and off in BIOS

  • Stress tests: no issues identified

The weird thing - during initial boot and the second boot after resetting the PC, the GPU and overall computer worked mostly fine. I was able to run 3DMark and get and the computer handled it fine. 25000 score on TimeSpy. About 20 mins after running it in both instances, I was unable to use any games or benchmark software again.

Computer specs:

  • GPU: Red Devil 7900 XTX

  • CPU: 7800X3D

  • MB: Rog Strix B650E-F

  • 2 x 16GB Kingston Fury DDR5

  • Samsung 990Pro 2TB

All features of the computer work fine, EXCEPT GAMING. Any help is appreciated.

2 Replies
Adept II

Event Viewer might be able to shed some more light on it, like if it gives you a faulting module in connection with the crash.

Otherwise, have you updated the firmware on your Samsung 990Pro via Samsung Magician? It's an SSD known for having shoddy firmware on release. Though I doubt that's the issue even then.

I'd also update your BIOS not just because a chance of stabilizing it, but depending on how old your board's BIOS is, it could have some...issues with the 7800X3D. Namely 7800X3D was known for melting itself back in April, and particularly on ASUS motherboards it would take the mobo with it. Like I got an ASUS x670e at the store a couple months back, but the BIOS on it were over a year old and still had the CPU-melting version.

MemTest86 is also really good for uncovering harder to find RAM issues, but will also take hours to do.

I also like to run an sfc /scannow in the command prompt after a crash to make sure nothing stays broken. Probably won't matter since you've already reinstalled windows, but hey.


As @Zalugar mentioned, I recommend you update the BIOS on the Asus ROG Strix B650E-F to the latest available. The X3D chips came out some months after the initial 7000-series processors and typically require a BIOS update to support.

Aside from the motherboard BIOS, can you check the graphics driver version under the device properties to see if possible Windows Update is replacing the AMD driver with a Microsoft driver?

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT