cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

baileys88
Journeyman III

New GPU, everything "works," but settings won't run.

System type - Desktop
OS - Windows 10 Home 64 bit
GPU - Radeon RX 580
GPU Driver - Adrenalin 2019 Edition 19.1.1 / 19.1.2 (Tried both)

Motherboard - Gigabyte GA-Z27DP-03 

Bios Driver: F8 (Updated)
CPU - Intel i5 7600K

Display - Acer 144Hz, 1080p (HDMI or DP)

I recently got a XFX brand Radeon RX 580. It had faulty DP's so I returned it, but I never had issues with Radeon Settings. New one has arrived, no issues with high load, however it's only running 60 frames on an 144Hz screen and settings won't load and just disappears when I click it.

- Tried AMD clean up utility and installed both recent drivers

- Tried generic DDU and installed both ver.

- Tried clean install for both ver.

Is it possible it's an issue with the GPU? Please help. >_<

Tags (1)
0 Likes
3 Replies
baileys88
Journeyman III

Re: New GPU, everything "works," but settings won't run.

I have now tested a different graphics card, clean installed the drivers for it, and the same problem.

0 Likes
Hardwood
Paragon

Re: New GPU, everything "works," but settings won't run.

Are you using Display port as HDMI seems to have issues with resolutions over 1080p.

Try Custom Resolution Utility (CRU) 

A google search of radeon hdmi 1440 might bring up some useful info.

0 Likes
sur6e
Adept II

Re: New GPU, everything "works," but settings won't run.

if you can, try the card in a different computer

0 Likes