Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Need custom resolution options for Eyefinity in 2020 Drivers (20.1.3)

Hi Everyone,

                    I am having real issues trying to get a 3x1 eyefinity setup going here. It used to work so well, but lately 3 screen eyefinity has been RUBBISH! AMD used to own this segment. AMD Eyefinity was the benchmark for other's to follow with regard to multi-monitor setups. How has it come to this? 

Anyway, I'm not here to bash. But I would like to get multi-monitor working sufficiently again. 

My setup:

AMD 3900X in Asus Crosshair VI Hero (Windows 10 Pro x64 1909)

32GB(2x16gb) G.Skill Trident Z 3000C14 @ 3600C16

Asrock "Phantom Gaming" Radeon VII 16GB HBM2 Driver 20.1.3

3 x iiyama G-Master GB2888UHSU 4K 3840 x 2160 @ 60Hz Display-Port Freesync

EVGA 1000W Supernova Platinum PSU

I also have 2 Vega 64 LC kicking around, but Xfire is not worth it, that's another story.

As you can see, I've spent a lot of money to have a nice multi-monitor setup ££££'s

Ok, so my native resolution is 4k 3840 x 2160. 

I finally managed to find Eyefinity quick setup in the new GUI, I had to disable live streaming (which I wont use anyway) and then the Eyefinity option appeared in settings/display. 

I also found that Eyefinity Pro app that is hidden in the CNext folder of the driver. I was able to use that to get bezel correction, I found a nice setting and that was as it should be. 

So now, here's the thing. I used to be able to set a custom resolution in the old driver. Like I said, native resolution is 3840 x 2160. So if I let Eyefinity do it's thing it creates a group with 3 x 4k resolution (11560 x 2160). With bezel correction it was 11720 x 2160. 

Ok thats fine, and sat on the desktop, its fine. No problem. As soon as I try to load a game it just insta Blue Screens. 

Now it used to do that quite often if I tried to run an intensive 3d game at ridiculous resolution (11720 x 2160)

So used to set a lower resolution like 7680 x 1440 or 5760 x 1080. You could only use one at a time, but that was fine. Pretty much every game would run decently @ 7680 x 1440. 

But I cant find how to do this on this latest driver. Please does anyone know where this is? 

The display settings page shows a "custom resolution" option with no Eyefinity group. But as soon as you create an Eyefinity group that option disappears!  I am really stumped! 

All I want to do is play Euro Truck Simulator 2, with 3 screens, wheel + pedals + gearstick and head tracking. 

Is that too much to ask?

Thanks in advance if anyone has any solutions! 

4 Replies
Journeyman III

I am having the same issue and the new driver doesn't seem to have this included in the changelog, nor in the unfixed but known bugs section.

I am using radeon rx 5700 xt (Sapphire Nitro+ SE) with 20.12.1 driver (windows 10 64bit latest up to today)

Edit: I could get ~60 FPS in Dirt Rally 2 at 3*4k (11520*2160 px which is quite amazing) by removing all antialiasing etc... and with a custom medium-low-ish settings and ultra textures... Anyway, my "old" 4k monitors can't do more than 60Hz, but I am planning an upgrade and thinking between the G9 (2xQHD in one monitor) or 3 separate 1440p monitors with higher refresh rates. Or maybe I should go with 3x1080p with lots of FPS and framerate to match. Either way it would be great to be able to set custom resolutions to be able to fine-tune game graphics.


Would be great if AMD took notice of this problem. There is literally no way to run eyefinity at a playable framerate with 3 4k monitors if you are stuck with the daunting 11520x2160 resolution. Would prefer to have options for 7680x1440 as well as 5760x1080 resolutions.

Journeyman III

Good Moorning

Do you have some news for this problem???

me too ineed prefer to have options for 7680x1440 as well as 5760x1080 resolutions.


I had the same issue with WRC Generations.

My solution was installing AMD Catalyst to set up the resolution in the Eyefinity Options. After that i could choose the desired resolution in Game or in the Windows settings.

Hope that helps, if you haven't found a solution allready