Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Mouse lag after Radeon Crimson update on RX 580

Same issue happened few months back. Had to roll back driver to get mouse to work normally. Mouse is extremely sluggish. It works for few inches, then freezes, then will move again after a delay. I went to Device manager and rolled video driver back to previous version and mouse is fine again. Ok version 24.20.11021.1000 6/7/2018.

8 Replies
Adept II

same problem. I return a monitor (second screen) because have this problem. I think was the DVI cable corrupted. My god, was the  drivers.

AMD = problems + problems + problems

Adept I

Same here with RX580 Mouse stuck every 2 Seconds for 1 Second. No problem with 18.5.1

I have 2 displays and both are Powered On.

Journeyman III

turn on mouse trails...that fixed the mouse problems caused by previous drivers


Mouse trails don't work for me. It was the first thing i tried. I have also removed my Oculus Rift and reinstalled the driver. Only fix for me is using old drivers.

Journeyman III

I'm seeing this behavior with 18.8.2.  I just upgraded this PC from an R9 285 to a 580 and with 2nd monitor enabled I get the crazy mouse freezes.  Enabling trails seems to have fixed it for me, but it's a really obnoxious problem to have out of the gate.


Even with trails it still is is jumpy occasionally.  Does anyone have any other advice?  Old driver releases that are better?


To fix my mouse lag, I turned off HDCP on my 2 monitors that had it enabled by default. Radeon settings - Display - Display 1 - specs - override - disable HDCP (if it has it). do the same for any other monitors. I have 3, only 2 had HDCP. I do not know what HDCP does.

You, my friend, are the big winner.  Disabled HDCP on all 3 monitors and everything works like a dream.  HDCP is a security system used primarily by HDMI to make it more difficult to pirate movies, and really it's one of those things where anyone who wants to bypass it bypasses it anyway and average users get an extra layer of garbage that occasionally causes problems.  Thanks, movie industry!  Of course, this will probably break playing back some content somewhere.  Some day I'm going to be scratching my head wondering why media application XYZ doesn't work and it will be because of this setting.

Anyway, thank you very much.  Someone needs to sticky this somewhere.


Glad to help, and thank you for the info on HDCP.