Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Monitor Fails To Resume from Sleep S3 Mode with 23.2.2 & 23.2.1 Adrenalin

Hello everyone,

Since I upgraded to Adrenalin Edition 23.2.1/2, when the monitor turns off automatically (as set in power saving options), even if I move the mouse or press any key, it doesn't turn back ON again ("no signal" message on the screen).

The PC stays on, the fans spin and the LEDs on the keyboard react.
I'm forced to shut down the pc using the power button and when it restarts this happens:

Immagine 2023-02-24 110117.png


The problem is not random but always present, both with drivers V. 23.2.1 and V. 23.2.2
At the moment I'm back to the 22.11.2 version and everything works fine.

My hardware is as follows:

DESKTOP PC CPU: Intel Core i5-12400F
GPU: AMD Radeon RX 6650XT (Gigabyte)



1 Solution
Adept I

I'm really touched to see that, after more than 9 months, AMD has finally solved the problem.
Of course this doesn't change the decision to NEVER get AMD GPUs AGAIN, but "that's one small step for man, one giant leap for mankind".

View solution in original post

322 Replies
Journeyman III

Same here, I got a cheap 2nd handed platform like 4 month ago and this started from day 1

CPU : Intel Xeon D-1581
RAM : 64GB reg-ECC DDR3
GPU : AMD 5700XT(powercolor)

I've changed different version of drivers and disable ULPS in registry, no luck.
I have to limit the power saving mode to S1 in the BIOS in order to avoid this issue....
I'm not using my machine 24/7 so sleep isn't that big as an issue for me but still it feel sucks.

Adept I

I just turned off ULPS and my problem with the unwake up monitor was solved. As with this 23.7.1, the same was true for the old 23.5.2 driver. I used the MSI Afterburner menu. RX 6650 XT

It doesn't really solve the problem - it's just a workaround. And with this workaround an error message of the Adrenalin driver always appears after waking up the computer from standby.

Adept I

After doing this, the error message stopped showing up for me. What is your GPU?

Adept I

Fellas, I think I found a way to fix this, by cheer chance. In going back and forward with different drivers versions, the following fix is working without hiccups to me:
1: download and install the last Pro driver available (the 22Q4 at the time of this writing)
2: when installing the driver, be sure to check the reset all options button
3: after complete, download the latest Adrenalin edition available and install it (23.7.1 at the time of this writing)

I have no knowledge of why this works, but if I have to guess, the pro driving installation with the reset configs option probably cleaned whatever bad setup was destroying our sleep mode. I've been using my PC normally for more than a week with no problems and the sleep mode working flawlessly. Give it a try if you still have this problem. 

My specs are: Ryzen 7600X, Radeon 6650X, ASUS TUF B650M-PLUS WIFI, 32 GB of GSKILL RAM at 6000 MT/s

Are you turn off ULPS?


Nope, never touched this option.

Adept I

Almost a week with driver 23.7.1. There have been no problems with sleep yet. ULPS did not disable this driver version.
Has it really been fixed?


Now with the newest I also haven't problems with the awake up, but somethimes its appear warning for the driver is falled after the awaiking. With disable ULPS, everithing is alraight, without warnings.



(amd ryzen 7 5800HS with radeon graphics)

so sad...
HOW AMD STILL DOES NOT FIX this basic and important issue...

Im soOO disappointed....


Adept I

Yeah, the problem returned out of nothing. Don't know why


Still working great 4 weeks later using 22.11.2

To recap, problem started for me with 23.4.1 not coming out of sleep mode. As a workaround set display to never sleep and turned the monitor off when not in use.

After upgrading to 23.5.1 new problem started with spontaneous system reboots while idle/inactive. Wiped drivers and went back to 22.11.2

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
Adept I

The same with the newest driver 23.7.2. When it is turn ON ULPS, no wake up. When i turned it OFF, no problem.

I turned off ULPS, too. It definitely helps, but I still have some glitches even with ULPS disabled. For example sometimes icons or windows are not properly refreshed after wakeup. I think the driver still crashes after wakeup, but without ULPS it is somehow able to recover automatically.

Adept I

I just bought the ASUS 6650XT V2 and i have the exsact same isue with the display not waking up.

So the problem is solved with MSI Afterburner:

Brez naslova.png

I have tried every possible other setting and it didnt help:
- Erp on/off
- CEC Ready2019 on/off
- Powerplan sleep off/on
- USB emulation 60/64
- Wake up from mouse keyboard on/off
- Drivers Pro and Adrenalin latest 23.7.1 and 23.7.2
- Pcie ASPM mode L1 L0 Disabled
- HDMI cable on 144Hz - DOESNT HELP
- Displayport cable on 165 and 144 Hz - DOESNT HELP

No setting helpet but just disabling ULPS completley!!!!!!




My hardware is:




Posnetek zaslona 2023-07-27 233614.png

 Im not willing to wait to have basic functionality!!!! Im not wastin my money, You had few months to resolve this with driver updates, sorry but im going green i think or just use my hd7950 3gb.-

Plus rust performance is garbage if i set low everything and max everything i get same FPS like 30 to 70 max! **bleep**?????



Does the MIS Afterburner seem to work better than simply editing your Regeidt manually to disable ULPS?

Adept I

Still no hope...

It's been months at this point

Seems like my problem is solved. Tested for 2 days. No longer event 41 or driver crash.

RX 6600 XT

But yeah, i will buy Nvidia for Shadowplay. Relive is disgusting... 144hz perfomance is terrible.

Adept II

Basic desktop functionality still not fixed on 6650xt. Crashing wake ups from sleep and monitor not waking up from idle. How hard can it be to fix what you broke with the release of 23.x.x?? 22.11.2 works perfect

It's been months!

Yep - I'm right there with you with a 6650xt. I have noticed this issue too. My display won't come back up after it has turned off (from basic Windows settings to turn off after x number of minutes). Very silly that we are in August and no fix in sight.

Adept I

So glad I found this, my 6600XT suddenly decided to cause my PC to completely reset at least 25% of the time with a kernel power error after screen sleep kicked in with 23.x.x drivers. The weirdest thing is this happened AFTER a completely fresh install of Windows 11, prior to that with 23.7.x on an 2-ish year old constantly updated Windows 11 everything seemed fine.

This caused me to waste an entire weekend ripping my PC apart and control testing BIOS/Hardware/Windows thinking it was the 5800X3D I recently purchased having some fast emerging failure. However, after swapping out the CPU to my old 3700X (crash), testing the same fresh Windows 11 install with my old GTX 1080 (no crash), and then trying the 6600XT with 22.11.2 drivers as advised here (no crash), I can definitively add my expereince that something is wrong with the 6600XT and Windows 11 interaction in the 23.x.x drivers. I tried just about everything for installing: DDU, the AMD driver cleanup utility, installed Windows 11 with BYPASSNRO and left it completely offline while editing group policy to disable automatic driver updates, old BIOS (pre-ASPM settings), etc...

Not a fanboy of any company, even though my current build is full AMD, but I guess we're back to the stereotype of broken AMD graphics drivers since this has been affecting others since March. I've built about a dozen computers over the last couple decades and never had something this bothersome, obsurce, and completely unacknowedged by a company cause me issues.

PC Specs:
Msi B550M Bazooka (BIOS 7C95vAE)
Crucial Ballistix E-die 2x16GB (Dual Rank) DDR4
Sapphire Pulse 6600XT
WD SN850 (PCIe 4 M2 slot), Intel Optane P1600X (PCIe 3 M2 slot), Samsung 860EVO (SATA 6G)
Seasonic Focus Plus Gold 650W
HP X27Q (set to 120hz, DP connection)

I agree. The failure to wake from sleep was bad enough, the spontaneous reboots had me chasing other system components. Still rocking 22.11.2 and no problems.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
Adept II

I've just been pointed to this thread after having the exact same issues with a 5 day old 6650 XT.

Wow, this lack of action from AMD is beyond a disgrace. It's almost 6 months since the opening post.

I'm going to look into returning this card as it's obviously not fit for purpose.

Adept II

My issues seem to have been solved by ticking the "disable ULPS" box in MSI Afterburner settings.

Screen wakes up.

No stuttering in PGA 2k23.

FreeSync is now working flawlessly.

Thanks for nothing AMD.

Scrap that. I'm still having issues.

This time it's driver timeouts/crash after waking from suspend.

Fed up of this now. I'm spending most of my time troubleshooting these issues rather than doing anything productive.

Sick to the back teeth of of it.

Adept I

Just bought a brand new PC: MB with A620, 7600 CPU, 6650 XT GPU. And the PC can't resume from sleep. With ULPS disabled the driver crashes after resuming from sleep. How is it possible that this bug was reported 1/2 a year ago and is still not fixed?

6 months ago in this thread, yes.

I've seen posts elsewhere that are 2 years old. This issue has been around for at least that long.

Shame on you AMD.

Journeyman III

this happened to one of my screens the other day when i started installing vs-code and a few others  all three screens flickered and went black two came back the other one still nothing well it displays branding i try to manually adjust no response. dinner time ill follow up and post if i figure it out / or not

Adept II

Just tried the new 23.8.1 driver.

Same issues.

I used DDU in safe mode. Disconnected from internet. Installed the new driver. Let my PC go into standby. Wouldn't wake up. Restarted PC and it booted into 1024x768 rather than 1440p.


"Device disabled" on reboot.

I give up. I'm making another attempt to return this card as faulty.

I just got the notification that 23.8.1 was available and figured I'd log on here to see if anyone reported on it... can't say I'm surprised to hear there's no improvement.

Still running 22.11.2 and going on 60 days strong.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Yeah, I'm back on the same older driver dated 8th December!

To put things into perspective - this driver is 260 days old as of today

What did AMD do with subsequent drivers to mess things up so much?

what is not acceptable to me is that AMD is not even bothering to include the issue into the knows issues and is not replying in any form

I hope AMD create new branch for 22.11.2. 

MSI B550 Pro-VDH - MSI 6600XT - Ryzen 5600G
Adept II

New driver same problems on 66xx.

DEAR GOD amd!!!!

Journeyman III

Dear AMD,

I've been been working with computers for over the last three decades. I consider myself a gamer, a power user but I'm also a professional software developer with over 17 years of experience.

I've never had any issues with your products. In fact, my employer is a dedicated Intel and Nvidia shop. They only buy these brands and I've suggested to them many times in the past to try also AMD products as they are more competitively priced with performance being on-par or superior. This stops now, and will now fully back your competitors products both personally and professionally. Here's why...

In the last few weeks, I decided to build myself my quasi-dream PC. I went from an Intel Xeon E3-1231 v3 with an MSI RX 6650XT to a Ryzen 9 7900X, 32GB DDR5 6400, X670E motherboard, 1000W PSU and for the moment kept the mightily noisy but still adequate RX 6650XT.

Ever since I finished the installation of Windows 11 on this new PC, I was plagued by this issue. I must admit it took me a while to stumble upon this thread, believing at first that I might have an hardware issue. After all, every components but the GPU are brand new, the OS is a clean install with no bloatware, last GPU drivers, chipset, etc...
What could go wrong software wise? This seemed too big to be something that was released in a production driver. And isn't "bad AMD drivers" an old saying of the past?

I don't want to sound harsh. As a developer I understand that investigating this might be complicated. You have to support a range of hardware, configurations, maybe your developers do not even easily reproduce it in-house. But what frustrates me the most is the lack of communication. I went over all of this thread and what kills my confidence in AMD as a company I want to do business with (personal or professional), is the radio silence of the last few months and this issue not being acknowledged in the release notes.

I wanted to wait a year before updating my GPU. I was pretty much convinced I would go with AMD for an all team red setup. Now I know it's going to be a green-red "Christmas" setup as I won't be returning my new Ryzen as nothing is physically wrong with it (though I now start to regret not sticking with Intel) but will most likely go back in the Nvidia camp for the GPU.

If this message helps raise the priority of this issue in your issue-tracker software and means a more expedient fix for me and my comrades here, it will have achieved it's purpose.

In any case, thank you for having taken the time to read through my story.



Adept I

Unfortunately in Europe, we normally have 30 days return policy. First I thought I fixed the problem with registry setting fix. But later I found out the driver also crashes - I didn't know the green picture on YouTube video was the symptom of this. Now the return window is closed an I am stuck with a GPU with 2022 drivers and I just lost hope that this will ever be fixed.
The thing is - they know that the breaking changes were introduced with 2023 drivers. They could just ask one user in here to install some development driver version with logging enabled a few times to pinpoint the problematic driver code if they can't reproduce the problem themselves. As most of us here do not have a problem reproducing this bug.

And is not easy to judge because we don't know their SW development process or code architecture - but normally some sort of procedure must exist for debugging issues like these. But it seems what it will just be one of those bugs what will be in Open state for a few years and then closed with "Won't fix" status.