cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Flea
Journeyman III

Monitor enters Power saving mode

Hi!
I have an RX 6800 (Asus TUF 6800 OC) and I am trying to use a third monitor I got for free (old company monitor). I have the following setup:

DisplayPort 2 (seems to be the main port, shows POST) -> Main Monitor LG Ultrawide 3840x1600, works fine
DisplayPort 3 -> Dell P2213 1680x1050, this one goes into Power saving mode
HDMI -> AOC 1920x1080, works fine, does not have DisplayPort

The Dell monitor immediately goes into Power saving mode.
All 3 monitors show up in Windows 10 display settings and in AMD Software. Monitors 2 and 3 are set to extend. I can move my cursor to the inactive monitor.

What I have tried:

- Input set to DisplayPort
- Intput set to AutoDetect (detects DP cable, but still no signal)
- Factory reset the monitor
- unplugged everything, held power button to make sure clean power cycle
- turned on/off DDC/CI
- Change DP and power cables (including swaping with working LG DP cable from main monitor)
- changed Ports on GPU, several configurations
- changed resolution - weirdly it worked for a while with lower resolution, after I changed it it stopped working
- disconnect the AOC monitor
- Reinstalled newest drivers (removed previous with DisplayDriverUninstaller in safe mode)
- tried older drivers (from 2022 and 2021)
- disabled some UltraLowPower setting in the registry (found on the internet)
- set Windows Power plan to High Performance
- fresh Windows 10 install on a spare SSD

The following makes me think it may be a driver issue.
- boot with only Dell monitor on port 2: The monitor shows POST and BIOS and goes into power saving mode after Windows boot
- boot into Windows safe mode with Dell monitor only: Monitor works fine, full resolution, but only the main port on the GPU is active

The Dell monitor doesn't have HDMI, but DVI. I ordered a DP-to-DVI cable. If that doesn't work I don't know what else to do.

Thanks!

 

EDIT: I found some more weird stuff...

When I set the Dell monitor to 1024x1280 resolution (only on this one) it gives me the option to choose 75Hz under Advanced display settings in Windows. The monitor only supports 60 Hz, but my main LG monitor is at 75Hz. It works but it doesn't use the whole display because of the weird resolution. BTW I am trying to use portrait mode, but nothing changes on landscape mode.

 

EDIT2: I finally found the solution. https://www.dell.com/community/Monitors/Monitor-AMD-Radeon-not-working-with-DisplayPort-cable/td-p/7...

I created a custom resolution in AMD Adrenalin with 1680x1050 60Hz and changed the timing to GTF. Everything works now.

 

0 Likes
1 Reply
ViperForce64
Journeyman III

THANK YOU SO MUCH!!!

I have been searching all over for a solution to this EXACT problem, with the EXACT same monitor. Your solution worked perfectly.

 

0 Likes