cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

omega552003
Journeyman III

Minimum Kernel version for AMDGPU-Pro drivers?

Is there a list of AMDGPU-Pro ver's kernel versions? This is a rough list of what I have found so far from what people said worked. I've found the OpenCL is super finicky about the kernel version its running on.

AMDGPU ver.Kernel ver.Notes
16.20.34.4.0-22Beta driver
16.30.34.4.0-34 
16.404.4.0-47 
16.504.4.0-51 
16.604.4.0-59 
17.104.8.0-46 
17.10 (429170)4.8.0-54 
17.204.8.0-56Frontier Driver
17.304.10.0-27 
17.404.10.0-37Beta Mining Driver
17.504.10.0-42 
18.104.13.0-39 
18.204.15.0-23 
18.304.15.0-32 
18.404.15.0-39 
18.504.15.0-42 
19.10  
19.20  
19.30  
19.505.6.0-999 
20.205.4.0-26 
20.305.4.0-52 
20.405.4.0-54 
20.45 (1164792)5.4.0-54 
20.45 (1188099)5.4.XPatched for newer kernels
20.505.8.0-45 
21.105.8.0-50 
0 Likes
1 Reply
Roesjka
Journeyman III

Re: Minimum Kernel version for AMDGPU-Pro drivers?

I am running Debian testing with kernel 5.10.0-6-amd64, xserver-xorg-video-amdgpu and firmware-amd-graphics from the Debian repo. Probably the same with the Ubuntu repo. The latest kernel I think you can use with amdgpu-pro-21.10-1247438-ubuntu is the one used by ubuntu 20.04 or 20.10. The kernel used by 21.04 is not supported yet afaik.

For Debian I only needed the driver for OpenCL (for mining) and installed it with the following command, Ubuntu hirsute should be the same:

amdgpu-install --opencl=legacy --headless --no-dkms

If you are using Vega or higher you can try

amdgpu-install --opencl=legacy,rocr --headless --no-dkms

cheers

0 Likes