Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Memory leak minecraft 1.7.10

Minecraft is totally unplayable on 1.7.10 it litearly eats ram just by loading chunks then glitches and finally crashes, when using the old whql 22.5.1 it works perfectly without any issue.

it is reproducible just by loading chunks, for me took ~15 min straight with world type: AMPLIFIED selected.

it happens way quickier on a modded version.

2023-04-23 06_08_27-Minecraft 1.7.10 (Not Responding).png

7 Replies
Adept I

This happens in all versions of minecraft before the release 1.8.
I use a 5600g APU, on Minecraft Beta 1.7.3 java takes 30-60 minutes to eat up 8gb ram and glitch out. Just tried the 1.2.5 release version and it took about 2 minutes.
The problem seems to be caused by a recent driver update, since all the reports about it are relatively new:

As one reddit user said, here's what's probably causing the problem:
"This is also made more likely by the fact it seems to be correlated to chunk updates, which involves sending data to the graphics driver and it may have issues with handling display lists (after all, they were deprecated in 2008, even before Minecraft was developed, and AMD and Intel are notorious for poor OpenGL support, even with newer versions. A good way to test this theory is to run release 1.8 (not Beta 1.8) with and without VBOs enabled and see if the issue still occurs both ways)."

I have already reported this with AMD Adrenaline and have received 3 updates since then. No change at all.
I'm so glad I'm using apu and didn't buy their dedicated gpu. The amount of drivers problems are insane

Same idea about broken displaylists, memory is not freeing for some reason. I'm was playing on the modded servers and it's enough even 5 minutes for client i'm playing to eat up to 20gb of memory(VRAM, Virtual and RAM). I'm tried to use custom logger and found out that memory is freeing pretty rarely for some reason, and when there's no free VRAM left, client starting to use auxiliary memory (usually combined both virtual memory and RAM in my case), and after that when there's no auxiliary memory left you're able to see that chunk glitches

I'm tried to profile minecraft with Java Mission Control, VisualVM but both shown absolutely nothing except JMC that shown total memory taken by JVM process that was 10 times more than allocated heap (Xms/Xmx args) or Permgen, also nothing was happening in the other memory regions, and they was pretty small to be related to this issue. Already reported that to the support but not sure will they fix this or not

Journeyman III

hello forum
Through a long search, I managed to fix this problem and how to clear the devoured memory
To do this, you need to download amd Adrenalin version 22.6.1 or below

After looking at the release notes of the adrenaline version 22.7.1, I noticed that with this version the first request to minecraft comes
I can not assure you that this is the problem, but drivers up to this version work stably and without memory overloads!


Thank you. This not only helped, but also did not reduce performance in the new version.


Helps. But this is not a solution to the problem, since in version 22.6.1 and below, performance drops by about 2 times in the same version 1.7.10.


I'm getting driver crashes when using chrome on this driver version, so yes, this is not a solution.
But AMD accepted this leak issue

Journeyman III

Any Updates?