cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Ineke
Adept I

How to get my AMD HD7970 working on windows 10?

Hi everyone! 

So, i decided to install Windows 10 on an old PC. 

It's a Clevo P170EM, with Intel core i7-3630QM Cpu (8), and an AMD7970 (M) graphics card. 

I tried various things, but no luck so far. Does anyone have any idea how i could solve this?  

Below, the things i already tried, and failed. 

1. From the OEM i downloaded all their recommended drivers for this machine, for windows 10, 64 bit. I installed the Intell Chipset drivers first, and then updated them directly with the Intel site, so they are fully up to date. The Installed Intel Driver now is version 15.33. 

2. I Downloaded the Adrenaline 22.6.1 program for legacy drivers and tried to install. Install freezes during installation, also when internet connection is offline. I also made sure Windows update does not automatically update hardware anymore, by setting that option to No in advanced system settings. 

3. I removed all AMD install data using DDU in safe mode, rebooted, downloaded various previous versions of Adrenaline (19.1.2 and later 18.12.1), and tried installing them with another frozen screen as a result, and me going back in safe mode and deleting everything AMD with DDU. 

4. I downloaded the Graphics drivers for windows 8 from my OEM. This one actually managed to install itself fully. In Device Manager the ADM card was recognized, however, upon rightclicking it it tells me it's not functioning as it should, since the driver is not compatible with windows 10. I Tried from this point to use Windows Update to my benefit, but this didn't work. Windows Update did find a new AMD driver, and downloaded it by itself, however upon installing it (you can probably already guess what happened): my screen froze. 

5. Before step one, i also tried more stuff:  first I installed all drivers recommended by the OEM for windows 10, but there was no AMD driver included in their software. I didn't update the intel chipset to the latest version, but kept the one recommended to me by the OEM. Then i tried installing the original driver (this used to be a Windows 7 machine), but that again froze my computer. They also had an updated version of the driver (7970M) but that also froze. I cannot remember if it was during or after install. 

6. I read online that my Bios should be up to date. However, i cannot find a bios update for this system anywhere, since it's quite an oldy. I did contact the OEM about this, and am still waiting for response. My current Bios is American MEgatrends inc. 4.6.5 22-8-2012, SMbios 2.7, with out of date Bios modus. 

So, quite a challenge to get this baby up and running. 

Anyone any tips on how to proceed? I would be very grateful. 

 

Kind regards, 

ineke

6 Replies
schldskjoirz
Adept III

Try installing the Radeon driver without Adrenalin by selecting the option 'Drivers only'. If that works, then Adrenalin itself is in conflict with something.

If you need to update the bios, see here if you can find a suitable one: https://my.hidrive.com/share/yze8mg-wf8#$/BIOS%20and%20EC%20Firmware/CLEVO

░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
• 5900X • 6900XT • X570 • NH-D15S • 16Gb@3600Mhz • 1000W • 65" TV (HDMI) • Sony 5.1 audio (toslink)
0 Likes

Thanks! I'll try it out and will let you know. Just got a reply from the oem that Clevo no longer provides the bios I'm looking for, neither the original win7 or the update for win 10.

So any suggestions are welcome indeed. I'll try it and will let you know! 

0 Likes
Ineke
Adept I

So. Just installing Drivers Only didn't work. During installation, with 0:12s left on the clock, it froze. 

So i decided to do the bios update. I downloaded to one i needed for P170EM and managed to install it (was sweating a bit there). I see that the only thing that changed after this update is KBC/EC firmware. The bios of the system is still the same version. 

I thought, maybe the video card itself is broken, so i checked if it is visible in the bios, before and after doing the bios update. The card itself is seen in the bios, but just not in windows. 

I'll try to update the Vbios. However, before the bios update i tried this, and it didn't work because i had issues with Atiflash not doing what it should. I thought this may have to do with the fact that Windows doesn't recognize the AMD card. It just displays the Generic Display in Device Manager. 

Not sure how to procede. I'll try again to update the vbios and will let you know. Otherwise, very curious about any other ideas you may have. 

Thanks!

 

0 Likes
Ineke
Adept I

So, i've managed to update the Vbios to the newest one available at techpowerup.

It's now at version 015.021.000.002.042768 in stead of 015.018.000.000.000000

However, when i check my Graphics card with Device manager or with GPU-Z, it's still not recognizing this AMD card. 

I'm hoping that with the updates on Bios as well as Vbios now the adrenaline legacy Driver install works. 

I'll try that next ....keeping fingers crossed.

 

0 Likes
Ineke
Adept I

i did have to this in pure Dos though, since if i tried in windows or in prompt i got messages like 'not compatible with windows'......This could be another hint towards a possible solution. 

 

0 Likes
Ineke
Adept I

So, no. It didn't work. The screen freezes when Adrenaline 22.6.1 is installing (this time with 3min on the clock). And then it's done. Please let me know if you have any other ideas. 

And hey, it took me all day but now i know how to update bios and vbios and create a pure Dos system booting from USB. Geekskills UP!

0 Likes