Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Forza Horizon 3 issue

Describe your system:

AMD Graphics Card

  • XFX RX 580 GTS XXX

Desktop or Laptop System

  • Custom built early 2015 desktop

Operating System

  • Windows 10 64bit

Driver version installed

  • Radeon Adrenalin 18.4.1

Display Devices

  • Hannspree HS241HPB (No freesync, 60HZ) via HDMI

Motherboard + Bios Revision

  • Asrock H97 Pro4, Bios v2.10


  • Intel i5-4460

Power Supply Unit  Make, Model & WattageRAM

  • XFX TS 550W

Amount of memory installed;

  • 8 GB RAM

Hello everybody, I tried and tried but didn't manage to solve the problem. I used a Sapphire r9 280x until a few days ago, which worked fine playing the game. However, as soon as the new rx 580 arrived, I had a bunch of problems with forza horizon 3: with latest drivers (18.5.1 and 18.5.2) the game doesn't start at all, it stops while "optimizing for your pc" at 88-89% and it crash to the desktops. With older drivers, the 18.3.1 and the 18.4.1 I'm currently using, the game starts fine and has good framerates too, but within 30 minutes it freezes and crashes to the desktop. I reset the game, uninstalled and reinstalled it, moved to another drive (i tried both hdd and ssd, hdd is unplayable) with no positive result. Currently i'm playing on ultra (dynamic/automatic mode), but i'm willing to sacrifice some details if it can help. The card is overclocked to 1420 Mhz core, 2250 memory, it ran the benchmarks and other games very well (no problems). Thanks in advance.

Edit: just tried with 2x msaa and less anisotropic filtering, the game ran for 6 laps (of 6 total... i'm very lucky) of goliath run before crashing, so  ~ 1 hour. Any tips?

Messaggio modificato da Hangingardens

10 Replies
Journeyman III

Update: uninstalled and reinstalled again, changed the details to high, still freezing and force closing.

yes...i too have the same issue i'm using rx 560x 4gb,ryzen 5 in my acer nitro 5 laptop.All the games are playing good at high but forza Horizon 3 is freezing..hardly completed a lap until it freezes tried medium setting also still the issue raises.amd455

Journeyman III

I had same problem. FH3 stuck on "Optimizing for your PC". I use R9 390 graphic card. And had driver version 18.8.1 (latest ones).

After i uninstalled drivers and installed older ones 18.3.1, I can play again, and game gets through "Optimizing for your PC"

I would just like that newest drivers fix this problem, and I don't want to have outdated drivers just to play this game...

how many moths does amd radeon takes to give an update to rx560x many games are not working like origins,atch dogs 2 and even photoshop is not working...i ran out of patients waiting for updates i will not recommend anyone radeonj graphic card in my gng to sell this useless thing and buy a nvidia laptop

Journeyman III

I can confirm that game stucks at "Optimizing PC performance" on drivers 18.8.1 and 18.5.1.

Its a shame, that we have to install old drivers to make this game work...

EDIT: After uninstalling 18.5.1 by Windows Applications "modify" option, and installing 18.3.1 game still did not start. I had to use Display Driver Uninstaller, then i installed 18.3.1 and game is finally starting. I havent tried it, but maybe this would also work with newer drivers.

i dont under stand what amd is doing e are facing so many isue and they not even responding and giving any updates..adobe photoshop,obs recoder nothing is working with graphic card


even the older drivers has problem. I just found one the screen is flickering randomly sometimes and evil within is laggy . pls anyone contact acer or amd and request them to give updates...


I have found the genuine solution for Acer Nitro AN515-42 AMD Laptop [ Ryzen 2500U + Vega 8 and RX560X ] driver problem affecting multiple users.

After updating to the version [revised] from trax, i was getting little bit poor and fluctuating FPS in games although color discoloration problem was resolved. Thanks to trax again.

Permanent Solution is to clean install Microsoft WHQL Certified AMD driver from the Microsoft catalogue page. Here are the steps :

1) Download AMD Clean Uninstall Utility from the page AMD Clean Uninstall Utility

2) Download the UPDATED DRIVER [ 6/16/2018 with driver version 23.20.826.3072 and a file size of 265.3 MegaBytes ] below

Microsoft Update Catalog

After visiting above microsoft catalog page, you will need to click on the Last Updated filter to Sort drivers in the descending order

3) Disconnect internet and run AMD Clean Uninstall Utility. This will UNINSTALL your AMD Chipset drivers and ALL AMD GPU Drivers. DO NOT PANIC and after uninstall utility is finished doing it's work, REBOOT THE COMPUTER

4) After laptop reboots, screen resolution will be less since Microsoft basic display adapter will be the GPU Driver now.

5) CONNECT INTERNET AND RUN WINDOWS UPDATE which installs AMD Chipset and Microsoft WHQL Certified AMD GPU Drivers

6) Extract the UPDATED DRIVER CAB file using 7zip software to your HDD. [ one folder named B330055 and 2 files named and U0330186.inf MUST BE PRESENT ]

7) Go to device Manager and right click AMD Radeon vega 8 graphics -> Update driver -> browse my computer for driver software -> let me pick from a list of available drivers for my computer -> HAVE DISK -> Browse to the file named as U0330186.inf which MUST Be present within the driver folder extracted as per previous step -> CLICK OK -> Select AMD Radeon vega 8 graphics -> CLICK Next and if any driver warning appears click ok and install driver. This will install driver for BOTH Vega 8 and RX560X Combinations.

8) After driver installation, REBOOT THE LAPTOP

9) you will observe that AMD RADEON SETTINGS Will not be present. To install this, go to the place where you extracted Updated driver and there in folder B330055 you will see ccc2_install.exe file.This is our AMD RADEON SETTINGS and double click ccc2_install.exe file and follow the prompts. After AMD RADEON SETTINGS Installation, REBOOT LAPTOP

After folowing this some games run good but OBS and photoshop are still not working with rx560x


the .cat numbers changed and they are not working can you help... if you have the old drivers as you mentioned i your post pls upload them to google drive and share link that will be helpful


Im abroad right now,

i can check when i will get home (~2 weeks) but unfortunately i think i dont have installer anymore.