Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

EX3203R Freesync 2 monitor does not show 120hz option on RX 5700 XT

Benq EX3203R Freesync 2 monitor does not show 120hz option in windows 10 (only 60hz) on Sapphire Nitro+ RX 5700 XT when set to Freesync Premium (10-bit mode) on the monitor.

This happens on all driver versions and did not take place on my previous Vega 64.


I contacted Benq and Sapphire, but both of them say it's not an issue with either the EDID profiles nor with the vbios as they refer me to AMD.

I already issued a bug report via radeon software, but I wanted to ask when is this going to be fixed????

1 Solution
Community Manager

This issue is now resolved in 20.4.1, appreciate your patience folks.

View solution in original post

45 Replies


Are you sure your DP cable is up to the task of producing both 10-bit color as well as 120hz refresh rate?

I have the Samsung C49RG9X monitor which supports Freesync 2, 10bit and 120hz. But, when you choose 10bit there just isn't enough bandwith in the DP cable to run at 120hz so I have to go down to 100hz to activate Freesync 2 when I use 10-bit. I am using the Samsung DP 1.4 cable that came with the monitor.

Try 100hz with 10 bit and Freesync 2, does that work?

Try 120hz with 8 bit and Freesync 2, does that work?

Try 120hz 10 bit and Freesync 2, does not work? Then try Freesync, see if that works with 120hz and 10 bit.

Not a solution, but could be an explanation to the issue.


I have a premium Lindy DP cable and it was never an issue with my former Vega 64.

I can only select 60 hz in the menu when in 10 bit mode. 100hz and 120hz does not even show up for selection in the monitors settings. It is a software problem.


I did not take into account the lower resolution of your monitor compared to mine. My mistake, you should have enough bandwith then.

What you say is that windows will not let you choose another refresh rate, you are stuck at 60Hz when in 10 bit mode?


Yes, exactly that.


Dum suggestion; Try to reinstall the monitor driver.


So far I have done the following as suggested by Sapphire:

1. Update motherboard to latest version.

2. Clear motherboard CMOS.

3. Update motherboard chipset driver to latest version

4. Make sure the Windows OS you are using up to date with all patches release from Microsoft. (I'm using Win 10 1909)

5. Remove all you previous card drivers (Nvidia or ATI drivers)

6. Install Adrenalin 2019 Edition 19.9.2(WHQL) driver

7. Install Adrenalin 2019 Edition 19.7.2 driver

I also used DDU before installing drivers. The issue persists since the first RX 5700 XT driver up till today.

Both Sapphire and Benq didn't take the blame for this issue.

I've seen a post on this forum from a person that had this issue but the problem is still there after a few months. :-(


Now i read monitor driver.. Yeah I reinstalled that too a couple of times. No luck..

Adept II

I can add the 120hz option manually with Custom Resolution Utility, then it works. It would be really nice if it worked out of the box though!

At least you got it working. Well done. 

Adept I

same monitor benq ex3203r

When I use Radeon VII graphics,my monitor works at 2K120HZ freesync2,everything is normal

but when I use 5700XT my monitor only works at 2K60HZ 

I changing two 5700XTs of different brands has the same problem

I think this should be a problem with the driver

I'm a bit disappointed with AMD's graphics card

Journeyman III


I have exactly the same problem.

In the monitor settings you find Freesync "premium" and Freesync "normal"

If Freesync Premium is activated you won't get 120hz. But you can choose between 6 to 12 bit colour.

If you disable Freesync Premium you get your 144hz but only with 8 bit colour, the rest is not possible.

A problem with the cable is not the case because everything worked (Freesync premium, 120hz with 10 bit) on my older RX580.

I will try to add the setting manunally. Also contacted AMD, Sapphire and BenQ.

AMD thinks its a hardware failure (WTF????), BenQ wants me to write an email (will do that later...) and Sapphire does not know whats going on, but they said this won't be a hardware issue.

Incredible how stupid it can be sometimes...

Yeah, the blame-shifting is what's really infuriating...

Community Manager

Thanks for the post, i have filed a ticket with engineering on this issue. 

According to the monitor documentation, with FreeSync Premium (+HDR) enabled, the maximum resolution and refresh rate supported should be 2560x1440P @ 120HZ.

Community Manager

We tested this and were not able to reproduce the issue, 120HZ is available to select via Windows Display Properties with FreeSync Premium enabled on the monitor. Please refer to the attached screenshot. 


Tested on 20.2.1 + Navi10 XT + Benq EX3203R "FreeSync Premium".

If the option is not available in Windows Display Properties, it could indicate a bad DP cable. 


Zrzut ekranu (3).png


Tested on 20.2.1 drivers and 3 different DisplayPort cables (one of wich is Premium)... I see that the timing info is different on Your monitor and mine..

This feature worked with my former vega 64 with the same monitor and cable... Please tell me why... 


Thanks, I'll seek feedback on this and get back to you. 


Ok, I rechecked my Lindy CROMO DP cable and it's specification is 1.2 instead of 1.4.

This shouldn't be a issue because, again, it wasn't before with my Vega 64 but I may have to buy a 1.4 cable next week just to make sure..

I was sure it was version 1.4, so I am sorry for misleading information.

I'll get back to You once I have the new cable and more info.

Thanks, please test a certified 1.4 DP cable and let me know the results. 


I have a DP 1.4 cable now and the results are more or less the same. The new 20.2.2 driver has maximum refresh rates of 60 hz and lower for ALL resolutions, when the monitor is set to FreeSync Premium mode.

Zrzut ekranu (4).png

Thanks, will pass along feedback and we will continue investigating. 

hi,When I use Radeon VII graphics +EX3203R,my monitor works at 2K120HZ freesync2,everything is normal

but when I use 5700XT my monitor only works at 2K60HZ,same DP line

Please pay attention to current link setting in mokurai82 picture,only 2.7Gbps*4,I same problem

Radeon VII + EX3203R = current link setting working 5.4Gbps*4

5700XT + EX3203R = current link setting working 2.7Gbps*4   same DP line

I tried different DP line and HDMI line and Several versions drivers,The problem is still,I think not lines problem

I changing two 5700XTs of different brands has the same problem

so i think driver problems

I am chinese,so i am english not good ,Hope you understand what i mean

Thanks, I'll pass this information on. 


It's showing "current" not "max" link settings.

If your Radeon VII is using 144Hz, then it will be higher than if you are using 60Hz.

Set your Radeon VII to 60Hz and you should get the same link settings as RX 5700.


Ok didnt rtelise we were on this post  when my monitor is exchanged I will post results I can see you have 120hz  dosnt show on mine  thanks  Ticket #2389142

also noticed that freesync refresh rate under link status  is missing on mine  

2020-02-27 17_11_22-Window.png


What happens if you select 4:4:4: RBG?


the same matt no change 

I did just switch  cable to far right hand side on 5700  looking from back and now hdr switchs with premium on but still only 60hz max


2020-02-27 17_52_50-Window.png


Ok  I have freesync refresh rate showing now but still 60hz max  20.2.22020-02-28 15_23_58-Window.png


What DP cable are you using?

Is there anything on the monitor OSD options about changing the DP mode? For example, DP 1.2 to RP1.4?

Can you try an monitor OSD restore to default settings as well. 


Cable is Club 3D 1.4 HBR3 

DP is set to 1.4 

Have reset monitor ,, no change 



I do hope some progress has been made on this matter ?


current link setting working 2.7Gbps*4,I same problem

I have tried this on two different DP cables and HDMI cable

As long as the 5700XT is used, it can only work in DP1.2 mode no matter what cable is changed.

Radeon VII current link setting working 5.4Gbps*4


ok what cable are you using ??


Hi Have received my replacement ex3203r  and there is no difference at all  Apart from hdr does not switch on when selecting freesync premium I still have both so swapped round just to confirm this so I am using the original which switchs on HDR at 60hz only but still NO 120hz freesync premium on both monitors 

Why is this thread marked as answered? we are only half way there ?

I'm not sure. it says "probably resolved" but I haven't clicked on anything.


amdmatt‌ Can you try reproducing the issue with Alienware alienware aw2518hf?

When u go to create a custom resolution in adrenaline it doesnt allow you if you change the value of HZ from 240 to anything and then try to set it to 240 again it wont accept it, it will only accept up to 200hz why is this happening? is this the reason im microstuttering? and i feel like my freesync is not working as it should?

Journeyman III

Hi all. Reached this site looking trough this problem too. Im not able to get 120Hz and i noticed in the Radeon Software, that the "Current Link Settings" says 2.7 Gbps x 4, instead of 5,4 x 4. So, i cant see 120Hz on my screen options, only 60Hz. Card its Sapphire 5700XT and the cable its a Club3D HBR3, the same as in a photo above. amdmatt‌ could you give me a hand please? Drive its the latest one, 20.3.1


Don't have a solution for you at this time, but we are still looking at addressing this issue as we were able to reproduce it. I will be back to update the thread once i have more information to share.