cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mcseem
Journeyman III

Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

I used driver AMDGPU Pro 19.30 during long time in Kubuntu 18.04 LTS. I work with Unity 3D engine 2019.3.0f6. I recently updated driver up to 20.10. But now, I can't launch my Unity projects (runtime), I get the error "munmap_chunk(): invalid pointer". Previous version of AMDGPU Pro driver (19.30) worked fine with Unity 3D runtimes. How can I fix this problem?

5 Replies
qnerd
Adept II

Re: Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

Yes, I noticed this too. 

Just try to start Albion Online (linux version, The Fantasy Sandbox MMORPG | Albion Online ),

and you will see the error message mentioned above.

qnerd

mcseem
Journeyman III

Re: Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

It seems to me that it's necessary to solve this problem both on the Unity 3D develop side and on the driver realization side. A similar problem also exists on the official forum Unity 3D.

0 Likes
qnerd
Adept II

Re: Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

For what it's worth, it does work with the amdgpu driver 20.10 non-pro installation, as well as with the all-open variant that is shipped with Ubuntu.

qnerd

0 Likes
yujikosuga
Journeyman III

Re: Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

I found a workaround -- it's for AMDGPU Pro 20.20 on Ubuntu 20.04 but it can also work for other versions of drivers and OSes with some small fixes or without any. Make sure uninstall the one previously installed and run these commands at your own risk.

$ sudo apt install dkms libva2
$ sudo dpkg -i amdgpu-core_*_all.deb amdgpu-dkms-firmware_*_all.deb amdgpu-dkms_*_all.deb amdgpu-pro-core_*_all.deb amf-amdgpu-pro_*_amd64.deb clinfo-amdgpu-pro_*_amd64.deb libdrm-amdgpu-amdgpu1_*_amd64.deb libdrm-amdgpu-common_*_all.deb libdrm-amdgpu-radeon1_*_amd64.deb libdrm-amdgpu-amdgpu1_*_amd64.deb libdrm2-amdgpu_*_amd64.deb libgl1-amdgpu-mesa-dri_*_amd64.deb libgl1-amdgpu-mesa-glx_*_amd64.deb libglapi-amdgpu-mesa_*_amd64.deb libllvm10.0-amdgpu_*_amd64.deb libopencl1-amdgpu-pro_*_amd64.deb mesa-amdgpu-va-drivers_*_amd64.deb opencl-amdgpu-pro-comgr_*_amd64.deb opencl-amdgpu-pro-icd_*_amd64.deb opencl-amdgpu-pro_*_amd64.deb opencl-orca-amdgpu-pro-icd_*_amd64.deb vulkan-amdgpu-pro_*_amd64.deb xserver-xorg-amdgpu-video-amdgpu_*_amd64.deb

Note:

  • My GPU is RX 580.
  • The non-pro version or the all-open variant weren't my option because I needed to use amf-amdgpu-pro (available only in the pro version) for hardware acceleration when running Unity 3D runtimes. 
  • With the driver installed by the "amdgpu-pro-install" script, simple Unity 3D runtimes that I created on Unity 2019.4.3f1, 2019.3.15f1 and 2018.4.24f1 raised the error 'munmap_chunk(): invalid pointer'. After my workaround driver installation, the issue was gone.
  • I suspect "libgl1-amdgpu-pro-appprofiles" and "libgl1-amdgpu-pro-dri" caused the issue because installing them generated the munmap_chunk() error --- I would like AMD folks to dig in further, please.
kesed
Journeyman III

Re: Error 'munmap_chunk(): invalid pointer' with Unity 3D runtimes under Linux on AMDGPU Pro driver 20.10

This problem has been fixed for me with the 20.40 driver on Ubuntu 20.04.1