Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

DX11 Applications crash on 17.11.1 and above for A8-6410 APU with R5 M230


My Configuration


Lenovo G50-45 Laptop AMD A8-6410 APU with Radeon R5 M230 as Primary and HD 8500 M as the discrete.




Immediate Crash on all tested DX 11 Applications, they simply crash on launch. Do not even load. Non OC'ed .

Event Viewer Log


Faulting application name: heaven.exe, version:, time stamp: 0x511b9e02

Faulting module name: aticfx32.dll, version: 23.20.788.0, time stamp: 0x59fb6507

Exception code: 0xc0000005

Fault offset: 0x00041ec4

Faulting process id: 0x239c

Faulting application start time: 0x01d383b5e8b8854a

Faulting application path: C:\Program Files (x86)\Unigine\Heaven Benchmark 4.0\bin\heaven.exe

Faulting module path: C:\Windows\System32\DriverStore\FileRepository\c0320046.inf_amd64_8e8f6af872d98101\aticfx32.dll

The above log is from the 17.11.1 - Nov 10 driver , but the crash logs are same on all drivers on and above this version.

Tested Apps


Uningine Valley, Uningine Heaven benchmarks and Tom Clancy's Rainbow Six Siege

Isolation Done


Siege doesn't start, simply crashes. Benchmarks run fine on OpenGL mode or DX 9 mode, only crashes on DX 11 mode immediately on start.

Tried Recommendations


Clean install, used AMD clean install, display driver uninstaller and also ( Just as a sanity check ), a clean windows install.

Driver Versions


17.7.2 - July 27 to be the last working version. Every driver above that if i remember correctly has this issue,including the Adrenaline Release.

I have already contacted the AMD tech support regarding this, and after around 7 e-mail exchanges with me mentioning repeatedly that I would love to be able to use newer drivers, I was finally requested to use the driver that my manufacturer releases. Unfortunately that driver has horrible performance and is a 17.1.1 driver. Way too old. I am putting the post here after a lot of trials from my side in the hope that someone could maybe help me debug this, it could still be an issue on my side, and help me use newer drivers on my laptop or ( in the unlikely case ) if it is an AMD driver issue, someone from the team could fix it on their end. I know I am using a crappy laptop and a very low end GPU, but any help at all would be very very appreciated.


1 Solution
Adept II

The problem solved with new 18.2.1 , this driver supports APU systems

Lenovo G50-45 A8-6410 , R5 M230(8500M)

Download from there

View solution in original post

23 Replies
Adept II

Try Adrenalin Edition 17.12.1 , I have not problem with this driver


Hey, is yours the exact same configuration as mine ?

Because I've already tried the Adrenaline 17.12.1 on my laptop and the error persists. What is your configuration?

Yes I have the same Laptop with A8 6410 -R5 M230 , radeon 8500M
Windows 10 1709 (fall creators update)


This is very interesting. So it might be an issue on my side or could be cause of a different laptop make. Mine is a Lenovo G50-45. If you don't mind, can you attach a dxdiag log please. I would like to see if I can find something from it. And yes, I am on build 1709 too.

Thank you.

Sorry for my delay, yes you are right

I have the same problem , I didn't know that games that I tried wasn't directx 11 games
But today I ran The Walking Dead The New Frontier (directx 11 game) and yes I have crash on launch too (With High Performance)
With  Power save option works .....

My Laptop Lenovo G50-45 , exactly the same as yours
3D viewer crashes too (with high performance)


Maybe AMD is going to drop support for DX11 games there too old now


i got that thing same as you bro.
i use adrenaline 17.12.1 want to play some DMC 4 SE and saints row the third
and i got that 'aticfx32'
i don't know what to do.


Is your laptop a Lenovo make ? Mines a Lenovo G50-45.

Can you try installing Heaven benchmark by unigine and run a DX11 API benchmark? If it crashes on start, then we might have a common problem as you mentioned.

If you want a temporary workaround to our problem, roll back to a 17.7.2 July 27 driver. You can find it on old AMD driver releases page.


mine is ASUS.

The thing problem i believe is aticfx32.dll
I've been testing with and without AMD Switcahble Graphics. You know what the result? its worked without my 2nd GPU (Dual/Switchable Graphics) but sadly a lags for sure. when i switch it to my 2nd GPU on run its crash at startup. I've been test saints row the third cuz there's an option running with DX9 and 10/11
DX9 seems running but lags shuttering (i believe with recent news that adrenaline driver cause this). And then using DX10/11 with switchable graphics no result.

Simple DX11 on my driver doesnt work correctly and keep crash with aticfx32.dll

I stick with the new driver throw.


So now we need to get this to the notice of an AMD representative since it might be a driver fault. Does anyone know how to get this mentioned to some community moderator or AMD representative? Maybe they can help us more with this.

Adept I

Laptop Lenovo 110-15ACL - AMD A6-7310 with AMD Radeon(TM) R4 Graphics & AMD Radeon (TM) R5 M430. OS Windows 10 Home x64 16299.125, installed ALL WU, and ALL DirectX! When installing the driver 17.12.1 or 17.11.1 for APU (driver ver. 23.......) ALL games starts with black screen without error, BUT in event error "aticfx64.dll". Вut when i installed for APU AMD Radeon(TM) R4 Graphics 17.9.3 (driver ver. 22.19.677.257) or any driver ver. 22....... , ALL games & apps perfect work. On discrete AMD Radeon (TM) R5 M430 installed and work any ver. driver, now I use 17.12.2 only for R5. How fix it ??? P.S. (But as soon as I turn "Force WARP" on DXcpl, game starts , BUT VERY LOW) Sorry for my english

Yeah, it could be the same problem as on mine and @undetakerize . I hope some community moderator or AMD rep gets to see this. I do not know who to mention to get this to AMD's notice.

Adept I

ray_mali_d​​ , I apologise to directly mentioning you people here. I hope it is not considered rude, but I would love it if you guys could also take a look at this. Seems like this issue is very easily replicated on R5 M230 by all the people who have replied and I would like to hear your response if possible.

Thank you.


There are established methods to report driver issues to AMD:

AMD Issue Reporting Form



Hey. Thank you for the reply. I have already submitted this once in the past sometime during early November I think. But there has been no mention of this, not even a confirmation saying they have taken note of this issue. So I have been waiting for newer driver releases. When even the Adrenaline version had this issue, I had even gone to the extent of making a complete clean install because I thought the issue was on my side. When even the clean install failed, I have put up a thread here, and thankfully, it is being reproduced on other systems too.

I have, as you have mentioned, submitted the issue once again just now like you have mentioned, but is there any way for me to know that the AMD driver team is going to give two cents on this issue of ours ?

I mean, I would understand, there's probably not enough people at hand to take care of old models such as these, but at least a response from them would be welcome.

Just a small update for those interested.

AMD service has responded to my email and has reported the issue to the internal driver team finally yesterday. So there is a very high possibility that our issue will get fixed. I'll keep updating this post if I get any further information.

Good news

Journeyman III

Sorry to bump this thread but I have the same problem and it still persists, I wanted to know if there's news.

My config:

HP Pavilion 15, Processor AMD A8-6410 APU with Radeon R5 as primary and Radeon R7 M260 as discrete, OS Windows 10 64-bit, 8 GB RAM.

The problem is the following: since the latest windows update I had problems with my graphics drivers. Win compelled me to update since it somehow reverted my drivers to 15.1 and the performance decreased a lot, but any driver above 17.11.1 crashes all my DX11 apps on startup (tested on Fallout 4, Dragon Age Inquisition and DMC 4). Not only that, but also the blue screen error "Video TDR failure" appeared.

I think I did everything, downgrading drivers, clean install, and even a Windows clean install and the issue persists. The thing is, the latest working, stable driver for me is 17.2.1 (as suggested when you search for APU A8-6410 in the AMD support page), which is quite old. I wouldn't actually mind to stuck with it (it works fine for me), but since it is an old driver, it causes the random blue screen "thread stuck in driver device", and what's the solution to that? updating to the latest driver. Which crashes my DX11 applications. So... I need help.

I wanted to know if there's any answer from the team to address this bothersome issue. It has costed me so much time to figure out.



No update from AMDs side was given to me yet. I'm still stuck with the 17.2.1 driver too. Luckily, I don't get the thread stuck in driver device issue, (in my experience, a clean install after using DDU helped solve that) but as for the DX11 crash, I have noticed that our card did not get the 18.1.1 optional driver at all, while other cards did. So maybe they have stopped releasing newer drivers because they are aware of this issue and are working on it maybe? Would be nice to hear a word from them, but for now all we can do is wait.


Right, let's hope for the best then (though tbh I can't be very positive regarding AMD drivers lol). Since now I know it's not only me who has the best results with 17.2.1, I'll try to fix my issue with the thread stuck blahblah error, it's the lesser evil. Thank you very much for your answer!


18.1.1 didn't support APU's

18.2.1 supports and works perfect with A8 6410 and R5 M230

Adept II

The problem solved with new 18.2.1 , this driver supports APU systems

Lenovo G50-45 A8-6410 , R5 M230(8500M)

Download from there

Yep. Can confirm 18.2.1 driver solves the issue.

Tom Clancy's Rainbow Six Siege and Unigine Heaven Benchmark, both work now.

Thanks guys for the support and also thanks to AMDs driver team for solving the issue.