Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Drivers not loading on boot

Hello, i have a radeon RX5500XT and when i boot my pc my gpu drivers don't load up. Once i have loaded in i have to reboot the pc 2 or 3 times for it to show up and sometimes it takes more tries to load them. This has been happening since the start. Different versions of the radeon software has not helped nor did buying an NVME as i suspected maybe it was my ssd that was DRAM-less. Does anyone have the same problem or know if i can even fix it? Once the drivers show up everything works fine, it's just annoying having to restart my pc several times every time i turn it on.

Many thanks.

8 Replies
Adept I

Do you get any device manager error codes? Try use a cleanup utility. It wipes your drivers for good, I suggest DDU. Then Clean install your drivers and try again.



PC specs? Make sure you have the 8 pin power connected. 

"It worked before you broke it!"
Journeyman III

searched the whole web to find this..

same problem with msi rx 570 gaming x 4gb

no matter the version, drivers wont load with windows startup, at first it gave a bsod with error code of : THREAD STUCK IN DEVICE DRIVER

now im not seeing this bsod anymore but issue is present, no driver when booted from shutdown or sleep state, and they come back after couple of restarts,

also in my case i cant run my gpu in ufei bios mode , it only works in csm mode.







Journeyman III

I have the same issue with a 7800XT.  After trying everything I thought maybe switching to the 'silent' bios might fix it as I thought it might be an issue with the 'overclock' bios on my Asus TUF card. Sadly, it is doing the same thing with that bios also. I do not think there is anything wrong with the card itself - it must be a driver issue. Deeply frustrating having to gamble on whether the drivers load every time you turn on the PC.


Most likely reason for drivers to be not loaded is that the GPU is not recognized. Failure to recognize GPU can be for many reasons. If you only have the one GPU, then it could be power related, motherboard settings, GPU not seated properly, bad GPU.

If you are using a riser, then most likely it's the riser.


Just the one card, and no riser. I have reseated the card several times, have changed bios settings on my Z790 board to ensure the PCIE is Gen 4 rather than 'Auto', checked that my PSU cables are securely attached and numerous other suggestions found by googling the issue. Like the original poster noted, the issue seems to rectify itself without me doing anything if I just reboot the computer a few times, but I should not need to do that. I have just gone from using a displayport cable to an HDMI cable to see if that makes any difference.


Well, that did not work. What has appeared to work, for me, is just installing the AMD drivers by themselves with no Adrenaline software. I have not had a boot related issue so far and can also successfully wake from sleep on the PC without random black screens, which I could not do before even when the software succesffuly loaded. As it is an Asus card, I am just using GPU tweak for things like altering fan curves etc. So bare drivers only for me from now on.


Sadly, even doing that only fixed it for a day or so, then the boot issue returned. Have returned the card as only had it for a couple of weeks and put my 3070 back in. No boot issues. Back to Team Green for me I am afraid.