Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Dota 2 Crashing AMD Radeon 530

Hi there,

Recently I've been trying to play Dota 2 but the game has been crashing constantly to the point where it's now completely unplayable. This issue occurred instantly after some driver and software updates.

The updates all occured on the 11th of August 2019 and are as follows: 

- Windows 10 update KB4505903 (

- AMD Radeon driver/software update 19.5 (the version has since been updated to 19.8.1 and has made no difference to the issue)

- BIOS update 1.2.3 DELL (Inspiron_5570_5770_1.2.3.exe)

I have a Dell Inspiron 5570 with AMD Radeon 530 discrete graphics card.

I must mention, Dota 2 has been completely fine on my laptop for an entire year since I purchased the laptop on 15th August 2018. Now suddenly, 1 year later after some driver updates and windows 10 updates (and a bios update as I mentioned), Dota 2 is completely unplayable.

The game minimizes itself to the desktop and the video completely disappears but games mouse still stays present, if that makes any sense. 

Only 1 error message has appeared, and it has appeared on a different game: 

ERROR: GRAPHICS CARD HUNG or something similar.

I've also noticed flickering etc.

I've noticed that I can't play with DX11, DX9 or Vulkan as the graphics options (in Dota 2).

But I can successfully play with it set as OpenGL.

For the entire year prior, I've been able to play Dota 2 with DirectX 9 selected. The graphics were very nice. Open GL looks so bad that it makes me not want to play.

I'm pretty upset, I spent exactly $1200AUD on this laptop and it's only 1 year old. I'm quite poor and don't have the money to purchase a new laptop.

How can something just SUDDENLY stop working after I click "OKAY" to updates? I thought updates were a good thing. Clearly not.

I must also mention, I've done plenty of troubleshooting. I've re-installed/updated DirectX9. I've rolled-back the graphic driver to a prior version before the update. The only thing I can't do is roll back the BIOS as it will not let me. So I am baffled as to why this has suddenly occurred.

The most hilarious and depressing fact is, and also ironic, is that my Dell Warranty expired the DAY AFTER all this happened, on the 12th of August 2019. It's almost like it was planned by Dell, but I'm sure that was not the case.

Any help would be fantastic. 

Kind regards,


Below is some additional technical information:

Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - Radeon (TM) 530
Device ID - 6900
Vendor ID - 1002
SubSystem ID - 0810
SubSystem Vendor ID - 1028
Revision ID - C1
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x4
BIOS Version -
BIOS Part Number - BR42924.002
BIOS Date - 2019/03/12 10:56
Memory Size - 4096 MB
Memory Type - GDDR5
Memory Clock - 1125 MHz
Core Clock - 1024 MHz
Total Memory Bandwidth - 36 GByte/s
Memory Bit Rate - 4.50 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001
OpenGL® API Version - Not Available
OpenCL™ API Version - 2.0

Radeon Settings Version - 2019.0808.1917.34733
View Release Notes -
Driver Packaging Version -
Provider - Advanced Micro Devices, Inc.
2D Driver Version -
Direct3D® Version -
OpenGL® Version - 26.20.11000.13570
AMD Audio Driver Version - Not Available
Vulkan™ Driver Version - 2.0.99
Vulkan™ API Version - 1.1.113

Radeon Software Version - 19.8.1
Radeon Software Edition - Adrenalin 2019
Windows Version - Windows 10 (64 bit)
System Memory - 8 GB
CPU Type - Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz

7 Replies
Journeyman III

Same happened to me after updating to Dell bios version 1.2.3. The only difference is that the game that crashes in my case is CSGO. I have an Inspiron 5570 with Radeon 530 and i did try all the different things mentioned on the internet starting with complete reboot,installing drivers after removing with DDU in safe mode. The only thing i cant do is downgrade BIOS to earlier stable version as it is blocked due to unsupported downgrade. Someone pls help.

Journeyman III

Hello, i have exactly the same problem. Dell inspiron 5570 after some updates 3 days ago, new BIOS, new AMD driver and new Intel driver. When i'm trying to play a game (Age of Conan) it always crashes after 1-2 min and i get the message DXGI ERROR DEVICE REMOVED. Tried everything mentioned above, even downgrade BIOS but nothing helped. The only thing that works somehow is to play in windowed, windowed (fullscreen) mode and even then it crashes sometimes. In fullscreen mode it crashes after 1-2 min.

Journeyman III

Did u get a Solution for this Problem?


No, problem still exists for me. The only solution is to play in windowed, windowed (fullscree) mode. And the game crashes after alt+tabing out. It has a worse performance as playing in fullscreen mode, since fps drop from 120 in fullscreen mode to 70 in windowed (fullscreen). 

Journeyman III

Do you know when the new BIOS update is coming?

Journeyman III

I don't know what happened but it seems to work now for me. Yesterday i played 3 hours on fullscreen mode without any crash. Only thing i tried last week was the solution here Solved: Games crashing on Dell 5770 since bios and windows update - Dell Community , but it didn't work. Yesterday i installed 2 windows updates,  and . Well since then my game works, but i don't really know why.

Journeyman III

Hello, me again lol. The solution mentioned above works fine if done correctly. Sorry my mistake.