Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Display “unplugs” after 10 minutes in windows use on ryzen APU

Bought my ryzen 5 5600g. Updated my am4 motherboard (a320m-s2h) bios and tried booting with the apu, no post. After a few tries it booted to safe mode, i deleted the graphics drivers and was able to boot to windows. But when i try to download drivers again it just “disconnects” my display hdmi adapter and monitor reads no signal. Making the windows disconnection sound and im left with a non working pc. I have to restart to safe mode by restarting my pc multiple times until im in recovery mode. Then a few tries later it boots me back into windows. Or i have to delete the driver using a tool (ddu) then i can have the igpu post display to windows 10. I tried first updating my chipset driver and even that unplugged my display and bricked the pc… Is there something im doing wrong? I already tried installing both recommended and newest driver versions on and without internet. Even opening a few things on the basic display (no drivers installed) windows is sluggish and after about 10 minutes or less it unplugs making the disconnection sound and im back to this tedious loop. Any help? I paid a premium to be able to use the onboard graphics and now its a struggle to get it to work…

1 Reply
Adept I

I'm having this problem too, did you get a solution?