Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

cpumetricsserver.exe, version: Error in Windows Logs

I was checking my Windows Logs and see the following under System:


Error application name: cpumetricsserver.exe, version:, timestamp: 0x615c7dd8
Faulting module name: cpumetricsserver.exe, version:, timestamp: 0x615c7dd8
Exception Code: 0xc0000409
Margin of Error: 0x00000000000076bc
Error process ID: 0x1f78
Application start time with error: 0x01d7c71b772ebee7
Faulting application path: C:\Program Files\AMD\CNext\CNext\cpumetricsserver.exe
Faulting module path: C:\Program Files\AMD\CNext\CNext\cpumetricsserver.exe
Report ID: c9b50e4e-150d-4a8b-a231-38fe19896d64
Full package name with error:


After a short research i found out that "cpumetricsserver.exe" is from AMD Radeon.

11 Replies
Journeyman III

Same here.

cpumetricsserver.exe crashes at every computer startup.

This started occurring after the 21.10.2 Radeon software update.



I believe that has to do with AMD new feature Performance Monitoring which is part of AMD Overlay Menus:

Journeyman III

Same here,

I installed both Windows 10 & Windows 11, but this issue (cpumetricserver.exe), happens only in Windows 11.

on Windows 10, it's all good


In Adrenalin s/w Turn of all overlays, You really don't need it and it is known to cause more trouble than benefits.
And while You're are at it, turn off hotkeys as well, since it interferes with customized games and other s/w action keys.




Usually I'm using Radeon Chill to set min and max fps and to get a nice cool & quiet gaming experience while playing all my games at ultra settings.


And most important if Your monitor support AMD FreeSync Premium - Enabled



How it is while playing Assassins Creed Odyssey and every setting maxed out +120% on the Resolution Modifier and it looks similar with AC Valhalla except that more ampere (A) is drawn and SAM can be fully utilized with AC Valhalla:
My Gpu has two temp sensors and this is on my second monitor.

Normal-GPU temp sensor x2 AC Odyssey.PNG

If you would like to record or broadcast your game play: do Not use Adrenalin s/w for that, instead use OBS which is free and remember to change one important setting while playing games:
GPU h/w to s/w encoder since the GPU hardware is occupied with the game engines graphics.

My rig:
GPU: ASUS TUF Gaming AMD Radeon RX 6900 XT OC 16GB
Adrenalin s/w: 21.10.2
Extended monitor setup: Gigabyte AORUS-FI27Q27" 2560x1440 @165Hz (primary), Philips IPS 24" 1920x1080 @60Hz.
Mobo: Asus ROG Crosshair VIII Hero (wi-fi) with AMD X570 chipset
BIOS ver. 3801 (with AGESA V2 PI Patch C).
Chipset: amd_chipset_software_3.10.08.506
SAM: Enabled and fully functional.
CPU: AMD Ryzen 9 3950X
Ram: Corsair Vengeance low profile 16GB @3200 MHz cl16
CPU Cooler: Noctua NH-D15-Se AM4
Storage: M2 Samsung 980 Pro 2TB NWME, SSD Samsumg 950 Pro 1 TB SATA
Windows 10 Pro 21H1 with latest Windows optional update.

Best regards from Sweden

You really need to first try my suggestion above regarding disable all overlays.
cpumetricsserver.exe has an direct impact on the overlays and vice versa.

I'm sorry but I forget to asked some important questions.
What system are You running:
Motherboard manufacture and model no.
Motherboard BIOS version (press Del, F1 or F2 during startup to enter BIOS Setup menu) .
Graphics card manufacture and model no.
Processor: manufacture and model no.
If it is a laptop - manufacture and model no.
Windows OS version (Windows key + Pause key will show the details).
Detailed description of the problem and s/w involved.

Above are the essential information that needs to be present to be able for the community to try to help.

First of all if you are using Windows 11 (but it also applies to Windows 10):

1. Make sure that you have an updated BIOS version from the manufacturer.
2. Make sure that you have an updated Windows version in particular: installed Optional updates (manually run Windows update from the settings menu).
3. Make sure that You have the latest chipset drivers:
For AMD chipset:
For Intel chipset:

4. Make sure that You have the latest graphics driver:

For Windows 11 especially but also applies to Windows 10:
All are important since the Windows 11 is not a really ready product and filled with problems and Microsoft together with AMD and Intel have recently made significant changes, but most of it of course lies on Microsoft.
*Windows 11 is Not a good and ready-steady-to-go product. Period.*
Just read this for an important information:
If You are on Windows 11 You really need to constantly check for updates for everything (1-4) - regularly.

Personally I will wait at least 6 or 10 months before installing Windows 11, wise of history...
Best regards from Sweden

Windows 10 Home (21H1 with latest updates)
mobo ASUS Prime X570-P (UEFI/BIOS v. 4021 with AGESA V2 PI Patch C)
cpu AMD Ryzen 5 3600
gpu Sapphire Radeon RX 5600 XT
chipset driver version
display Samsung S27A750D 27" 1920x1080 @ 120Hz
memory Kingston 2 x 8GB @ 3200MHz
system disk Kingston M.2 NVMe 512GB
Adrenalin software 21.10.2

Like I said, the problem started when I updated Adrenalin software to version 21.10.2.
Before that, everything was ok.

Bug severity is nuisance at worst though. Makes stability log look untidy.
System and games work quite well otherwise.



My systems Are :

Processor : AMD Ryzen 5 2600

Motherboard : Asrock X470 Master SLI (latest bios for Pinnacle (3.40)

Ram : 16GB (2x8) DDR4 3000

GPU : Asrock RX 570 4GB

Chipset and GPU driver using the latest version.


I'm Running both Windows 11 (build 22000.282) and Windows 10 (Build 19043.1266)

This Issues (cpumetricsserver.exe) only happen in Windows 11, and sometimes it cause my PC to goes Blank/crash.

Playing games in Windows 11 also got my PC to crash (DOA6 and Crysis remastered).

But in windows 10, that games running just fine.

I Think my best options is keep running windows 10 until windows 11 is ready


Adept II

My configuration of my pc:


Microsoft Windows 11 Pro

Gigabyte B550M DS3H

AMD Ryzen 5600G Vega 7

16GB Crucial Ballistix 3600 @ 3800 m/t



Sounds more like user error, oc ram mentioned so what else is not being said.

Come back when you have optimal non oc settings applied.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

The latest Adrenalin 21.10.3 seems to fix this issue.




Do you know what else can I try?

I have the same problem, but I have tried everything and I'm about to give it up.

Adrenaline version doesn't fix the problem, I tried the last version 22.2.1 and 21.10.3 mentioned before.


In version 21.10.3 New World runs for about 2 minutes.

Last version, 22.2.1, the game runs for 10 minutos and than goes to black screen or freezes the game.

In this 10 minutos playng the game it runs normal, no gliches, and FPS goes as up and down as expected. 

I have done all these things: desabled overlay, turned on AMD chill, updated drivers, downgraded for the last test, formated win 10, updated Bios, updated chipset drivers and so on, but nothing works.

As it goes:











This list was realy long, but I have formatad so, as you can see, this were my tests. When it reboots by it self we have a event, when it freezes, it doesn't go to the list.





PC spec.: