cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

autouzi
Journeyman III

Constant display driver crashes on R9 Fury

I am getting display driver crashes about every 5-15 minutes. These crashes present as either a  black screen that then crashes app/game to desktop, a CTD without a black screen, or complete system freeze. I do not get an error message after a crash unless I try to open Radeon Settings, in which case I get the "Radeon Settings has crashed or is not responding" message from Windows. It will open normally after a 2nd attempt. This occurs 100% of the time after a crash. These crashes occur on any application that stresses the gpu including Youtube on Chrome (especially 4K videos), Witcher 3, Skyrim SE, BOINC, and many more. These issues are not hardware related. I can be fairly certain of this due to this only occurring since Crimson Relive edition. Additionally, see below for the things I have tried to fix. I have spent many hours of my life trying to fix this and am completely unable to enjoy gaming because the crashes occur so often. I have tried many, many solutions to fix this, please read below before commenting something "obvious". I am posting this in hopes of finding a solution I have not tried, although unlikely. Of note, I do not use any overclocking software (Trixx/Afterburner). There are several entries in the Windows crash logs about Radeon Settings but the details on crash logs are not helpful (or above my understanding). I can try to upload the logs if someone can tell me an easy way to do so.

Specs:

GPU: Asus R9 Fury Strixx

Driver: Currently 18.1.1

CPU: FX-8320

MB: M5A97 LE R2.0 Bios 2701 (latest)

Ram: 8GB DDR3 1600MHz Crucial Ballistix Sport

PSU: EVGA 850 BQ 850 Watt Bronze

SSD: Kingston 120gb SATA III

Display: LG 27MU67 4K Freesync over Displayport

OS: Windows 10 64-bit Version 1709

Things I have tried:

  1. Installing drivers after running DDU in safe mode (always)
  2. Increasing AND decreasing power limit in Wattman
  3. Increasing AND decreasing voltage in Wattman
  4. Underclocking GPU by 100MHz in Wattman
  5. Changing TdrDelay to 8 and 10 in regedit (causes "X has been blocked from accessing the graphics card" messages)
  6. Disabling Tdr by setting TdrLevel to 0 in regedit (crashes way less often, but if it does it requires a restart)
  7. Never opening Wattman after a fresh reinstall of drivers to ensure Wattman is not the problem
  8. Ensuring no thermal throttling by running Furmark on several settings (never goes above 70C)
  9. Reinstalling Windows 10 (very disappointed this didn't work)
  10. Removing CPU/RAM overclocks
  11. Running the Windows memory diagnostics test (always passes)
  12. Re-seating the GPU
  13. Using a different display output on GPU including HDMI
20 Replies
autouzi
Journeyman III

Update: Still occurring. Since tried: 15.11.1 (+/- HBM underclock/overvolt) and reflashing vbios.

0 Likes

Hi Friend,

I`m also facing same problem and already tried all mentioned steps but no luck. If you find any solution, Please let us know

Thanks

0 Likes
stalinizator
Journeyman III

Made an upgrade lately, and as i have crossfired furys (the most stupid thing i've ever done) i swapped cards when changed motherboard. And got epic crashing sequence every next minute in Witcher 2 due to better gpu load than before, and before this game crashed once or twice for dozens of hours played, and i do not think those were gpu related. So i changed pci slot priority in bios and did not face any more crashing, though ought to be checked for a longer period.

Guess we just got faulty products which is so common these days on gpu market. QC ftw.

0 Likes

Since this post, I have upgraded my my CPU, RAM, and motherboard and the driver crashes instantly disappeared. Logic would indicate this is a hardware issue or instability, but it is not. The PC would pass overnight tests of RAM stability tests and hours of P95 or any other RAM or CPU benchmark; the black screens still occurred, but did not interrupt these tests. Testing that system with a different GPU also showed no evidence of driver crashes. I also considered that it is possible that motherboard was just unable to provide constant power to such a GPU, but the GPU I tested in it was even more power hungry than my Fury. I also tried undervolting, which considerably lowered power draw, yet the driver crashes still occurred. I theorize the black screens people experience are a collection of multiple different bugs that only occur with specific hardware combinations, which is likely why AMD is unable to reproduce many of these.

0 Likes

What can i say. In my case black screens occured with single gpu config, then they occured in multi gpu. My old system was almost identical to yours, after upgrade what's left of old system are gpus and ssd/hdds, in my case problem still persists. Crashes themselves are mostly sporadic, may appear in constant crash sequences, may not occur for weeks either.

Followed all steps you mentioned in your last post on my own. Nothing helped

0 Likes
autouzi
Journeyman III

Update August 2018: Black screens have returned this week. I am using the latest 18.8.1 drivers, which may the cause. So far the black screens this week have only occurred on YouTube videos using Chrome or Edge, so I suspect it is an issue with either YouTube or the hardware decoder in my Fury. Turning off hardware acceleration may fix this, but I am unable to tolerate the stutter this introduces in 4K videos.

0 Likes
samboush
Journeyman III

Hi. I have same problem. WIN 10 Radeon Fury.  Display driver amdkmdap stopped responding and has successfully recovered. All the time.
Not only in games but everywhere where is used some 3d acceleration.
My investigation end with this. Any Win 10 64bit driver from AMD for Radeon Fury after 17.4.4 is not working. Same issue. But 17.4.4 works ok in any cases without crashes.
It's same version of drivers what Windows 10 install automaticly after complete removed any AMD drivers and Software.
I don't know how it's possible that AMD leaves Radeon Fury without support for One and half year.

0 Likes
quinceonwheels
Adept I

Hi mate, any progress on this? I'm in the middle of ruling out all my other components (currently running MemTest86). 

I have been able to isolate my crashes/black screen issues whenever I have Blizzard launcher open or the League of Legends client open. 

However League of Legends I by far the worst case of crashing. I usually crash in random intervals, sometimes 5 seconds apart and others 30 seconds apart. Each time the image freezes, screen goes black for about 5 seconds and then I get put back into the game. Sometimes if it's really bad, the client crashes all together and I'm back at the desktop.

0 Likes

It's the GPU, don't bother crossing out other components. Use clockblocker software in order to reduce crashes.

0 Likes

MemTest86 came back clean after 4 passes. I just installed clockblocker and after testing it out in League of Legends for 5 minutes it hasn't crashed once. Thank you very much for recommending this software!

It's a shame that AMD haven't found a way to support Fury cards with their new power management scheme. I mean have they even acknowledged it officially anywhere yet?

0 Likes
raab74
Journeyman III

I have the Radeon R9 Fury. Used to experience black outs and even my whole computer freezing when gaming. It was game breakingly consistent. It seemed like a power issue - stress caused blackouts. Noticed AMD was failing and restarting when the blackouts occurred. This occurred even after a new card and on multiple computers.

I finally resolved this problem and stabilized the card by tuning it and setting just about everything to manual. I have no idea if these are optimal settings but they work. If you go into your Radeon settings software - go to Performance and then Tuning. 

I currently have GPU Tuning and Advanced Control enabled. I've also enabled the Voltage. I set the States, of the Voltage, in this order - Min(900), 1000, 1100, 1200, 1200, 1250, 1250, and 1250. 

I think that is pretty much all you need to do to keep it from blacking out.

I set my frequency to - Min(300), 700, 800, 900, 950, 950, 974, 1000.

That is as far as I wanted to push it. If I set them at, say, all 1000, my GPU would crash.

Hope this helps you! This was an awfully frustrating problem and took plenty of time and tantrums to resolve.

Ok, i did this (like hour or 3 ago) playing some games now, and so far no crashes. "fingers crossed". Ill keep u updated.

I've got faith in that solution. I'm a heavy gamer on the weekends, I can rock any game for 6+ hours. Lately I've be heavy into Pavlov-VR so I know that has to be a load on the ol GPU. The problem is with the automatic voltage controls between the software (amd radeon) and the GPU. Once I found this out, I no longer experienced crashing.

Do keep in mind though that some software updates can reset your manual settings back to default. If you do experience any more crashing, be sure to check your tuning and set it back to manual.

I'm very happy I was able to help you with my experience. Happy gaming fellow gamer!

Thank you very much!!!! ive been searching a solution for 3+ years now. And new graphic card stands in the hallway atm ><. Guess that one is going back to the store. not a single crash tonight! <3 

0 Likes

@ AMD: I am seriously fed up with this issue, and i am never, ever in my life gonna buy an AMD video-card again. This issue is fully your responsibilty and never got acknowledged. This videocard is crap, and it does not work as intented. I got this card into RMA, but sadly i got it returned with the answer; "nothing wrong with this one". Just because the issue is so vague and inconsistent. Doesn't mean it is because of my setup. 

@raab74: At first your suggestion worked for me. Altrough i noticed later that in some games i couldn't alt tab when the game was on full-screen windowed mode. The game would then suddenly lag-out. But no worries easily fixed by putting the game on full-screen. At least i thought, untill i started playing wow. Sadly this game does not have the option to pick full-screen mode. Ok so i tried updating AMD software, this worked. I can safely alt-tab without lag-crashing. But now again as before each time i watch a video on full-screen mode, i get the same old issue back. And my entire computer freezes, both screens go black for 1 minute+ and it either refind itself or crashes my game. 

minoesch wrote:

i am never, ever in my life gonna buy an AMD video-card again.

You said it. Since buying this card in 2015 I swore never to buy an AMD product again because of the hell they've put me through. I have personally turned countless people away from them while system building. Not looking back.

minoesch
Adept II

Hi, got same issue from start i brought this videocard (also see). Less of an issue when i totally downgraded the drivers. Lately i updated again cause i had to for assassin creed odyssey. Now the problem is fully back 10-till 25 screen crashes on a evening of gaming league of legends..... 

Weirdes thing is that that this problem seems to change over time... Sometimes i got a lot of crashes, sometimes not so much, sometimes my screen gets back up after 10-15 seconds and sometimes my entire system is just crashed.

I use two monitors 

1 - 144hz 

2 - 60hz

But also happens with 1 monitor.

I tried DVI and DP cable (seems to happen more frequent with a DP cable). 

My 144hz monitor has been back for repair, but they didnt found any issues.

All cables have been replaced.

Clock blocker did not solve my issue.

Downgrading videocard drivers to catalyst seemed to redeem the problem a little.

Im gonna test out some more things again and post it here, would be nice to have an overview.

0 Likes

Yea, i also have 144 monitor and i thought it was the issue. Luckily i have pc connected to TV, so, after it crashed on TV too, i crossed out monitor. I actually hate repair/rma process, as in such cases its very likely that nothing would be found. For instance because GPU, as we've noticed doesn't crash on a system basis, but can have crashing sequences, when it crashes right after it recovers from crash, and this sequence can last forever till you turn pc off. Or it may work well for a long time, until you give it a decent load. Mine crashes in BF1 and other vram demanding games with memory errors. I never played league of legends, but in war thunder game tends to crash often from the start, when i do not use clockblocker. At first i used it only when crashes appeared, now i use it always. Also, reason why you may have worse results from clockblocker. I have two furies (and its its stupidest thing i did in my life, buying those lacking QC glitchy gpus) and one of them was showing times worse stability results. I'm not sure which one is the primary at the moment.

N.b. rma did not show any problem at all, as these crashes can not be repeated, for instance, using some stress test. And if you give certain game, its the game to blame. 

Clockblocker does help actually. It still crashes from time to time, but crashing loop sequences are gone. I'm using latest drivers always.

0 Likes
samg381
Adept I

Just started having this issue after upgrading to the latest windows build.

Any fullscreen application instantly crashes my Fury X (worst GPU I've ever purchased)

Clockblocker seems to somewhat help the problem, but the crashes still occur.

Event viewer shows the following Warning:

The Desktop Window Manager process has exited. (Process exit code: 0x000000ff, Restart count: 6, Primary display device ID: AMD Radeon (TM) R9 Fury Series)

0 Likes
ryh
Adept I

Got the same issue with Radeon R9 Nano. Then upgraded to Radeon RX 5700 and was surprised that got this problem also. Even after fresh (from zero) Windows 10 installation the same.

Noticed that ive got some crashes of TCPIP.sys sometimes.

Thought that maybe LAN card (wired connection to router).

I use cFosSpeed for many years (not sur if it do something but got free licence years ago).

After delete cFosSpeed - its 2 weeks now without any crash of TCPIP.sys or Radeon Replay.

So - if U are ising cFosSpeed or similar software (some MB vendors got such) - try without it.

0 Likes