Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

cant install new amd am4 chipset drivers

so, in late dec i downloaded 17.40 drivers.. but i checked again and the same number drivers but from JAN 15th 2018 are on the amd website.

i download them.. extract them and when i try to run the setup it says instance already running.. go to ask manager and close it.. try to run again and the same thing happens

first off.. is the jan 15th drivers different than the dec drivers? being they are the same version number? 17.40?

and if they are different how can i get them to install? i cant get the setup to run

8 Replies
Adept I

I will also mention that I have an asus rog crosshair Vi hero MB, i have the ryzen 7 1800x

once again.. i installed the drivers from dec 17 or 23rd or something like that.. which took the drivers to 17.40

i then checked and there was drivers on JAN 15th.. some said this was the specter patch or whatever.. not sure honestly.

but I cant install it.. im sure I could use the driver tool to uninstall all drivers and install again.. but do i need too? cause the drivers I installed in Dec 2017 are the same number that was on Jan 15th 2018. Driver 17.40

Community Manager

Please provide the essential INFORMATION REQUIRED WHEN POSTING A QUESTION  and a screenshot of the error you experience.

my system specs are

desktop computer

Asus rog crosshair vi hero bios version 1701

ryzen 1800x

CORSAIR Vengeance LPX 16GB (2 x 8GB) 288-Pin DDR4 SDRAM

windows 10 pro 64bit

current installed chipset 17.40

EVGA SuperNOVA 750 G3, 220-G3-0750-X1, 80+ GOLD, 750W Fully Modular, EVGA ECO Mode with New HDB Fan,...

monitor is samsung UE590 4k running at 4K

gpu is evga 1080 ti ftw3

I think i have added all the information.. but at the time of fist posting this I could not install the 17.40 drivers that were posted newer than the ones I already had of the same version number

but today there is a new version chipset 18.10

when I download it, and go to the folder it creates and run the setup, it says another instance is running.. i can go to task manager and see that "AMD SOFTWARE" '

is runnnig, if I close it, and then run setup again.. it does the same thing.. says ANOTHER INSTANCE IS RUNNING

should I remove the drivers totally? then install the new drivers? if so.. how would i do that? is there a tool from amd to do this?


okay, somehow I got the install to come up.. right after posting this i tried it again.. doing nothing different.. closing it from task manager and it installed.. i restarted.. and i thought.. ill run the setup again.. cause it shows what the current version is.. and the newest, or if your up to date.. it still shows that i have 17.40 installed... so i just now installed the 18.10 again.. same thing.. still says that I have 17.40??

whats up with that?

That might be the last version that works with your ATI 800 graphics on Windows XP.


what are you talking about? I dont have windows xp, i have windows 10, and I have gtx 1080 ti ftw3

but I did figure it out.. what I did was I noticed that it installed everything in C:/program files/amd so I went there and found a cleanup utility, something I tried to download from their website but it was only wanting to remove radeon graphics which I dont have.. i ran the utility, it removed all amd drivers.. i restarted, ran the 18.10 chipset driver installer again, and this time it installed.. i sort of figured it would work if I could uninstall any drivers I had, but couldnt figure out how to do it

so if anyone else is having this issue, just do what I did.. all is well now.. when i run the installer again it now shows that my current version is 18.10

Finally got the info out of you....

I had the same problem with 18.10 driver and solved the problem with your instructions.

Like GPU drivers, looks like chipset drivers are also need clean installation process.

Anyway, thanks.