Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Can't get RX 590 to run on Ubuntu Desktop 18.04.1 with amd-gpu-pro 18.40

Hello, On a fresh install of Ubuntu Desktop 18.04.1 with amdgpu-pro 18.40 (Radeon™ Software for Linux® 18.40 Highlights | AMD​) I can't get an RX 590 to run even though the "Product Family Compatibility" claims support for the RX 590 series. the computer boots to a purple screen, then the GPU revs up to full fan speed, then the GPU fan speed goes back to normal, then the screen turns and stays black.

The same system runs fine with an RX 470

I tested the RX 590 on Windows 10 to confirm that the issue isn't with the GPU and it seems to run without issue on Windows 10.

Any help would be greatly appreciated, thanks!

9 Replies
Journeyman III


Got the same problem. I just install RX 590 and amdgpu-pro 18.40 driver, Ubuntu start then the screen turn black and i can't do anything just reboot.

I don't have the problem on Windows 10.

Untilthis problem was fixed i have found a temporary solution, into the grub menu select advanced boot option and select Ubuntu XXX (recovery mode) and after resume startup.

Hope this can help you.

I know this is a year old now, but I'm having the exact same problem and it (only) works in recovery mode.
Though I'd like to enter in normal(?) mode. Have you been able to solve this?
Please, I don't know what else to try!

Journeyman III

Same problem with RX580 on Ubuntu 18.04. I had to uninstall amdgpu-pro (18.40) and use the Radeon driver that comes with Ubuntu. Since I need to run OpenCL, I installed amdgpu-pro again with headless mode and it worked. So it looks to me the display driver part doesn't work.

Journeyman III

Not sure this is applicable... AFAIK, AMDGPU pro uses same kernel module as AMDGPU without pro (which use MESA to implement OpenGL & Vulkan), so it should be.

That kernel module has issues with 590, at least with some OEM versions. There are number of patches which intended to fix this, but they are in testing now. You can partially fix this, you will be able to boot and work, but videocard will not boost, so performance will be times less than has to be.

With opensource driver you can do this by adding amdgpu.dpm=0 to linux image command line. Amdgpu pro kernel module may have another name.

Adept I

Update, I've tried running the RX 590 with the ubuntu server live install usb and the same issue occurs (even with the display cable pluged into the iGPU port on the motherboard.) I unplugged the card to install ubuntu server 18.04.1 on the computer then installed amdgpu-pro 18.40 with the "--opencl=legacy" and "--headless" flags. I then plugged the card back in (display cable stayed attached to the motherboard) and the same issue occurs where the system won't boot. Also I noticed that the BIOS is very small when the display cable is plugged into the GPU which is strange behavior.

Journeyman III

You need to be running kernel version 4.20 or higher, have the firmware for your card and get the updated vulkan drivers. There is a decent guide from levelonetechs ( ) .

This is the process I went through on a dual boot system. Depending on your configuration the steps may differ. Before starting, backup all your important data, configs, keys, etc & keep them safe.

1. Make sure you're updated to the latest current release. e.g.:

sudo apt -y update && sudo apt -y dist-upgrade

now reboot.

2. Add the firmware for your GPU from

cd /lib/firmware/amdgpu/
sudo wget

3. Update your kernel to 4.20 or better. There are various ways to do this. If you are confident with cli, the manual process uses dpkg, Kernels for manual update can be found here:

OR, you can use a tool like UKTools, ukuu or a combination of scripts such as Linux Kernel Utilities

once installed, reboot.

after reboot run 'uname -a' & verify you're running on the right kernel.

4. Download & install the amdgpu drivers from

tar -xvf amdgpu-pro-19.20-812932-ubuntu-18.04.tar.xz

cd amdgpu-pro-19.20-812932-ubuntu-18.04/

sudo ./amd-pro-install --headless

You will find any install errors in a log under

running the --headless will allow apt to deal with any unmet dependancies.

Now run 'update-initramfs -k all -u'

5. Add the Vulkan drivers and utilities:

wget -qO - | apt-key add -
sudo wget -qO /etc/apt/sources.list.d/lunarg-vulkan-bionic.list
sudo apt update
sudo apt install vulkan-sdk

update-initramfs -k all -u

With a bit of luck you should be good for 4K on a single screen, upto 1440p res on dual screen. I haven't got it working on dual screens at 4k yet, best so far is 4k/1440. possibly a cabling issue (I have a 1.2 & 1.4), the 1.4 gives 4k, the other flashes black when set to 4k but is fine on 1440. Waiting on the post for a new set of 1.4 cables.

Good luck.

I have been trying to properly install the RX 590 on my Ubuntu 18.04 system for weeks now. I have followed the level1techs step by step guide and the video that was posted. The firmware that is listed on the website that is provided only goes up to Polaris 12. The RX 590 is built using Polaris 30.  

I have downloaded EVERY file in the link and placed them in cd /lib/firmware/amdgpu/. The proper driver is still not being displayed. Installing the driver using the provided steps lets Ubuntu 18.04 utilize the card as if it were a RX580x. Are there other options?

Journeyman III

Okay I've FINALLY been able to solve my problem (the exact same thing that happens to OP).

I was able to enter from recovery mode so from there this is what I did:

   1. I set NOMODESET in the /etc/default/grub file. To do this go to the mentioned file and go to the line that looks something like this: 


add `nomodeset` and it should be something like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Finally run `sudo update-grub` and reboot.

For more information on why this works (or if you have any extra doubts on how to exactly do this) here is the source: Ubuntu Forums.

Weirdly my /etc/default/grub file was empty, so I just copied the example from /usr/share/grub/default/grub as adviced here: grub2 - There was no /etc/default/grub file, so how come my system was able to boot? - Ask Ubuntu. Then reboot and all worked fine.

   2. A bit of backstory: I was able to boot into recovery mode so before all this I installed amdgpu-pro (foolishly) from recovery mode (don't do it).

I was able to enter in Ubuntu normally but I had some visual glitches. So to solve the glitches I just uninstalled amdgpu-pro with the following command: `amdgpu-pro-uninstall`.

(If you didn't install amdgpu-pro you don't need to do this).

I still have a brief glitch effect after I enter my password, but other than that is all working fine!!!
Hope this helps anyone with this same problem!

Journeyman III

I had same issues with Sapphire RX 590 installing ubuntu 18.04.03. So I used Win7 with 19.11.3 drivers. After a while I booted same Ubuntu live usb and it worked without any configurations.  And everything works fine now.

BTW. You have to enable KMS and run on an older kernel to be able to install 19.50 drivers.