Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AOD Driver 4.2 causing crash in Windows 10

My PC has been crashing for awhile now and it is getting worse. It finally seemed to be related to the last couple of graphic card drivers so I rolled them back to Oct version.  That resolved the problem for a few days.  It is now back.  According to the event viewer, AODDriver 4.2 service failed to start because it would not find the path specified.  This may have been the cause all along as I needed by HD space so I cloned my HD to a newer and larger one.

The thing is, I do not use AOD. I do not even see it installed anywhere. It may have been removed from AMD's file cleanup tool. 

I looked at the services listed in task manager.  I cannot see it listed.  All I see are AMD Crash Defender and AMD External Events.

So how can I find whatever it is in windows so I can remove it? I am guessing it is a registry issue.

3 Replies

AOD (AMD OVER DRIVE) Utility is AMD legacy CPU Monitoring and Overclocking app for Non-Ryzen CPUs.

Ryzen Master took the place of AOD Utility.

Sounds like a Registry issue where a left over or corrupt Registry key is causing the issue.

Enter Registry and use "Find" option to find AOD and see if anything comes up. Any key that deals with AMD AOD Utility delete.

You can try using a Registry Cleaner to see if it deletes any leftover Registry keys.

From this old Windows 8 Forum about the same error:

deleted the single reference to 'AODDriver 4.2.0' in the registry.

Also run DDU to remove the current AMD Driver and traces which might remove or delete any AMD Registry keys leftovers.

Then reinstall again.

Journeyman III

Thanks.  I had like 6 or so of those in the registry.  Removing them solved the problem . . . until yesterday.

Right now I am stuck in the File System Filter 'FileCrypt'  has successfully loaded and registered with Filter Manager and File System Filter 'npsvctrig' has successfully loaded and registered with Filter Manager followed by crash loop. 

The only thing I did was remove CCcleaner from my system.  While it is not noted recently, after the first time this reoccured, the Event Viewer lists: The AMD User Experience Program Data Uploader service failed to start due to the following error:  The system cannot find the file specified.

However, that has not repeated itself.  So I am not sure if that is a fluke or not.  It is likely not a hardware issue because I have been in safe mode for nearly an hour and without safe mode, I can't go more than 10-15 minutes without it crashing. 

Any thoughts?


You can disable AMD User Experience Program through Radeon Settings. That is not really needed unless you don't mind giving AMD data.

If you do have it disabled then there should be no reason for that service to be in use.