Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

amdkmdag.sys system error, becomes unresponsive and crashes.

System Details:


GPU: AMD Radeon 6800 XT

Processor AMD Ryzen 7 5800X 8-Core Processor, 3801 Mhz, 8 Core(s), 16 Logical Processors

Desktop or Laptop: Desktop

Operating System: Windows 11, Version 10.0.22621 Build 22621

Driver version installed: AMD Adrenalin 23.2.2

Motherboard: MAG B550 TOMAHAWK (MS-7C91)



My PC is brand new, and to be honest overprepared for anything I might be playing on it, as it runs a smooth 60 frames and has no issues processing anything (Maybe Overwatch 2, at the most). Everything seems to be fine with it on a normal scale, until the system crashed. I didn't expect anything from it, just a random one-off crash, though I haven't had it happen with my old computers.


Every now and then however, on a 1 to 2 week basis, my PC will simply become fully unresponsive, wherein I must hit the power button.

Music continues to play and sound continues to go through just fine, I can even hear my friends in discord talk for about 30 seconds to a minute after the crash occurs before they cut out. During that time I have tried Ctrl Shift Esc, Alt F4ing the program, Ctrl alt del to open task manager, nothing on it works except sound.


When I restart the PC, it basically acts like nothing ever happened, and like I mentioned above, 1 to 2 weeks can go by with nothing happening before it randomly happens again.



What I've tried


I've tried a combination of things so far, I've updated Windows to as recent as it can be, I have installed the most recent Drivers and Chipsets (I don't know the difference between the two but know they are at the very least different). As well as began to undervolt components on my PC as the error task I've been getting (ID 41, Task Category 63) has been said that it may be a PSU issue, however with it being a brand-new PC with only 2 months of being used, I highly doubt it is this, but I figured I'd try anyways.


Another voiced concern that MSI-Afterburner program might be causing the crashes as well, or so I've read, and I've uninstalled that (I had it installed to check temperatures only, I'm a hypochondriac when it comes to my PC).


I found a few DMP files of previous crashes, and after running them through the debugger I have found this information below with all of them being generally the same:


Debugging Details:

Unable to load image amdkmdag.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for amdkmdag.sys


    Key  : Analysis.CPU.mSec
    Value: 1890

    Key  : Analysis.DebugAnalysisManager
    Value: Create

    Key  : Analysis.Elapsed.mSec
    Value: 2481

    Key  : Analysis.IO.Other.Mb
    Value: 0

    Key  : Analysis.IO.Read.Mb
    Value: 0

    Key  : Analysis.IO.Write.Mb
    Value: 0

    Key  : Analysis.Init.CPU.mSec
    Value: 249

    Key  : Analysis.Init.Elapsed.mSec
    Value: 3016

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 112

    Key  : Bugcheck.Code.DumpHeader
    Value: 0x117

    Key  : Bugcheck.Code.Register
    Value: 0xaa7c17e0

    Key  : Dump.Attributes.AsUlong
    Value: 18

    Key  : Dump.Attributes.KernelGeneratedTriageDump
    Value: 1


FILE_IN_CAB:  WATCHDOG-20230128-2203.dmp

  Kernel Generated Triage Dump
  Live Generated Dump


BUGCHECK_P1: ffffce8b14002050

BUGCHECK_P2: fffff8038c3a66a0



TAG_NOT_DEFINED_202b:  *** Unknown TAG in analysis list 202b


VIDEO_TDR_CONTEXT: dt dxgkrnl!_TDR_RECOVERY_CONTEXT ffffce8b14002050
Symbol dxgkrnl!_TDR_RECOVERY_CONTEXT not found.

PROCESS_OBJECT: 0000000000000c44


ffffef8d`05e9f620 fffff803`74fa8f24     : ffffce8b`080e8030 ffffce8b`080e8030 ffffce8b`0ee269c0 ffffce8b`14002050 : watchdog!WdpDbgCaptureTriageDump+0xb7
ffffef8d`05e9f690 fffff803`74e0db1d     : ffffce8b`14002050 ffffef8d`05e9f850 00000000`00000000 ffffef8d`05e9f850 : watchdog!WdDbgReportRecreate+0xd4
ffffef8d`05e9f6f0 fffff803`74e0c580     : ffff9706`00000000 ffff9706`95a4ca60 00000000`00005000 00000000`00004840 : dxgkrnl!TdrUpdateDbgReport+0x11d
ffffef8d`05e9f750 fffff803`74e0d600     : ffffce8b`00000000 ffffce8b`14002050 00000000`00000000 00000000`00000000 : dxgkrnl!TdrCollectDbgInfoStage1+0x300
ffffef8d`05e9f890 fffff803`71dc72b6     : 00000000`00000000 ffffce8b`07f76238 ffffce8b`07f76240 ffffce8b`07f76248 : dxgkrnl!TdrIsRecoveryRequired+0x140
ffffef8d`05e9f8c0 fffff803`71e551c3     : ffffce8b`11d24000 00000000`00000000 ffffce8b`11d24000 00000000`00000010 : dxgmms2!VidSchiReportHwHang+0x5fe
ffffef8d`05e9f9d0 fffff803`71d8b05c     : 00000000`00000000 00000000`ffffffff 00000000`010e744c 00000000`00989680 : dxgmms2!VidSchiCheckHwProgress+0x2d2e3
ffffef8d`05e9fa50 fffff803`71e33c95     : ffffce8b`1ebcb000 ffffce8b`11d24000 ffffce8b`1ebcb010 ffffce8b`07ed1920 : dxgmms2!VidSchiScheduleCommandToRun+0x5c
ffffef8d`05e9fb20 fffff803`71e33c0a     : 00000000`00000000 fffff803`71e33b40 ffffce8b`11d24000 00000000`00000080 : dxgmms2!VidSchiRun_PriorityTable+0x35
ffffef8d`05e9fb70 fffff803`61e0f4a7     : ffffce8b`0d12c3c0 fffff803`00000001 ffffce8b`11d24000 004fe07f`b4bbbdff : dxgmms2!VidSchiWorkerThread+0xca
ffffef8d`05e9fbb0 fffff803`6202de84     : ffff8500`df8e7180 ffffce8b`0d12c3c0 fffff803`61e0f450 000e6b76`ffffffd8 : nt!PspSystemThreadStartup+0x57
ffffef8d`05e9fc00 00000000`00000000     : ffffef8d`05ea0000 ffffef8d`05e99000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x34


SYMBOL_NAME:  amdkmdag+d66a0

MODULE_NAME: amdkmdag

IMAGE_NAME:  amdkmdag.sys

STACK_COMMAND:  .cxr; .ecxr ; kb

FAILURE_BUCKET_ID:  LKD_0x117_IMAGE_amdkmdag.sys


OSNAME:  Windows 10

FAILURE_ID_HASH:  {eb317d22-0fcb-4b7a-404e-a69301cad237}

Followup:     MachineOwner


As for the more recent crashes, ever since I've updated my drivers and chipsets, I have not received any DMP files (I'm not sure why) so I can't say for sure if these crashes are still because of the same issue, but since the last 2 happen to be the same, I would like to assume the crashes following would be as well.

The only correlating evidence between them is I've been playing Final Fantasy XIV when the crash has occurred, this is every single time mind you, not just once, I play a few other games, some of which require more to run than Final Fantasy, and they run completely fine.

I was also told that certain games/MMOs had issues with AMD graphics cards, and I would accept that if it crashed just the game, but it continually crashes the entire computer.

I admit I am a novice in the PC department and have absolutely no idea what any of this means, I am simply trying to stop this crashing.

0 Replies