Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

amdgpu-install on Ubuntu 23.04?


Yesterday I received a new monitor with a somewhat higher resolution (3440x1440, 165 Hz). The problems started when I tried to connect my laptop to it via HDMI. The laptop is not able to detected any higher resolutions than 1920x1080:

HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 800mm x 337mm
1920x1080 120.00* 119.88 60.00 60.00 50.00 59.94 30.00 25.00 24.00 29.97 23.98
1600x900 60.00
1280x1024 75.02 60.02
1152x864 75.00
1280x720 60.00 50.00 59.94
1024x768 75.03 60.00
800x600 75.00 60.32
720x576 50.00
720x480 60.00 59.94
640x480 75.00 60.00 59.94
720x400 70.08
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DVI-I-4-4 disconnected (normal left inverted right x axis y axis)
DVI-I-3-3 disconnected (normal left inverted right x axis y axis)
DVI-I-2-2 disconnected (normal left inverted right x axis y axis)
DVI-I-1-1 disconnected (normal left inverted right x axis y axis)


Operating System: Ubuntu 23.04 
Kernel: Linux 6.2.0-24-generic
Architecture: x86-64
Hardware Vendor: Lenovo
Hardware Model: ThinkPad E595
CPU: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx (8) @ 2.100GHz
GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series

The weird thing is I use the same laptop with other external monitors that have the same resolution (via HDMI) and even 4K (via USB-C) without any problems. I never had to install any drivers manually but I tried to install this one: (23.10.2 for Ubuntu 22.04.2).

~ amdgpu-install -y --no-32 
Hit:1 lunar InRelease
Get:2 lunar-updates InRelease [109 kB]
Get:3 lunar-backports InRelease [99.8 kB]
Hit:4 stable InRelease
Hit:5 lunar-security InRelease
Get:6 lunar-updates/main amd64 DEP-11 Metadata [76.0 kB]
Get:7 lunar-updates/universe amd64 DEP-11 Metadata [35.8 kB]
Hit:8 jammy InRelease
Hit:9 jammy InRelease
Get:10 lunar-backports/universe amd64 DEP-11 Metadata [13.0 kB]
Fetched 333 kB in 1s (303 kB/s)
Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-i-386/Packages' as repository ' jammy InRelease' doesn't support architecture 'i-386'
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
amdgpu-lib is already the newest version (1:5.5.50502-1607507.22.04).
rocm-opencl-runtime is already the newest version (
rocm-hip-runtime is already the newest version (
amdgpu-dkms is already the newest version (1:
linux-headers-6.2.0-25-generic is already the newest version (6.2.0-25.25).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up amdgpu-dkms (1: ...
Removing old amdgpu-6.0.5-1607507.22.04 DKMS files...
Deleting module amdgpu-6.0.5-1607507.22.04 completely from the DKMS tree.
Loading new amdgpu-6.0.5-1607507.22.04 DKMS files...
Building for 6.2.0-25-generic
Building for architecture x86_64
Building initial module for 6.2.0-25-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/amdgpu-dkms.0.crash'
Error! Bad return status for module build on kernel: 6.2.0-25-generic (x86_64)
Consult /var/lib/dkms/amdgpu/6.0.5-1607507.22.04/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So what's going on here? Is Ubuntu 23.04 not yet supported or am I doing something wrong? By the way, I have the same problem with a newer model Lenovo laptop (also AMD CPU). Log file mentioned in the error:

1 Reply
Adept I

Best way to fix it is to uninstall Ubuntu and switch to Manjaro KDE. Ubuntu is made by monkeys.