Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

AMD Software returns a "Update Failed" error every time I try to check for updates

AMD Support has been more than useless on this issue, so maybe someone here can help me with this.

OS is Windows 11, latest build. Card is the RX 6600. Mobo BIOS is updated to the latest version. Windows driver updates are disabled via Group Policy.

Things I've tried to solve it:

-Opening AMD Software and closing every other application

-Adding exceptions to Defender, Windows Firewall and my router

-AMD Cleanup Utility and reinstall

-DDU and reinstall

-Performing an in-place upgrade of the entire OS (a reinstall without formatting and starting over)

If I use AMD's Autodetect utility an error which I suspect is related to this one gets returned: error 195 (AMD Software Installer Cannot Continue Because It Is Unable to Access the Required Web Resources).

I'm literally going insane trying to fix this, so if anyone has solved this issue more info would be appreciated.

4 Replies
Adept I

Похоже что у вас конфликт стороннего ПО, либо защитника windows. Попробуйте рекомендации из этой статьи:

Напишите если помогло

С Ув. Х.А.А.

Yeah as I said I already tried those solutions. It isn't a conflict with any program or Defender, or Windows Firewall, because I already tried opening AMD Software and closing every other application, and adding exceptions to Defender, Windows Firewall and my router (as I wrote in the original post).

Ошибка 195: Устройство не подключается к веб-серверу AMD.

Вы пробовали установить драйвера в ручном режиме?

С Ув. Х.А.А.

The drivers install fine if I download the whole package, but the autodetect won't work. Either way, the error the autodetect returns isn't the issue, it's just an error I suspect is related to the actual Adrenalin autoupdater error.