Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

amd software incompatible with current driver?

ive just reijnstalled my radeon rx580 8gb after installing a new gigabyte z370p-d3 and downloaded the amd adrenaline software that amds website says is for the rx 580 however any time i try to open the software it comes up saying "the version of amd software that you have launched is not compatible with your currently installed amd driver.    for information on how to resolve this please go to:" ive tried running ddu and reinstalling the drivers ive tried my gpu in a different slot ive tried resetting cmos and ive tried the support forum its linked however it says page not found ive even tried reinstalling windows but nothing seems to have worked is there any way to resolve this?Screenshot 2023-12-10 231710.png

9 Replies

May be Windows update replaced the driver, check your update history?


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

ok i will try running ddu to remove all amd drivers then update it from the software but ignore the windows driver and see if that helps i have ran them individually with the other removed from the system and they work with the software perfectly fine but as soon as i run them together that error comes up


As of right now (2023-12-14), the Guru software "DDU" is infected with a severe Trojan (Trojan:Win32/Wacatac.B!ml). 

According to Google search, the DDU utility was suppose to be safe, but when I downloaded it, Windows Defender immediately popped up an alert this was a severe threat and removed it. 

Windows does install an AMD driver for the Radeon GPU (mine is integrated with the Ryzen 7 7800X3D CPU), and does not last long before it turns into an error driver. Luckily, I am using a PCIe GPU for my video display, else this would certainly be a serious stopper for AMD systems.

So I hope someone with the necessary knowledge answers this initial post on how to resolve this because I have the same issue. 


Working link to pa-300, try the compatibility tool

And is Win.11 RTM or insider build?


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Sorry, I should have included more information for my part.

The compatibility tool does not make any difference. 
It said: 

"The version of the AMD software installed is already a compatible version. Please check if the AMD display driver is working correctly."

I have uninstalled the driver letting Windows install its version on a reboot, and that won't work.

I have uninstalled that, and installed the downloaded driver version from AMD, that won't work.

The AMD adrenalin software installed shows the error pop-up posted by the original post on top. The software won't open. 

Nothing seems to work, the AMD driver keeps showing as broken, not working along with the AMD software. 

I cannot use the DDU utility, because it is infected, which is typical of freeware. 

So, it seems the only answer is AMD has to update the driver. 
I did send them a bug report also.



Hi Mark,


Did you ever get this sorted in the end? I am having the exact same, infuriating, loop as you were back in December 


Yes I did, a sort while ago.

For my situation, the original cause (things that led to the AMD driver issue) was the "no boot screen" (black screen) on a startup. The screen did not display anything until the boot process reached the Windows 11 login screen, then the display turned on. 

At this time, the AMD driver was working fine. 

When I tried a GPU test for the black screen on boot issue, I used an older GTX 680 GPU that triggered the MSI BIOS into CSM boot mode from default UEFI boot mode, and that fixed the black screen on boot issue. When I replaced my 3070 GPU, the CSM mode apparently remained active because the black screen issue was fixed.

This is when I eventually saw the AMD driver fail, but at this time, did not make the connection yet. 

Later, the black screen issue returned when I updated the MSI BIOS, so I repeated the above test/fix and that is when I saw what occurred with the AMD driver.

The AMD driver started working fine again. 

What was occurring is when the MSI BIOS was in UEFI boot mode, the AMD Radeon driver for the CPU graphics was working fine. When the BIOS switched to CSM coot mode, that is when the AMD driver failed. 

Essentially, when the BIOS is working on a legacy boot mode, the newer AMD drivers will not work because they likely require the BIOS UEFI boot mode. (Note: secure boot makes no difference). 

I have been searching the Internet on this UEFI black screen boot issue and there are a lot of complaints with different system configurations about this boot screen issue.

What this narrows down for me is either the newer GPU card (3070 Ti) that are suppose to be UEFI compatible are buggy or the MSI BIOS software design is the buggy one. I think it is likely the 3070 Ti GPU. 

For that UEFI boot screen issue, which is the core cause, I am still working on a fix. The AMD driver issue is now resolved for me.

Thanks for taking the time to reply to me Mark. I just bought a portable egpu, GPD G1, and I've been trying for weeks now to get it installed onto my Huawei tablet. I only succeeded once and I'm not sure why that happened, but a series of DDU runs and AMD'S cleanup, and trialling installing driver only etc, I think I've finally had enough and will look to return it now


Well, good luck.
No offence, but based just on principle, everyone should get rid of Huawei products.