Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Ryzen Master installation failed

First of all, 
Hi everyone! I'm kinda an AMD Fanboy and it's my first post here. I think that presentation was enough, let's go to the problem.
Well, I tried to install once that Utility, a year ago or something like that, the first time it worked 10 out of 10, but after a month of using it it just stopped working (I mean, I just couldn't open the app), so I tried uninstalling it and installing it again, but doesn't work, so I thought it was a bug and leave it.

Now, after a year, I tried again, but the problem persists, I tried to install it, I downloaded the .exe and ran it as Administrator. At this time everything was wonderful, but when I agreed with the Terms & Conditions and clicked the Install button, and after 3 seconds the "Successfully Installed" message appears and I have two options that the only one working is "Exit" because the "Launch RYZEN MASTER" doesn't do anything at all and it didn't create any folder in the Start Menu, or any shortcut on my desktop. I looked up it on the web and found some solutions, about deleting some things on the Register Editor, but it doesn't work for me.

(I'm using an AMD Ryzen 2400G in a MSI A320M PRO-VH PLUS. If it's needed any more info, ask me!)

0 Replies