Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Radeon setttings won't open

After updating to the new 2019 radeon driver, I cannot open the AMD settings (both the recommended and optional updates),  the notification icon disappears if I click/hover over it on the taskbar and when I select AMD Radeon Settings when I right click, the notification icon appears in my taskbar, my cursor shows the loading circle and then nothing happens (the notification icon appears but disappears as before when I hover over/click on it. I am running with the newest version of windows, the newest updates and:

  • an Asus vega 64
  • an i5-8600k

   I could access the settings before the updates, so it must be a driver related issue.

1 Reply
Journeyman III

i still got this problem too, after installing the newest driver, AMD Radeon settings keep on chrashing.  When i look on this forum over the years people got this problem on different version of the driver but never a real good solutions.

I also tried older driver when it worked but looks like this newest driver messed up my software or something cause it wont help at all.

Last time i got problem with radeon driver i tried de DDU, but this broke my SSD, so since then ill never use this anymore, it should be weird that AMD is not coming with an solution and we need third part software to delete. 

Overall, only think what i didnt try and i will do is reinstall my windows. But yea no help at all from AMD on forum about this common issue.