Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Radeon HD 7970M drivers


recently I remembered I had an, admittedly old, laptop laying around somewhere. After finding it I decided to do a clean windows install to get rid of all the junk that was on there. However, after my windows install I couldn't get my gpu drivers to work for the life of me. I've literally tried everything... 

The laptop is an MSI gx60. It has integrated graphics, an AMD Radeon HD 7970M and an AMD Radeon HD 7660G.

At first I tried using the auto-detect software, which I thought had worked because it said it installed successfully, gave no errors or anything. I checked device manager, and even there it said the device was working properly. My resolution was still messed up however, and when right clicking my desktop there was to option to configure graphics or anything so I knew it didn't work. After that I tried to manually download the driver, and the same thing happened. 

Then I tried to download an old driver because I remembered when I used to use this laptop I never had any issues with my GPU. That DID work, I thought. My res was fixed and when I right clicked my desktop I could change my gpu settings and everything. Cool, it worked. Nice!

However, when I started downloading some basic stuff like chrome and stuff, I suddenly get a blue screen of death. And that just keeps happening now... 

Does anyone know what I'm doing wrong? I'm adding some pics aswell.

Thanks a lot!

6 Replies

First read this > 

Then tell us your APU.

Then tell us what OS.


Hey thanks for the reply.

I already read that post and I followed it.

My APU is AMD A10-4600M

OS is W10 Pro

To clarify, this is the drivers I'm trying to install:


Journeyman III


I currently have no drivers installed whatsoever because I kept getting blue screened as shown in the first reply. (atikmdag.sys)

This is what I had though:





Any suggestions as to what else I can do to fix this?

Thanks a lot!


Ok i just bought this laptop off a mate and loaded up windows10 on it. Oh boy, spent 3 days trying every single combo out.

So people  dont explain this properly and what i ended up doing was flashing the vbios to the latest

downloaded the latest crimson version which supported my device, you can't use the 5step guide by AMD to find it. You'll just have to search crimson and look at the notes for support of your device.

I ended up with 17.4.1

then you need to download the Processor with graphics  > A series processors > A10>your corresponding APU

You want to download both catilisty toolie and crimson

should be 15.7.1 and 16.2.1



Now  after you cleaned up your drivers with DDU 

Extract YOUR crimson version of your driver (i tried adrenaline, it didnt work)  you can use 7zip or what/ever

After you extract it, navigate to the folder>

Look for an INF file starting with a C in my case  "C0312788"

Right click and select install.

Alternatively you cab manually install it by going to device manager//update driver//pick my own//have disc//select that file//install

But because you have 2 unidentified display devices you'll either have to guess or know the device id. So i chose the latter.2.1

After it installs, you want to run and install 16.2.1 This installs your APU and the primary gpu.

Now restart

Install catylist if ya want, the 15.7.1.

Happy days

Wow, thanks Genukie. Finally after few days of hard work it finally worked, big THANKS. I have been trying to install all drivers and none of them fixed error code 43, but flashing GPU bios helped. I almost thought that by GPU broke. Thanks man.

AMD a10-4600M

Radeon HD 7970m 2gb

Radeon HD 7660G 2gb


Hi ,I am here from future  

I have another problem with the same driver since 2 year , and i think your solve could help me , could you record video about how to fix this problem ,please ? i will be thankful for you